Adobe Flash Player Not Detected In Firefox 60.0.1

I upgraded from Leap 42.3 to Leap 15.0 and since that time when I visit sites with Firefox 60.0.1 they are telling me that Adobe Flash Player is not installed even though it is.
If I go to this site: with Firefox, it tells me that I have Adobe installed.
But if I go, for instance, to the site informs me that I do not have Flash Player installed and so no music can be streamed…

In Firefox, under Plugins, it shows that Shockwave Flash 29.0.r0 is set to Always Activate.

Anyone has a solution to this problem?

Working fine here.

Check whether you have it installed :stuck_out_tongue:

When I first tried it with firefox quantum, it did not work. I was still running Leap 42.3 at that time (maybe two weeks ago). But I actually did not have flash installed. Instead, I was using “freshplayerplugin” and “flash-player-ppapi”. And that did not work. When I uninstalled “freshplayerplugin” and went with the real “flash-player” for firefox (the npapi version), it started working.

I’m guessing that’s probably your problem, too.

With the previous firefox (52.x-esr), the real “flash-player” did not work properly. It apparently bypassed “pulseaudio” with the effect that I could not use a flash app and also some other application using sound. Whichever one started first would block the other. So I switched to “freshplayerplugin”. Now with firefox quantum, the real “flash-player” does go through “pulseaudio” so my reason for using “freshplayerplugin” no longer applies.

The maintainers of the site, that still haven’t moved away from Flash, even though Adobe themselves told them so?

Where is the plugin located, is the path in FF’s search path. Did you try copying it to ~/.mozilla/plugins ?
More serious: did you try Chromium and the pepperflash stuff ?

I have to qualify that earlier reply. I went to the site you listed, and played some music from a classical channel.

However, I have firefox set to ask before activating flash, and it never asked. So it must be using something other than flash to play that music.

This site: does use flash, and it is working fine here (and asks me to activate each time). works fine with Ubuntu so what I did is to copy the Firefox profile from Ubuntu to openSUSE. Unfortunately, it still does not work.

YaST2 -> Software Management shows that flash-player-ppapi is installed. I think that I need to install flash-player-npapi. Would these instructions work fine?

That gives too many choices.

If you have the packman repo configured, then just install “flash-player” from packman.
If you don’t have packman repo configured, then do that first.

*** configure packman repo ***
Yast → Software Repositories
Click “Add” (near bottom left)
Select “Community Repositories”; click “Next”
Select “Packman Repository”
Click “OK”.
Follow your nose to complete the setup.

*** install flash ***
Yast → Software Management
Click “Search” (might already be selected)
Enter “Flash” into search box, and search
Select “flash-player”
If there is a conflict resolution popup, select the box to remove “freshplayerplugin” and then “Try Again”
Click “Accept”

and you should be set.

I probably gave more detail than needed, but you are relatively new to openSUSE, so why not.

Your firefox profile from ubuntu should be fine.

This is what I get by cliking on 1980s Hits:

No flash.

Try to install all needed packages:

But change the URLs to 15.0.

It shows that flash-player-ppapi is installed. I think that I need to find a way to install flash-player-npapi instead.

If you configured the packman repo, as described, the flash-player should now be available for installing with Yast software manager.

When you search for “flash” you will see “flash-player-ppapi”. Keep scrolling down. The display shows the installed packages first. And the available packages. The available packages are in alphabetical order, once you have scrolled past the uninstalled ones. Just check the box for “flash-player”.

When I do a search for “flash” in YaST2 it shows that I have “flash-player” and “flash-player-ppapi” installed. Before it also showed that I had “flash-player-plugin” installed but that has disappeared from the list.
In Firefox when I go to Add-ons → Plugins it no longer shows an entry for Shockwave Flash…

Here, Yast shows both “flash-player” and “flash-player-ppapi” as installed.

Firefox does show “Shockwave Flash” as installed.

Have you restarted firefox since making the changes?

Yes, I have restarted Firefox and the PC several times.
I must confess that the missing “Shockwave Flash” entry in Firefox is my fault… I went into YaST2 → Software Management and deleted the “flash-player”, “flash-player-ppapi” and “flash-player-plugin” entries. I was able to reinstall only the first two. The third one does not show up when searching for “flash”.
My intention was to delete and reinstall just like it is done in Windows when things do not work well…

I don’t recall that there was ever a “flash-player-plugin”. However there was (and still is) a “freshplayerplugin”. I suspect you may have confused the names. And “freshplayerplugin” worked for older versions of “firefox”, but not for the current version.

Yes, it is entirely possible that I am confusing “flash-player-plugin” with “freshplayerplugin”. In any case, in Firefox under Plugins the “Shockwave Flash” entry has disappeared and I am still unable to stream music at The site still says that I do not have Flash Player installed…

It is working here. So I’m not sure what is going wrong.


  1. In Yast software manager, find “firefox” (really “MozillaFirefox”). Right-click on that entry and select “Update unconditionally”. That should force a re-install.
  2. If that doesn’t solve the problem, then also do a forced re-install of flash-player.
  3. If you still have a problem, then create a new user account, and see if it works for that new user.

Actually, instead of a new user, run:

firefox -P

at a terminal (konsole or similar terminal application). That should allow you to create a completely new firefox profile, and switch to that profile. See if it works for that new profile. You can later switch back to the old profile with the same command (to start the firefox profile manager).

The unconditional update of Firefox did not bring any changes but the one for Flash Player did the trick! I can now access without it complaining that I do not have Flash Player installed – and the Shockwave Flash entry in Firefox’s Adds-On Manager → Plugins has reappeared!!
Thanks nrickert for your help.