Adobe Flash Player in OpenSuse 11.1 with AMD x64 not working

Hi everybody!

I just installed OpenSuse 11.1 on my AMD Athlon 64 box and I’m verifying that all applications run well. I am having problems with the Flash Player, which does not seem to work at all. Each time I load a page that contains flash stuff the browser tells me to download the plugin, but I’m quite sure that it is already installed…

me@home:~> zypper search flash
Loading repository data…
Reading installed packages…

S | Name | Summary | Type
i | flash-player | Adobe Fl-> | package
| flash-player | Adobe Fl-> | srcpackage
i | flash-player | flash-pl-> | patch
i | flash-plugin | Adobe Fl-> | package
i | libflashsupport | Addition-> | package
| libflashsupport | Addition-> | srcpackage
| libflashsupport-32bit | Addition-> | package
| libflashsupport-debuginfo | Addition-> | package
| libflashsupport-debuginfo-32bit | Addition-> | package
i | pullin-flash-player | Placehol-> | package
| pullin-flash-player | Placehol-> | srcpackage
| tvflash | Tool to → | package
| tvflash | Tool to → | srcpackage
| tvflash-debuginfo | Tool to → | package
| tvflash-debugsource | Tool to → | package

me@home:~> zypper info flash-player
Loading repository data…
Reading installed packages…

Repository: @System
Name: flash-player
Arch: i586
Vendor: openSUSE
Installed: Yes
Status: up-to-date
Installed Size: 18,7 M
Summary: Adobe Flash PlugIn and standalone Player
This package contains Adobe’s Flash Plugin for the supported Web
browsers in addition to a standalone flash player application.

me@home:~> zypper lr

| Alias | Name | Enabled | Refresh

1 | repo | NVIDIA Repository | Yes | Yes
2 | repo-debug | openSUSE-11.1-Debug | Yes | Yes
3 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | No
4 | repo-oss | openSUSE-11.1-Oss | Yes | No
5 | repo-source | openSUSE-11.1-Source | Yes | Yes
6 | repo-update | openSUSE-11.1-Update | Yes | No
7 | repo_1 | VideoLan Repository | Yes | Yes
8 | repo_2 | Packman Repository | Yes | Yes
9 | repo_3 | openSUSE Education | Yes | Yes

The only strange thing that I see is that it seems that the flash player plugin I have installed corresponds to the i586 architecture, which is not the correct one. Is this the problem ? Where can I get the x64 based plugin ? What should I do to get flash work on firefox ?

Thanks a lot for your help,


Did you add the packman repository? it’s working for me very well

Yes, as you may see in the output of “zypper -lr” you can see that I have the Packman repository added to my list…



From a su terminal

zypper in flash-player

IMHO having Videolan and Packman both active is just begging for trouble. I recommend you remove videolan ASAP from your active repos list. And I recommend you replace all videolan packaged apps with Packman packaged apps (with exception of libdvdcss)

Why do you have source and debug as repos? Is there something specific you are trying to do? Unless you are a developer, or unless you are a user with a very specific purpose, then IMHO you should remove those. What immediate benefit are they bringing to you? Don’t just add a repos blindly.

Reference the “Education” repos, I recommend you put that to inactive. You can make it active BRIEFLY if it has a download you need. Else you could install an app from there, which might conflict with an app packaged by Novell/SuSE-GmbH, and you will have no idea that has happened.

Blindly adding repositories with out understanding the consequence has to be one of the bigger mistakes that new users to openSUSE Linux make.

Thanks a lot for your help. I did not know all these details about the repositories. I’ll try your recommendations this afternoon when I come back home.



Hi everybody!

It’s me again! I just tried all the recommendations you mentioned above.

  1. I removed videolan repository and removed all packages from my system whose vendor was videolan.
  2. I’m currently only using the following repositories:

me@home:~> zypper lr

| Alias | Name | Enabled | Refresh

1 | repo | NVIDIA Repository | Yes | Yes
2 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | No
3 | repo-oss | openSUSE-11.1-Oss | Yes | No
4 | repo-update | openSUSE-11.1-Update | Yes | Yes
5 | repo_2 | Packman Repository | Yes | Yes
6 | repo_3 | openSUSE Education | No | Yes

I installed the flash player using

zypper install flash-player

But flash still does not work. Keep in mind that I have an x64 based architecture. I have opensuse on an i386 and the flash-player package works without problems. However, on the x64 architecture the flash-player package blocks the system so as that I have to reboot the system (but turning off the system). I even cannot change to text mode to try to kill firefox.

As I told you, it seems that when I do

zypper install flash-player

the i586 version is installed. I tried manually do find the flash package in the packman repository but I only found it in the i586 based architecture, but not the x64 one.

Currently I’m using ‘gnash’ but it does not support some of the funcionalities flash has.

Has anyone suceeded to install flash on an x64 based architecture ? Can you please tell me the output of the following instructions on your x64 based system ?

zypper search flash | grep ^i
zypper info zypper search flash | grep ^i | awk '{print $3}'



Do you have nspluginwrapper installed

zypper in nspluginwrapper

Up until last October, the Flash plugin was only available for x86 (32-bit) systems. For 64-bit systems, this usually meant that in order to run Flash on websites, one would need to use a 32-bit browser, or a 64-bit browser with a 32-bit wrapper.

From what I recall, the flash plugin available in the OpenSUSE repositories did most of the dirty work to get it to work on a 64-bit system. The problem was, these somewhat hacked solutions could cause system instability, and would occasionally not work.

Last October, Adobe released a 64-bit alpha version of the plugin that works natively in 64-bit browsers without the need for any wrappers. You can download the latest release of the plugin here:
Adobe Labs - Downloads: Flash Player 10

Even though this is an alpha version of the plugin, I personally haven’t had any more or less problems with it than I have had with the plugin in the past.

If you want to use this version:

  1. Remove the 32-bit version installed from the repos.
  2. Download the file from the link above.
  3. Extract the “” file
  4. As root, copy it to /usr/lib64/browser-plugins.
  5. Restart your browsers.

Suse is using the 32bit version you have 2 ways of doing it you can check with nspluginwrapper and load the 32bit. Or change firefox to 32bit.

I’ve confirmed what you found non-oss seems to be the repo with it on but only i586. There is a alpha 64bit which works as well as any of the flash stuff does on linux. Surprised it is not on the build service though.

PluginDoc: Linux (x86_64)

I can’t exactly remember how to list what nspluginwrapper is using but I suspect if about:plugins isn’t showing you need to add it as the above doc.

Hi everybody!

Thanks a lot for your help. By installing the nspluginwrapper package the flash-player has begun to work properly!



We got you sorted in the end!

Thank you guys.
You guys are a real help.
I was having the same problem. and could solve it by reading the thread.

@ srschifano and FeatherMonkey - Many thanks for this pointer; I’ve got the alpha installed now. Nice to be able to see Flash content at last!

I just installed Suse 11.4 and downloaded the flashplayer_square_p2_64bit_linux_092710.tar. Once that was installed in /usr/lib64/browser-plugins, 64 bit Firefox ran Flash fine! Thanks for the proper directory to install it in!!!