Adobe AIR on 13.1

Hi guys, I wonder if any of you have any experience running applications which use Adobe Air? I have searched about, and installed/uninstalled using various ‘methods’ including advice from Adobe’s own useless website, openSuse SDB, and other blogs. I have also, of course, installed it via the repo. No matter how I install, when I try to install an app afterwards, AIR accepts the instruction to install it, ask me for a directory (default is /opt), and then gives a screen with the new app’s title and it just stops there. I have tried different apps, to eliminate the possibility that it is the new app causing the problems.
Just by chance, I happened to have a test install of Mint16 lying about, I tried it on there and the install went flawlessly. I am aware that Adobe no longer ‘supports’ AIR for linux. I must confess that I loathe Adobe (far more than I do Microsoft!)

Doubly frustrating, is that I cannot find any way of finding where the problems lie, If I launch the Adobe app installer from CLI, no info is given, aside from a GTKwarning:

linux-wfk4:~ # Adobe\ AIR\ Application\ Installer 

(The spaces in the command, I think show just how committed Adobe are to helping linux users)

(Adobe AIR Application Installer:11454): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",

I have tried as root and as normal user.

It launches a file manager screen, for me to choose the .air app I want:

Then a brief ‘preparing to install’ GUI…
Then an install confirmation screen…
Then a confirm directory screen (I have tried install to directories other than the default, suggested /opt
Then it hangs, like this:
No info or error message is shown in the terminal.

Here are some of the sites I have consulted…

These sites advise the installation of various libraries etc and linking them to various places. How can I tell what it is that AIR is lacking? Does it log errors anywhere? Is there a debug mode or command options that I have somehow missed?

Just a cheeky bump, if anyone HAS used air with success OR failure, could you please notify me here… Thanks!

On 02/25/2014 05:26 AM, wakou wrote:
> Just a cheeky bump, if anyone HAS used air with success OR failure,
> could you please notify me here… Thanks!

I ran it in WINE, worked fine but I only tried it with one application
(minerva) so not sure how it will go for you.

Bring the Penguins Back!
openSUSE 13.1
KDE 4.11.4

Thanks Alan, I have it running in WINE, and working OK but it seems to be something of a resource hog. I was hoping it would work better when running natively in linux. As I say, it works fine on a Mint16 install.

Hmm. So I am the only one who needs this accursed Adobe Bloatware bugfest on my machine. It is strange that Mint runs it with no complaint, and openSuse hangs.


try install package libXt6-32bit :slight_smile:

WooHoo! Something worked, and your tip was the last thing I did, so TY TY TY! :slight_smile:

So, to recap. It can work. It is, like all Adobe stuff an immense PITA, but it can be done. Thanks again to “mitdac”, I would never in one (or two) million years have found out why to install that paricular lib. I intend to install a fresh copy of 13.1 in a VM and see if I can get it working from scratch, as my current install has had so many attempts over the last six months or so that I do not know what I did, and what is or is not needed. My apologies to mitdac for not thanking you sooner, I did not get notification of your post from this forum… I was doing a google search for this problem and came upon my own thread, and only then noticed your post.

In 13.2 it does not work.
Adobe aIr installation ask to install kwallet o gnome keyring in order to continue… I have both installed


You might want to write the owners of any AIR app whether they still support it since I understood Adobe deprecated the technology quite a long time ago. Maybe they’ve ported the app to another technology.