Adjusting fan speed

Hi community,

I’m quite new in the linux world and I just got openSUSE Tumbleweed with KDE installed.
I absolutely love it, you guys are doing a great work.

I’m using a Lenovo P14s Gen2 (Intel version with Nvidia T500) and everything worked out of the box.
(That wasn’t the case with Ubuntu and Linux Mint; MX Linux worked quite well but had some other issues.)

However, the fan of the notebook is driving me crazy. Obviously not a linux problem, but Lenovo did some really bad work here.
I’m aiming to adjust the fan speed with thinkfan, but i wouldn’t start.

I’m getting either the ERROR: /sys/class/hwmon/hwmon0/temp1_input: No such file or director
or ERROR: Error scanning /sys/devices/pci0000:00/0000:00:03.1/0000:27:00.0/hwmon: No such file or directory

I would also go for another software to control the fan speed, if there is anything reliable.

Operating System: openSUSE Tumbleweed 20220226
KDE Plasma Version: 5.24.2
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.2
Kernel Version: 5.16.10-1-default (64-bit)
Graphics Platform: X11
Processors: 8 × 11th Gen Intel® Core™ i7-1165G7 @ 2.80GHz
Memory: 31,1 GiB of RAM
Graphics Processor: Mesa Intel® Xe Graphics

I’d very much appreciate your help!
I’m trying to switch to linux already for quite some time to finally emancipate from windows, but I’m always getting thrown back by issues like these. This time I really want to stay with linux.

Thank you very much!

Although I’m not able to help you with your current issue, I think it’s useful for you to know that “we” are not the ones working on openSUSE. We here are users like yourself, nothing more. There may be some here who are in fact woking on openSUSE, but mostly, we’re just like you, users of a really good linux distribution that we love.

Hope someone will be able to help you here. :smile:

I don’t have a Lenovo laptop, but as I understand it thinkfan depends on correctly detecting the system’s sensors. Configuring thinkfan is described for fedora here: - the gist instructs that configuring thinkfan requires lm-sensors sensors-detect to be used to find out the correct sensors and kernel modules to load. Some SUSE Lm-sensors/sensors-detect documentation is also present here:

lm_sensors was installed and the sensors command give me a reasonable output.
I did the config according to this post:
It’s similar like the fedora config you were referring to, but using the structured YAML syntax.](

In this s-tui issue I found, that it’s probably a kernel problem.

When I look into the folder i get that there’s indeed no temp1_input.

sudo ls /sys/class/hwmon/hwmon0/
device in0_input name power subsystem uevent

I searched for an older kernel version in Yast - preferrably 5.2, since they claim it was working in 5.2, but I didn’t succeed. There’s no older version than 5.16 in Yast, or I am too stupid.
At this point I find myself again stuck.

The writer of the blogpost in the first link says:

Although, if you’re not very fond of Debian, I can recommend installing Fedora 35 on your laptop. I’m running it right now on my P14s and it works great, I don’t even use thinkfan anymore, since the fan is quiet out of the box.

At least it would be a distro that I haven’t tried out yet lol!

The issue you refer to seems quite old. I would of thought it would have been sorted by now (Lenovo being quite popular).

The arch documentation is usually pretty good:

The arch doc seems to state there is a thinkfan non-lm-sensors option which makes available /proc/acpi/ibm/fan or /proc/acpi/ibm/thermal. I often consult the arch docs even though I use Tumbleweed (arch being too labour intensive for my tastes).

In my own non-Lenovo non-noteboot desktop I’ve just fallen back to manually configured fan speed steps defined in the BIOS and only use the Linux sensors for monitoring.

Probably helpful: fan cooler at maximum speed no matter what cpu load is

Create bug report.
Select laptop with official Linux support.

I tired that, still didn’t work for me.

That’s why I bought a Lenovo laptop, because they usually have official Linux support.

I got tired of trying to fix it and nothing would work.
So I tried a handful of distros in live mode and installed Ubuntu Studio 21.10
The fan is now quite even without thinkfan.

Here I set a fan speed curve in UEFI, as sensors show fan speed zero. But that’s on AMD desktop systems.

Have you checked if it is possible to regulate the fan speed in the BIOS?

Could be, you have to enable the fancontrol to start at boot in yast2-services-manager.

Same here. New Intel P14s Gen 2 with Leap 15.3. Fan just runs and runs. /usr/bin/sensors show cores at 40-50 deg and fan constantly at 4K.

Problem goes away if I boot into Windows 10 or Fedora 35.

Currently running Fedora 35 KDE Spin. It’s not pretty (It’s KDE but all of the theme choices seem like they were made by Gnome users) but the fan noise was driving me crazy.

Does pwmconfig work at all?

I trashed my install so I can’t cut and paste the terminal output but my recollection was that it said there were no PWM-controllable devices available (or maybe no user-configurable PWM devices).

[Insult to injury, two other long-standing HW problems have gone away with the switch to Fedora – display behavior when docked to a Lenovo mechanical dock and audio over HDMI. I wonder if RH/Fedora just spend more time on Lenovo hardware.]