Additional categories support in suse applications menu

Hi all, is it a simple way to get full support for the additional xdg menu categories as specified in freedestop specification: https://standards.freedesktop.org/menu-spec/latest/apas02.html

KDE’s menu editor is better than nothing, but I just don’t have the time to edit everything when it is a specification for that. The issue is than almost no one sigle desktop follow that specification, it just doesn’t work when it should work.

I try to install fvwm-xdg-menu from https://github.com/domichel/fvwm-xdg-menu (yes, even plain old fvwm can follow that specification!lol!), but it doesn’t work in kde’s application menu. Instead of editing by hand the whole menu configuration, is it something simple I can do to make these f. additional freedesktop menu categories to work?:wink:

Hi
Follow these ones. don’t for get to run update-desktop-database;
https://en.opensuse.org/openSUSE:Packaging_desktop_menu_categories

Thanks, It is based on freedesktop specification I am talking about in my first post. If I read /etc/xdg/menus/applications.menu, it seam to follow that norm, but /etc/xdg/menus/applications.menu.kde4 doesn’t follow the additional categories spec, and the result in kde is erratic. In the games main cat, I get the wanted subcategories, but I get only 1 main category for audio, video and audio/video with everything in this main category.

Worst, If I install fvwm-xdg-menu from the above link, and put a symlink /etc/xdg/menus/applications-merged/fvwm-applications.menu -> /etc/xdg/menus/fvwm-applications.menu, this should include this menu into kde’s menu, but I cannot even test it because kde get confused and take forever to start.

Hi
Shouldn’t you be following Plasma5 things (I don’t use it… gnome here) instead of kde4?

/etc/xdg/menus/applications.menu.kde4 is not used at all.
It is KDE’s upstream menu structure (from KDE4 times), that got renamed by openSUSE to not conflict with /etc/xdg/menus/applications.menu (from desktop-data-openSUSE) on a file level.

Actually all desktops should use /etc/xdg/menus/applications.menu by default, unless they are configured or patched to do otherwise.
GNOME e.g. uses /etc/xdg/menus/gnome-applications.menu instead, and KF5 (and therefore Plasma5) uses /etc/xdg/menus/kf5-applications.menu.

The files themselves follows the same standards though.

So if you want to change KDE’s (i.e. Plasma5’s in Leap 42.2) menu structure, you have to modify /etc/xdg/menus/kf5-applications.menu accordingly.
You can override it per user in ~/.config/ though, to prevent it getting changed by updates.

To make a symlink in /etc/xdg/menu/applications-merged should work with all desktops.

I try to make a symlink

ln -s /etc/xdg/menus/fvwm-applications.menu ~/.config/menus/applications-merged/fvwm-applications.menu

but I get the same result, plasma just go wild and run forever without showing the application menu. Is is in fact a very simple way to hang kde. It is sad because it should just work.

I solved that issue by managing to use nm-applet in fvwm alongside with the fvwm-xdg-menu above. That issue is very important to me because that laptop will be used by a dozen of people that know almost nothing about gnu/linux and its numerous software. I know well fvwm, so it is easier to me to configure it to my taste and for an easy use, than to configure something that should work out of the box and doesn’t work as expected. BTW, Thomas Adam’s fvwm config is simple but great.

My mistake, fvwm in opensuse is using the default opensuse application menu, which have a correct support of the additional freedesktop categories.

That said, this issue is very important to me, because the laptop I am installing will be used by a dozen a linux newbies which know almost nothing about gnu/linux and its numerous software. Kde’s support of the additional freedesktop categories is a shame which make it almost unusable to such peoples. And last but not least, fvwm have another advantage for me in that case: it have no accessible preference and they will hopefully not screw it up.

You have this wrong.
KDE’s support is quite correct AFAIK, and they are one of the main contributors to freedesktop.org.

That openSUSE doesn’t use applications.menu for Plasma5 by default any more was a conscious decision by the openSUSE KDE team a year ago (personally I prefer the old way though).
GNOME does similar (since years, hence the decision of the KDE team), they use gnome-applications.menu.

If you do read the xdg specs, you’ll have to agree that this is in line though, I think.