Adding Network Connections in KDE Network Manager

Hi everyone,

This is the first time I post in forum (sorry for poor English). I recently install OpenSUSE 121.1. I really like it a lot. However, when I try to connect to Internet via wireless, error occured. I already checked Wireless forum, there is no problem with my network devices (OSuses detected and installed). So, I open KDE Netowk Manager to manage connections and see only VPN options is configurable (other tabs can not be choosed).

I read opensuse reference book 12.1 and here what I found:

Note: Availability ooptions

Depending on your system setup, you may not be be allowed to configure connections. In a secured connections, some options may be locked or require root permissions. Ask your system administrator for details.

Since I am the owner (adminstartor) and don’t have any idea what to do, I ask for help. Any idea how to fix this problem is apprecatiated. Thank you from new noob.

Open a terminal and post the output of:

/sbin/lspci -nnk | grep -iA2 net

When you click the Network Manager in the Panel - Can you toggle the Enable Wireless and Enable Networking

Along with Carl’s advice, the following command can assist us with identifying your detected wifi hardware

/usr/sbin/hwinfo --wlan

If you can’t enable wireless with the network manager, it is often due to drivers and/or firmware.

Here is the output of /sbin/lspci -nnk | grep -iA2 net:

02:00.0 Ethernet controller [0200]: Atheros Communications AR8121/AR8113/AR8114 Gigabit or Fast Ethernet [1969:1026] (rev b0)
Subsystem: Acer Incorporated [ALI] Device [1025:0214]
Kernel driver in use: ATL1E
03:00.0 Network controller [0280]: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) [168c:002a] (rev 01)
Subsystem: Foxconn International, Inc. Device [105b:e01f]
Kernel driver in use: ath9k

Output of /usr/bin/hwinfo --wlan

21: PCI 300.0: 0282 WLAN controller
[Created at pci.318]
Unique ID: y9sn.lGgwO9_JimF
Parent ID: qTvu.dndKntsun_4
SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:03:00.0
SysFS BusID: 0000:03:00.0
Hardware Class: network
Model: “Atheros AR928X Wireless Network Adapter (PCI-Express)”
Vendor: pci 0x168c “Atheros Communications Inc.”
Device: pci 0x002a “AR928X Wireless Network Adapter (PCI-Express)”
SubVendor: pci 0x105b “Foxconn International, Inc.”
SubDevice: pci 0xe01f
Revision: 0x01
Driver: “ath9k”
Driver Modules: “ath9k”
Device File: wlan0
Features: WLAN
Memory Range: 0xf0600000-0xf060ffff (rw,non-prefetchable)
IRQ: 17 (no events)
HW Address: 00:26:5e:6a:ee:89
Link detected: no
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: “pci:v0000168Cd0000002Asv0000105Bsd0000E01Fbc02sc80i00”
Driver Info #0:
Driver Status: ath9k is active
Driver Activation Cmd: “modprobe ath9k”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #9 (PCI bridge)

caf4926 quetion:
When you click the Network Manager in the Panel - Can you toggle the Enable Wireless and Enable Networking -> Only Enable Networrkig checkbox available.

Well, maybe I missed something from Wireless forum sticky note. I followed through step 1-4 and succeded, but failed to ping Samba - opening windows to a wider world (step 5).

Thank you for the reply caf4926 and deano_ferarri.

I’m not familiar with your device personally but it looks like the driver is loaded.
Looking in the HCL is not helping me much as it’s not up to date (11.1) is the last entry and it recommends compat-wireless, which for 12.1 would be this:
http://software.opensuse.org/ymp/driver:wireless/openSUSE_12.1/compat-wireless.ymp?base=openSUSE%3A12.1&query=compat-wireless

BUT, I wouldn’t do that unless @lwfinger suggests it

Can you tell us, did you install via a Live CD or DVD
If you used a Live CD did the wireless work there?

I installed via DVD.
Now I try to configure networking using fiup. The intesting thing is it needs smpppd package, however my (DVD) installation didn’t included the smpppd installed. I will install the package and post the result in this forum.

Thank you.

configuring wireless with ifup is tricky and I don’t recommend it.

Hopefully Larry @lwfinger will post here soon

The wireless device is recognised by the kernel (ath9k driver), so the next step is to see if it is disabled for some reason. (Some laptops have a hardware switch to control the wireless hardware.)

You may need to install the rfkill package first

sudo zypper in rfkill

Then see if the wireless interface is blocked

/usr/sbin/rfkill list

If you find it is blocked, then you can issue something like this

sudo /usr/sbin/rfkill unblock 0

*Replace the interface number with whatever is applicable for your system.

On 11/01/2012 02:26 AM, caf4926 wrote:
>
> configuring wireless with ifup is tricky and I don’t recommend it.
>
> Hopefully Larry @lwfinger will post here soon

I agree. Even experts have trouble getting all the parts of ifup correct. At
least I do. If I understand your posting correctly, You are able to ping your
router and ping the network by IP, but pinging by name fails. If that is
correct, the failure is in DNS. To verify, please post the output of the
following commands (using NetworkManager):


/usr/sbin/iwconfig
sudo /usr/sbin/iwlist scan
/sbin/route -n
cat /etc/resolv.conf | grep -v \#

Please place all computer output inside code tags the way I did the above. That
feature is found in the Advanced Edit options. Include the command you entered
up to, and including, the following prompt.