adding manual ipv6 address openSuSE 11


I’m having trouble configuring a manual IPv6 address in opensuse 11.0. I can add it to the interface correctly at the command line through ifconfig and at that point it works fine:


ifconfig eth1 add <IPv6 addr>/64

However, I can’t get it to ‘stick’ after rebooting the machine. I’ve edited etc/sysconfig/network/ifcfg-eth1 to include a the following line:

IPADDR_1=’<IPv6 addr>/64’

The IPv6 address even shows up in YAST, but nothing works until I manually add it through ifconfig.

Any suggestions on properly configuring a manual IPv6 address in openSuSE 11?



Is NetworkManager running? Try disabling it in Network Settings.

Network Manager is running. However, I just worked around it by writing a short script to assign the IPv6 address to the interface when booting.