Adding hard drive, moving windoze to hard drive and setting up dual boot with Leap 15.3 on SSD

I am setting up a new (to me) workstation which is to be used primarily as windows fallback for some accounting software but will eventually be used to run Leap 15.3.

The machine presently has an SSD with windows 10 installed.

I have added a 1TB SATA drive and am now planning the captioned dual boot installations.

The order I am planning is to install windows again on part of the hard drive and have it working as a normal windows boot. Once windows working correctly, install Leap 15.3 on SSD with possibly multimedia data on balance of hard drive.

I am a bit concerned about losing the windows installation although I understand it is locked to the machine in the cloud so re-installation is easy without need for keys.

Should I disconnect the SSD in order to do the windows installation on hard drive?

Does this seem like a good plan and are there any catches?


Is it NVMe or SATA drive?

Should I disconnect the SSD in order to do the windows installation on hard drive?

And the reason you are asking it on Linux forum instead of Windows?

I disconnected my NVME and SSD, popped in another SSD and did the windows install (pre configured the device while still in openSUSE)

sda           8:0    0 223.6G  0 disk 
└─sda1        8:1    0 223.6G  0 part /stuff
sdb           8:16   0 111.8G  0 disk 
├─sdb1        8:17   0   260M  0 part [winX boot type ef00]
├─sdb2        8:18   0    16M  0 part  [WinX Reserved type 0c01]
└─sdb3        8:19   0 111.5G  0 part [WinX OS]
sdc           8:32   1 117.7G  0 disk 
└─sdc1        8:33   1 117.7G  0 part /run/media/cronopete/56428fe9-f28d-47b5-8c85-764d0645cedc
nvme0n1     259:0    0 476.9G  0 disk 
├─nvme0n1p1 259:1    0   248M  0 part /boot/efi
├─nvme0n1p2 259:2    0    56G  0 part /
├─nvme0n1p3 259:3    0    19G  0 part /home
├─nvme0n1p4 259:4    0    14G  0 part /opt
├─nvme0n1p5 259:5    0    14G  0 part /usr/local
├─nvme0n1p6 259:6    0   139G  0 part /data
├─nvme0n1p7 259:7    0   139G  0 part /var/lib/docker
├─nvme0n1p8 259:8    0    94G  0 part /var/lib/libvirt
└─nvme0n1p9 259:9    0   1.7G  0 part [SWAP]

After install was completed, updated rebooted etc [as windows seem to do] popped the NVME back in connected the SATA drives and then (since it’s a HP system) pressed F9 and rebooted into Tumbleweed, used efibootmgr to set openSUSE Tumbleweed as the default and good to go… Now I don’t display grub as want the system to boot direct. if decide want to use WinX, then just use efibootmgr -n option and reboot. So in YaST bootloader I also disable the probe foreign os…

A SATA drive and I am intending to install dual boot with Leap 15.3. I believe this is the correct forum.

Hi Malcolm, that looks neat. Not used the HP in anger yet, just feeling my way. No NVMe on the HP yet as all funds gone on the IBM machines, so just SSD and SATA. I am not at all familiar with windows install so have just taken an image from the SSD and will put on the SATA once image has been built. I like the F9 and efibootmgr so will try later.

Sure, except your question was

Should I disconnect the SSD [with Windows] in order to do the windows installation on hard drive?
You are of course free to ask anywhere you like, but you have much better chances to get good answers about Windows installation on Windows forums.

I have transferred the W10 OS to the hard drive and am now installing Leap 15.3 on the SSD.

The installation did present me with a problem I didn’t expect. I will end up with two efi partitions. Don’t think that should happen. I am allowing the Leap network installation to proceed and will see what I get in the morning but I think there will be a problem to sort out, possibly needing to use live distro!!!

Yes, I run with two efi partitions… one on the Windows HDD, one on the NVME, I want them separate :wink: Then it’s a matter of specifying the disk it’s on when using efibootmgr, but os-prober also takes care of it…

I do pretty much as malcolm says in my two dual boot desktops, except that I set grub with a short timeout (4 or 5 secs) to boot openSUSE, else I can select w10 from it.
I also have two efi partitions, where I copied the openSUSE efi to the windows one. This way I can boot from either partition. I did this after wrongly erasing the only EFI partition in one of the desktops.

Windows appears in grub twice, one for the sata and another for the nvme efi partitions. Both work.

I agree that the easiest way is installing windows first and then openSUSE, in different drives.
A couple of times, after a w10 update, the system would boot directly to it, bypassing grub. In these occasions I booted opensuse from UEFI BIOS and ran the bootloader to restore grub.

Just don’t forget to disable fastboot in windows if you mount any of its partitions on LEAP.

The Windows installer works best with a single drive. Remove all other drives before starting install.

I installed Windows instances on 3 different machines. One install failed, but succeeded when removing all other drives.

Very important or you will very likely see you Win10 installation self destruct.

All good this morning so many thanks to all for the advice.

In this case I disconnected the SSD while windows was being installed because it was easy to do and then plugged in the SSD to install Leap 15.3. This worked without a hitch and when I boot now I get the grub boot screen with an option to select windows included. All working but a couple of questions…

Removing the SSD was a simple expedient but what is correct solution if I only have one drive and cannot unplug anything?

I cannot recall exactly what I did but on my older system nothing was unplugged and couldn’t be, as all the disks are on a large hardware RAID. I still have the same boot capability but more importantly there is only one efi partition. It seems the Leap installer sorts it all out when only one efi partition is installed.

If I had not created the new efi partition during the Leap installation would the prober have sorted this out. I ask because I had been using the expert partitioner and was not sure which partitions to include and which not. If I had wiped the SSD and then let the installer do the work I wonder if it would have used the existing efi partition?

Only me rambling on now as I have what I need, but interesting having two efi partitions and one grub…

After install you can always check what it will find with the command os-prober.

/dev/sdb1@/efi/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi

Yes, it would have installed on the existing efi partition if not specifically pointed to, it should have gleaned that information and shown you during the partitioning phase of the install…

Well for better or for worse the windows replacement has been put in position and is now only accessible from my KVM.
It has been an interesting experience and I hope the thread has been useful to others.
Many thanks to Malcolm and to all who have contributed.

Hi Malcolm, just a footnote to your earlier posts concerning two efi partitions.

I am not sure how, with dual boot as presently installed, WoL actually works. I set up the WoL service as suggested earlier by Henk on the openSUSE system and shut it down.

Once woken up by my signal, the machine booted to windows without any intermediate grub and in fact this machine always starts in this way.

If I want to boot to Leap 15.3 I have to wait for machine, once woken, to complete the boot and then once running I have to ask it to reboot and then F9 when starting for the second time so I may select the openSUSE partition.

Not the most elegant process. I think I would prefer it if the initial boot is to the grub system, from which I can then select either windows or openSUSE. This saves time and trouble. How may I reconfigure to achieve this? I suspect a new installation but exactly how should I configure the partitioning to get this right?

Can you post the output from;


All you need to do is change the order… I suspect the Windows Boot Manager is first.

For example, my BootOrder was 0000 (WinX) and openSUSE 000A;

BootOrder: 0000,000A


efibootmgr -o 000A,0000

Changed it to;

BootOrder: 000A,0000

Hi Malcolm, here is what I have at present:-

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 001E,0000,000F,0012,0011,000E,0024,0010,001D,0002,0003,0004,0005,0006,0007,0008,0009,000A,000B,000C,000D,0013,0014,0015,0016,0017,0018,0019,001A,001B,001C
Boot0000* opensuse
Boot0002  Startup Menu
Boot0003  System Information
Boot0004  Bios Setup
Boot0005  3rd Party Option ROM Management
Boot0006  System Diagnostics
Boot0007  System Diagnostics
Boot0008  System Diagnostics
Boot0009  System Diagnostics
Boot000A  Boot Menu
Boot000B  Network Boot
Boot000C  HP Recovery
Boot000D  Startup Menu
Boot000E* IBA GE Slot 00C8 v1550
Boot000F* hp HLDS DVDRW GUD1N 
Boot0010* hp HLDS DVDRW GUD1N 
Boot0011* WD1003FBYX-23 43W7629 42C0401IBM 
Boot0012  USB:  
Boot0013  System Information
Boot0014  Bios Setup
Boot0015  3rd Party Option ROM Management
Boot0016  System Diagnostics
Boot0017  System Diagnostics
Boot0018  System Diagnostics
Boot0019  System Diagnostics
Boot001A  Boot Menu
Boot001B  Network Boot
Boot001C  HP Recovery
Boot001D* Samsung SSD 860 PRO 256GB 
Boot001E* Windows Boot Manager
Boot0024  USB:  

No idea what I am looking at or where I am “looking” from. It did occur to me that the F9 HP boot had a certain order to it which had openSUSE after Windows. I have taken a stab by just swapping the first two numbers and leaving the rest as is. Will try it now.

That did it. I assume the numbers with asterix are those which appear in the F9 boot order list.
Anyhow it worked as you advised and once openSUSE has booted, I have a choice because the boot manager gives me a choice which windows doesn’t.
I may need to extend the menu wait screen, where do I do that please.
Meanwhile setting up printers and all the housekeeping tasks I had forgotten existed!

You mean in GRUB? If so, via YaST Bootloader on the far right tab…

Almost ready to swap servers. Only one thing. Because my server will not boot from NVMe I have used a USB stick which remains permanently in the machine. The USB I used was one that was available at the time but is much bigger and more expensive than is required. I want to use a smaller and more suitable USB stick for the /boot/ and /boot/efi components but there may be other system components on the stick. Trouble is I cannot use a normal clone app because the new USB stick is much smaller.
How do I solve this please?