Adding advanced httpheader information

I have a new server with open suse 11.1 installed and plesk 9.2.1. We have an older plesk box that is a windows box. When we would create a new client we would have a subdomain setup in the windows box for instance com2.mycompany.com and we would point our DNS and give the customer login information etc to set up their site until it would go live.

When the site was ready to go live, we would goto the server and IIS and click on propertied and then click advanced and add all the http headers so the site would come up correctly. So for instance we would add com2.com com2.com -provides Solutions ! and would goto the appropriate folder even though technically the folder would be com2.mycompany.com. does anyone know how to arrange this? I am new to open suse so great detail would be appreciated.

Thanks for all the help for this awesome product. Also on a side note…I have two issue, when it reboots it gets stuck at the select for normal boot and safe boot which I need to fix and also for some reason after a reboot I have to go into connection and edit and then apply and save for the network to come up again.

tomtom98 wrote:

> I have a new server with open suse 11.1 installed and plesk 9.2.1. We
> have an older plesk box that is a windows box. When we would create a
> new client we would have a subdomain setup in the windows box for
> instance com2.mycompany.com and we would point our DNS and give the
> customer login information etc to set up their site until it would go
> live.
>
> When the site was ready to go live, we would goto the server and IIS
> and click on propertied and then click advanced and add all the http
> headers so the site would come up correctly. So for instance we would
> add com2.comcom2.com -provides Solutions !’ (http://www.com2.com) and
> would goto the appropriate folder even though technically the folder
> would be com2.mycompany.com. does anyone know how to arrange this? I
> am new to open suse so great detail would be appreciated.

Under Apache2 web server there is a “ServerAlias” directive that may help
you to get this:

http://httpd.apache.org/docs/2.0/mod/core.html#serveralias

> Thanks for all the help for this awesome product. Also on a side
> note…I have two issue, when it reboots it gets stuck at the select
> for normal boot and safe boot which I need to fix

Can you please elaborate this a bit? Are you saying that you are unable to
boot by selecting the standard boot menu entry? :-?

> and also for some
> reason after a reboot I have to go into connection and edit and then
> apply and save for the network to come up again.

Give us more info about your connection settings.

If using opensuse as server with a wired connection, I would suggest you to
use a network setup with “traditional method (ifup)” instead of
networkmanager.

Greetings,


Camaleón

[QUOTE=Camale�n;2008848]tomtom98 wrote:

> I have a new server with open suse 11.1 installed and plesk 9.2.1. We
> have an older plesk box that is a windows box. When we would create a
> new client we would have a subdomain setup in the windows box for
> instance com2.mycompany.com and we would point our DNS and give the
> customer login information etc to set up their site until it would go
> live.
>
> When the site was ready to go live, we would goto the server and IIS
> and click on propertied and then click advanced and add all the http
> headers so the site would come up correctly. So for instance we would
> add com2.comcom2.com -provides Solutions !’ (com2.com -provides Solutions !) and
> would goto the appropriate folder even though technically the folder
> would be com2.mycompany.com. does anyone know how to arrange this? I
> am new to open suse so great detail would be appreciated.

Under Apache2 web server there is a “ServerAlias” directive that may help
you to get this:

core - Apache HTTP Server

> Thanks for all the help for this awesome product. Also on a side
> note…I have two issue, when it reboots it gets stuck at the select
> for normal boot and safe boot which I need to fix

Can you please elaborate this a bit? Are you saying that you are unable to
boot by selecting the standard boot menu entry? :-?

> and also for some
> reason after a reboot I have to go into connection and edit and then
> apply and save for the network to come up again.

Give us more info about your connection settings.

If using opensuse as server with a wired connection, I would suggest you to
use a network setup with “traditional method (ifup)” instead of
networkmanager.

Greetings,


Camale�n[/QUOTE]

Can you please elaborate this a bit? Are you saying that you are unable to
boot by selecting the standard boot menu entry? :-?

Actually what I mean is when I reboot I get a screen that makes me literally hit enter to load opensuse or in safe mode. I have to go an hook up a monitor reboot and then hit enter to boot…sort of like a dualboot option with windows but no countdown

tomtom98 wrote:

> Actually what I mean is when I reboot I get a screen that makes me
> literally hit enter to load opensuse or in safe mode. I have to go an
> hook up a monitor reboot and then hit enter to boot…sort of like a
> dualboot option with windows but no countdown

It seems you are describing the commom Grub menu. But it has to be a
countdown that makes the system boots automatically the default entry if no
user input.

Put here the output of the command “cat /boot/grub/menu.lst” so we can take
a look.

Greetings,


Camaleón