Adding a new Sata drive to system


I’m new to Linux and this might sound like a stupid question so please bear with me.

I have Opensuse 11.1 running off an IDE hard disk and I have added a new internal 500 Gb Sata hard disk to PC. Dolphin shows it as “new volume” but when I click on it to open it gives a message “An error occured when accessing ‘New Volume’…etc” with something about permission denied in message also.

How do I mount new drive and have it mount at boot?

Many thanks:)

The drive has been formatted has it?
Open a treminal and become su and do

fdisk -l

post result

Hi cat4926,

I ran code and this was result

Disk /dev/sda: 30.0 GB, 30020272128 bytes
255 heads, 63 sectors/track, 3649 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xcc9bcc9b

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        1594    12803773+   c  W95 FAT32 (LBA)
/dev/sda2            1595        1603       72292+   7  HPFS/NTFS
/dev/sda3   *        1604        3649    16434495    5  Extended
/dev/sda5            3558        3649      738958+  82  Linux swap / Solaris
/dev/sda6            1604        2385     6281352   83  Linux
/dev/sda7            2386        3557     9414058+  83  Linux

Partition table entries are not in disk order

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x1b711b70

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1       60475   485765406    7  HPFS/NTFS

I hope this helps,

I have a mix of IDE & SATA on my Dell Precision, and they seem to work fine. I’ve taken to using the YaST Partitioner tool to set-up as it adds the entries to fstab and does the mount for you. I suggest you use this tool. It is in YaST > System

The new drive will be sdb, so when you open the partitioner highlight that entry, an it should show you one partition as /dev/sdb1. Highlight that and select Edit, make sure Do not format is selected, click the fstab options button. From the options select Mountable by user, and that seems to do the trick**.

The other way is to open the Super User File Manager** from the** System Menu**, right click the new drive in Storage Media, select Permissions and set the User & Group there.

See this HowTo: FSTAB - Editing Manually - openSUSE Forums

You need to edit /etc/fstab
First create a folder in the folder /media, call it STORE
so it will look like this: /media/STORE

add this line to fstab

/dev/sdb1    /media/STORE    ntfs-3g    defaults    0 0

Thank you very much for replies. I did what sid1950 suggested and it has worked fine.

Am I correct in saying if I partition Sata drive I can auto mount those partitions on booting in same way?

I was just wondering also, I can only boot from the IDE drive (old motherboard at moment) where Opensuse is installed but can I install Opensuse onto Sata drive and have IDE drive point to it when I boot PC?

This would speed up boot of Opensuse and running of PC as I have a Sata higher speed connection through PCI card.

Thanks again.:slight_smile: