Add installation source at command line

I’m ssh’d to my computer (which is many miles away, and no one lives there), and therefore no XWindow, hence no Yast GUI. How do I add an installation source from the command line? I see that I can

yast -i <package name>

but this assumes the owning installation source has already been entered via the GUI, and it has not. I can download the RPM and use the same method to install, but then I have a problem resolving dependancies. The only way I can see to get this done is to have the installation source entered in Yast. But how?

In running Suse 10.1, I’m trying to update my java runtime environment to 1.5.0_*

You can add it via the ncurses version of yast, which you run with: yast.

I remember that adding installation sources to 10.1 was a pain because of the zmd sync. Hope it works for you.

I’m not familiar with ncurses, but from what I can gleam from a quick google, seems overly complicated for what I’m trying to do. The only ncurses I have is a library, and short of writing a program to implement this library, I’m not quite sure what to do with it. Any other ideas? Is there a Yast file somewhere I can edit to add an installation source?

Nevermind, I see what you’re saying … just run


, and the text user interface is presented. That seems to have worked, thanks.

ncurses yast means the version of yast that runs in a terminal, using cursor graphics, tab and cursor keys, to give a poor man’s version of a GUI interface. Relax! You don’t have to write anything, just use it.

PS: Ok, I see you got the picture, or the screen. :slight_smile:

  • jetmonkey,

to add to Ken, take a closer look at zypper. It is a very powerful tool, and fast.


I wish there had been zypper in 10.1 though. :frowning:

It was called rug? zypper is in SLED 10 SP2, I wish they had the
rollback feature in zypper though.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 17:00, 0 users, load average: 0.08, 0.13, 0.14
GPU GeForce 6600 TE/6200 TE - Driver Version:

  • ken yap wrote, On 11/08/2008 12:56 PM:
    > I wish there had been zypper in 10.1 though. :frowning:

Argh, my “selective reading” filter needs some maintenance…
There was rug in 10.1
The set of commands and options is pretty similar, so it’ll be an easy switch to zypper once he UPGRADES TO A SUPPORTED VERSION of Opensuse. Did you read this, jetmonkey? :wink:


Yep, I read it. Unfortunately, for contractual reasons, I’m stuck with this version until end of project … soon I hope. Thanks for the info. I ended up using the ncurses method, and you were right about the timing issue. It worked, but what should have taken a minute or two took about 1.5 hrs. After getting installation source in, I

yast --install mypackage

and went to bed. All was good by morning.

I’ll have to look at some of the options mentioned for future use … thanks.