Add a virtual desktop on ICEWM

How do I add a new virtual desktop when using ICEWM

You need to edit your ~/.icewm/preferences as described in the iceWM documentation -> search for header “Workspaces”

This way not work

sergio@psitivo:~> cat ~/.icewm/preferences 
cat: /home/sergio/.icewm/preferences: No such file or directory

And in the links you sent I didn’t find how to change the number of workSpaces
Could you tell me how to do this?**
icewm supports multiple virtual desktops called workspaces. A workspace is like a screen where a subset of all application windows are mapped. Thanks to multiple workspaces we can more easily manage a large number of applications. The number of workspaces and their names are configurable in the preferences file through the WorkspaceNames option. By default four workspaces are created with the names 1, 2, 3 and 4 thus:
WorkspaceNames=" 1 ", " 2 ", " 3 ", " 4 "
Before I describe how to switch between virtual desktops I want to describe how to control their number. Imagine that your ~/.icewm/preferences has a row reading
This setting results in ten virtual desktops and ten buttons in your taskbar looking like this:
| 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 0 |

Simply create the preference file if it does not exist. Or use “icewm -directories” to find the preference file (as also described in the first link…).

If you name less desktops you obtain less if you name more you get more.

Maybe I didn’t explain it correctly:
I don’t need to rename the multiple virtual desktops
What I need is to create more workspaces, as the 4 that come by default are not enough for me. I need 6 desktops

Now I’m creating the file named “preferences” and I put a line inside it with the text WorkspaceNames=“1”,“2”,“3”,“4”,“5”,“6”
I will restart using ICEWM and report the result here

I created the file named “preferences” and put a line inside it with the text WorkspaceNames=“1”,“2”,“3”,“4”,“5”,“6”
I restarted using ICEWM and I still have only 4 desktops

What should I do to have 6 desktops?

Did you actually read the information that where provided to you? Read the man page carefully and use the commands to find in which directories icewm is searching for the preference file and make sure that you only have one (or at least matching content). Additionally list all your preferences and have a look that you have the right setting.

icewm -directories
icewm -postpreferences

*After a lot of futile attempts, **I finally succeeded.

  • I’ll put here how to do this, so that other people can change the To delete or create more workspaces just edite the file:

  • and look for the line
WorkspaceNames="1", "2", "3", "4"

Add or remove areas as you wish
And restart your PC