acpi=off tantrums

My system is a Dell Studio 14 laptop with 512 MB ATI Mobility Radeon HD 4530 graphics card, 4GB of ram and 500 GB of HDD.

The problem is that I am not able to boot into my studio without the “acpi=off nolapic noapic” boot option. And setting this option disables my machine from recognizing the battery connected to it.

Can anyone please help me out in booting without these parameters.

One more thing … the embedded speakers do not work( no sound) whereas the audio jack functions but with very less volume (its barely audible)… I was wondering whether it would have something to do with the acpi=off thing??

Alt+ Ctrl + fn (1-6) keys do not open another text based terminal instead display a blank screen.

I am stuck with these problems and I really want to use my system with opensuse.

Look at this, right thru

Planning for new laptop - openSUSE Forums

What is it that stops your laptop from booting properly ? Do you believe it to be the graphics? Are all of those boot codes necessary ? What openSUSE versions did you try ? Both 11.1 and 11.2 are available, and you can test either/both using liveCDs: Live CD - openSUSE Have you tested both 11.1 and 11.2 for this problem? Both KDE4 and Gnome ?

In case this is graphical driver related, here is a link to some graphics basics, so you can become more familiar with the graphic drivers that are available for openSUSE: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

Sometimes there can be a BIOS setting that is related to a problem.

You could also look inside your “dmesg” after a boot to see if it gives you any more hints as to the problem. Do you need guidance on how to look at the dmesg?