ACPI boot problems

Hi,

I had a problem with the timing descriped in following thread:

Timer/clock runs up to 4 times to slow - openSUSE Forums

I now managed to fix this but I have to use the boot parameter nosmp instead of acpi=off and noapic.

But as I understand now only one of my cpu cores runs.

Activating ACPI and SMP the last boot message I get is:

Marking TSC unstable due to: TSC halts in idle.

Then the boot process freezes.

System:

Intel Pentium Dual Core 2 x 2 Ghz
nVidia 9300m GS (runs perfect with nVidia driver)
250 Toshiba GB Sata HD
SIS 191 Network device
Chip set SiS m671DX
(brand new Laptop without any installed OS and unformatted HD)

Linux 2.6.25.11-0.1-pae i686
openSUSE 11.0 (i586)
KDE: 3.5.9 “release 49.1”

I’ve been watching your other thread about “4 times too slow” too.

The new kernel has enabled a ‘nohz’ mode, called “tickless”… it
improves kernel performance, but can cause issues with some hardware.

The new kernel ALSO enabled high resolution timers (HPET). Again, better
performance, again, can cause issues.

Three boot options to try:

highres=off
{ disables High Res Timers }

nohz=off
{ disables nohz mode }

clocksource=pit
{ least preferred, but could help }
clocksource=tsc
clocksource=hpet
{several possible options}

You’ll want to try the highres and nohz options by themselves, then together
before trying the clocksource options. (I’m not entirely sure clocksource will help, but certainly worth a try)

This could also solve your “4 times too slow” issue too.

You should not need the ‘acpi’ or ‘nosmp’ options, try the above options
without those first.

Hope this helps

Loni


L R Nix
lornix@lornix.com

On Sat, 16 Aug 2008 10:58:03 GMT
L R Nix <lornix@lornix.com> wrote:

>
>
> I’ve been watching your other thread about “4 times too slow” too.
>
> The new kernel has enabled a ‘nohz’ mode, called “tickless”… it
> improves kernel performance, but can cause issues with some hardware.
>
> The new kernel ALSO enabled high resolution timers (HPET). Again, better
> performance, again, can cause issues.
>
> Three boot options to try:
>
> highres=off
> { disables High Res Timers }
>
> nohz=off
> { disables nohz mode }
>
> clocksource=pit
> { least preferred, but could help }
> clocksource=tsc
> clocksource=hpet
> {several possible options}
>
> You’ll want to try the highres and nohz options by themselves, then together
> before trying the clocksource options. (I’m not entirely sure clocksource
> will help, but certainly worth a try)
>
> This could also solve your “4 times too slow” issue too.
>
> You should not need the ‘acpi’ or ‘nosmp’ options, try the above options
> without those first.
>
> Hope this helps
>
> Loni
>

Never fails… press send, and brain jumps up and down and says “hey!
something else…” {sigh}

Please add ‘notsc’ to the options to try. This disables the TSC timer.

My apologies.

Loni


L R Nix
lornix@lornix.com

The options with notsc I tried before (because of the error message) without any success.

I’ve tried the other options and at least the boot option nohz=off solved the boot problem.

Now everything seems to work fine.

I only will watch if the timer slow down problem will occur again.

Thanks a lot for this very quick solution!

On Sat, 16 Aug 2008 12:56:04 GMT
brankok <brankok@no-mx.forums.opensuse.org> wrote:

>
> The options with notsc I tried before (because of the error message)
> without any success.
>
> I’ve tried the other options and at least the boot option nohz=off
> solved the boot problem.
>
> Now everything seems to work fine.
>
> I only will watch if the timer slow down problem will occur again.
>
> Thanks a lot for this very quick solution!
>
>

Very happy to have helped. Congratulations!

Have fun!

Loni


L R Nix
lornix@lornix.com