ACL1200, ICH9 82801i - 4.1 surround sound problem

Greetings all,


00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

I am using a laptop MSI EX720 that has 4.1 surround sound. It appears both front channels play on the subwoofer channel, rear channels are faint, also playing on the subwoofer(only w/ pulse support enabled, otherwise no sound at all from rear channels). I hope that isn’t too confusing.

I ran mixers and all sound is at max and unmuted. I tried custom mapping the sound channels but even that didn’t help.

Please help me solve this problem, thanks you :slight_smile:

I have a surround sound system (5.1) but I’m by no stretch an expert in it … more like a beginner, as I have only a couple of tracks that use the 5.1 surround sound. I assume there may be some similarities between 5.1 and 4.1. sound.

I documented my experience here: Exploring surround sound in Linux - openSUSE Forums

If you think this is a configuration problem on your PC then we need more information in which to look at this. …

In that case, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your PC connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole


Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a detailed recommendation.

If using gnome, note here is a graphical front end/mixer called “alsamixergui” that you can install (it is in the nominal OSS repository, or on your DVD if you installed via DVD).

Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way. … however note I am out of town on business, with very limited internet access … it may be days between my replies.

Thanks for your reply, if it’s important to know, i’m currently running kde4.3 environment. The eyecandy is important to me lol.

here is the url you request:
I ran this code earlier while an freenode user was helping me.

Here’s the second part you requested:

linux-k8e4:/home/admin # rpm -qa | grep alsa

linux-k8e4:/home/admin # rpm -qa | grep pulse

linux-k8e4:/home/admin # rpm -q libasound2

linux-k8e4:/home/admin # uname -a
Linux linux-k8e4 #1 SMP 2009-08-15 17:53:59 +0200 x86_64 x86_64 x86_64 GNU/Linux

linux-k8e4:/home/admin # cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel
# u1Nb.hSHNs4ufGJ5:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

Thanks. I see you have a 64-bit kernel on openSUSE-11.1 with the latest 1.0.21 alsa (presumeably from the OBS multimedia directory) and your PC has an ALC1200 hardware audio codec.

You also have a custom .asoundrc file in place, of which I know nothing about.

You also have 5stack model option forced, but it is not in your /etc/modprobe.d/sound file, so I have NO idea as to where you forced that parameter.

Note my Asus P6T deluxe v2 desktop (intel core i7 920) has an ALC1200 and my 5.1 surround sound works and I did not find it necessary to add those items.

What happens, with 1.0.21 of alsa, if you remove that 5stack entry and also remove that .asoundrc file? (ie its possible they are restricting and not helping what your sound can do).

I do have an .asoundrc in place, however it’s just a bunch of tests i found from other forums. It did not make any difference on the current output.

The 5stack model I have removed just a few minutes ago actually. I added and removed from within the yast2 sound control panel. This also made no difference to the current output.

Now I removed .asoundrc and 5stack option, I do not have any sound period except front-left and front-right channel on the subwoofer speaker when running the sound test. Before removing I had sound just like above, but via youtube, amsn, etc.

Did you reboot after removing those ?

Did you compare your mixer options after rebooting? Note kmix in KDE allows one to add addition mixer controls/settings.

What is the diagnostic script output URL (/usr/sbin/ after making that change?

Per the thread I referenced where I tested my surround sound system, did you download chan-id.wav file from: and test it with various media players?

Yes I rebooted after removing these and no I did not compare my mixer options. I am using kmix and yes im aware of addition mixer sliders but non make any difference.

The new URL you requested is:

No I did not, but I will if you think it’s important :slight_smile:


No I did not, but I will if you think it’s important :)[/QUOTE]I think it is important to get a better test. So download that file and try playing that with different players, from the basic “aplay” to mplayer, vlc, ffplay, xine, etc …

Reference your model configuration, you attempted to use 5stack. I do not think that is appropriate. My guess is the ALC1200 is closer in implementation to one of the ALC882/883/885/888/889 and hence if you are going to try a model configuration, I would recommend trying one from that list:

  3stack-dig	3-jack with SPDIF I/O
  6stack-dig	6-jack digital with SPDIF I/O
  arima		Arima W820Di1
  targa		Targa T8, MSI-1049 T8
  asus-a7j	ASUS A7J
  asus-a7m	ASUS A7M
  macpro	MacPro support
  mb5		Macbook 5,1
  mbp3		Macbook Pro rev3
  imac24	iMac 24'' with jack detection
  w2jc		ASUS W2JC
  3stack-2ch-dig	3-jack with SPDIF I/O (ALC883)
  alc883-6stack-dig	6-jack digital with SPDIF I/O (ALC883)
  3stack-6ch    3-jack 6-channel
  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
  6stack-dig-demo  6-jack digital for Intel demo board
  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
  acer-aspire	Acer Aspire 9810
  acer-aspire-4930g Acer Aspire 4930G
  acer-aspire-6530g Acer Aspire 6530G
  acer-aspire-7730g Acer Aspire 7730G
  acer-aspire-8930g Acer Aspire 8930G
  medion	Medion Laptops
  medion-md2	Medion MD2
  targa-dig	Targa/MSI
  targa-2ch-dig	Targa/MSI with 2-channel
  targa-8ch-dig Targa/MSI with 8-channel (MSI GX620)
  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
  lenovo-101e	Lenovo 101E
  lenovo-nb0763	Lenovo NB0763
  lenovo-ms7195-dig Lenovo MS7195
  lenovo-sky	Lenovo Sky
  haier-w66	Haier W66
  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
  6stack-dell	Dell machines with 6stack (Inspiron 530)
  mitac		Mitac 8252D
  clevo-m720	Clevo M720 laptop series
  fujitsu-pi2515 Fujitsu AMILO Pi2515
  fujitsu-xa3530 Fujitsu AMILO XA3530
  3stack-6ch-intel Intel DG33* boards
  intel-alc889a	Intel IbexPeak with ALC889A
  intel-x58	Intel DX58 with ALC889
  asus-p5q	ASUS P5Q-EM boards
  mb31		MacBook 3,1
  sony-vaio-tt  Sony VAIO TT
  auto		auto-config reading BIOS (default)

In particular: targa, or targa-dig, or targa-2ch-dig , or targa-8ch-dig come to mind, although one of the others may work better.

When apply a model option, in openSUSE we apply it to the /etc/modprobe.d/sound file (for openSUSE-11.1 and earlier, 11.2 will be different). In your case, to try (for example) targa, edit the /etc/modprobe.d/sound file so that it looks like this:

options snd-hda-intel model=targa
options snd slots=snd-hda-intel
# u1Nb.hSHNs4ufGJ5:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel

and then restart alsa with su -c ‘rcalsasound restart’ enter root password when prompted and test. Be as thorough as you can in the test.

This strikes me as funny:

!!ALSA Version

Driver version:     1.0.21-git20091004
Library version:    1.0.20
Utilities version:  1.0.19

If libasound2 is 1.0.21 and alsa-utils is 1.0.21 I am surprised at that 1.0.20 and 1.0.19. It makes me wonder if you had a corrupted install when upgrading alsa. Can you try installing again the latest alsa apps with guidance given from here:
Alsa-update - openSUSE
Note you must send six zypper commands.

I didn’t notice that. I updated it to:

Driver version:     1.0.21-git20091006
Library version:    1.0.20
Utilities version:  1.0.21

However, I cannot get Library version up to 1.0.20 no matter what I do.

I’m starting on the other post now and will submit results shortly

Ahhh now things are starting to look up. I added models:
targe, targa-dig, targa-8ch-dig, 3stack-6ch, alc883-6stack-dig, 3stack-6ch-dig

They all basically give the same result

Front left -> Front left
Front right -> Front right
Center -> Front Center
LFE -> Rear Center
Rear left -> NO SOUND
Rear right -> NO SOUND

this is running the speaker-test, but when I try aplay, or any other sound player, I get no sound what so ever.

lol I feel this is a huge step forward and soo much closer to solved :smiley:

Update: I just tried playing a wav file using amarok and it worked, except on the rear speakers.

Update2: Playing mp3 file worked on all speakers normally as it should, however, the mixer sliders front control both front and rear speakers

Also, youtube, amsn, and other normal apps still don’t have sound. I just tried adding audio device to amsn, and have no sound :S, but I do on amarok

I don’t use amsn. But youtube should work. However its likely a different problem. Assuming you get video from youtube, then to get audio you will need flash-player. You will also probably need either mplayerplug-in (which has been depreciated by the developers) or gecko-mediaplayer. Both are available from Packman (I assume you are very familiar with Packman packagers for openSUSE ?). Note some users need to remove the app “libflashsupport” (but still keep flash-player) to get audio to work on youtube.

I got everything working just fine by turning on sound full duplex via the KDE4 control center (cmd: kcontrol). I don’t see how that solves these issues lol, but i’m glad it works.

Thank you for everything oldcpu, I owe ya lol!