Acer V3-572-5217, kernel 3.11, wifi problems

I just got an Acer V3-572-5217 and installed openSuse, and the wifi was not working at all.

I thought I had it working by the advice given here:
https://forums.opensuse.org/showthread.php/498395-Wireless-problems-on-an-Acer-Aspire-V3-772?highlight=atheros

However I kept having to re-authenticate and often I couldn’t load webpages even though I was supposedly still connected.

I also tried the advice given here:
http://askubuntu.com/questions/301442/atheros-ar9462-wifi-very-unstable-package-loss

Adding the hwcrypt option etc, which didnt seem to help.
Finally I updated the kernel to 3.16 (from 3.11) using stable, and that worked, but unfortunately it also broke my touchpad (I made another thread about that, but wasn’t able to solve it).

Anybody have any additional suggestions?

Ha sorry forgot to include key info:
openSUSE 13.1
AR9462 wifi
ath9k drivers

Update (I promise, I’m not just trying to bump this thread):
I booted from a Linux Mint KDE USB and I’m not having the wifi or touchpad issues, so it doesn’t seem to be that Linux hates my new machine.
I think I’m going to go ahead and install it, but if anyone has any suggestions I’d still be interested, I kinda fell in love with Yast and would like to give openSUSE another go sometime.
In any case thanks to the good folks here who helped me on the threads I’ve created over the past few days.