[Acer V3 571G] Legacy boot does not show GRUB2


I’ve just bought an Acer V3-571G-53236G50Makk laptop.

Since it would let me boot from openSUSE 12.3 x86_64 DVD for some “security restriction” and I couldn’t disable Secure Mode from BIOS, I switched to legacy mode and restarted my laptop.

It read the DVD (yay!) I resized my Windows 8 partition, created a SWAP, / (ext4) and Data (FAT) partition and went on with the setup. Grub2 was installed on / and MBR (so it said before I clicked install).
Installation went fine.
On rebooting I get a pretty verbose screen saying

Booting from local disk...
Missing OS
Missing OS

Then some Broadcom and Intel copyright text, then:

PXE-E61: Media test faliure, check cable
PXE-M0F: Exiting Broadcom PXE ROM

And a request: should I be so kind as to insert a boot disc and press any key?

I have zero laptop experience and since I couldn’t find a model-specific topic on Google, I’d rather bother you with a silly question than screw up my new laptop big time.


Okay, according to this ubuntu guide I’m an idiot, and you can’t dual boot if Win is in UEFI and Linux in Legacy mode…

right. both have to be in same mode. You should be able to boot the DVD in UEFI mode if you press a key I think F10 or F8 (depends on make)which should give you a boot menu and select the boot there. You can install with secure boot on you do have to tick the option in the install setup