Acer Timeline 3810T Trackpad Problem

I bought an Acer Aspire Timeline 3810T and have had issues with using Linux on it. Often certain icons won’t let me click on them. This even occurs during an install where when clicking on things like the time zone it won’t let me click with the trackpad or mouse if connected and I have to use the tab key and enter to select an item. Even when I use a program such as OpenOffice Calc if my mouse pointer is over the cells they will start scrolling from left to right without me even pressing anything.
I went through a lot of troubleshooting and finally figured out it’s related to my internal trackpad. Fortunately most of the time I use a trackball or mouse so it’s not an issue but my computer won’t work right if this trackpad is on. The Timeline 3810T has an on/off button that allows you to turn the trackpad off. It won’t allow me to turn it off during bootup until just before the desktop appears. If I miss that time and it’s finished booting then my system won’t work but as long as I turn it off in time it does. I wish there was a way to select to turn it off by default but I have looked in the BIOS and don’t see an option for that.
Still there are times I want to use the internal trackpad. Since this is new hardware I’m convinced it’s just not supported yet and that a future Kernel version or update to the distribution will support it. Yet I have done a Google search and have seen a lot of messages by people using Linux on this machine and not reporting problems.
Any idea what could be causing this? Is there some type of workaround, maybe within the settings for Linux, where I could fix this?

I would say, that if others don’t report problems, the device is supported. You might try to install ‘touchfreeze’; this is for synaptic touchpads, to auto-disable etc.