Acer Ferrari 4000 hangs at "Starting udev..." during openSUSE 12.3 installation

To the original author, RonPflaumer, if you are still monitoring this thread, I have a partial answer. I have a Ferrari 4000 that had the same problem with 12.3.

First off, I had to use the “F” keys specify screen resolution and choose safe mode at the first menu. Then chose “install”. I ended up with a non “x” interface, but the install worked, barring some random screen corruption. When going to the installed system, there were countless graphics and hardware problems. I was able to trace some of the errors to the power control system features. It may have been cause by the “safe mode” install, but I found no other way to make the install work.

I use grub, rather than grub2, as it is much easier to set up, IMHO. I checked /boot/grub/menu.lst and found that the installer had killed many hardware features for no apparent reason. I removed all the items from the kernel line that killed features (ACPI=no", for example), and saved the file. Upon reboot, things were much more normal. All I left in the kernel line was the “resume” section, splash=silent quiet showopts

The Radeon Mobility X700 still does not work well with 12.3 for whatever reason. It worked perfectly before. I have a working system and glxinfo states that direct rendering works. glxgears shows 60fps even when the window is enlarged. But KDE desktop effects are pretty much useless. I am unable to set the “advanced” tab in the desktop effects window to opengl. When I try, it fails. So I am stuck with xrender. The KDE “monitor” section does not even have resolution options.

Plymouth falls to the “failsafe” display during boot, and I can use Esc to get verbose readout. For some strange reason, the Plymouth shutdown screen runs normally and I get the Bitcom logo screen.

There are promises of better ATI support with the upcoming kernel 3.11. I hope so. The native radeon driver has had a regression since openSUSE 12.2 and trying various radeon drivers from has not helped. I am not sure if therr “mobility” version of the X700 is so different from the PCIe version. I have an old X800 PCIe card that I might experiment with in an old box.

If any seasoned pros can specify a certain driver, and possibly others to remove, I’m all ears. Radeon is loading and working, but KDE performance is horrible. If I want to get any work done, I boot into lxde.

Please disregard. I did some significant back-stepping and fixed the problems. I had added repositories for KDE 4.11 and kernel 3.11 which only served to give me a cluttered up mess. I had also installed sax3, trying to make things work. I deleted those repositories and sax3; downgraded and / or deleted packages as necessary, ran mkinitrd, and rebooted. All is well, with a fully working system. The plymouth problem seems to be related to the theme chosen. I changed to “spinner” and it works well.