ACER F 15 and NVIDIA drivers -> blank screen

|down votefavorite
|

|I’m on Opensuse Leap 42.1 and I’m trying to make it work with the NVIDIA proprietary drivers. At the moment, with the drivers installed via zypper or without proprietary drivers my laptop (an Acer F 15 with a NVIDIA Geo Force 940M) is almost useless… it freezes almost always using both Kde, Gnome and also other desktop environments. It seems a video driver problem and because of this I’m trying to install the proprietary drivers manually. I downloaded the last version (I’ve tried also other ones), then I installed it, run mkinitrd and blacklisted nouveau. Now I get a blank screen… the log files says: xf86OpenConsole: VT_ACTIVATE failed: Operation not permitted
I’ve also tried to generate a new xorg.conf file via nvidia-config but nothing… I’ve also tried su - -c chmod 4755 /usr/bin/Xorg but nothing also in this case… any suggestions?
cheers
|

I’ve read all the common issues, NVIDIA documentation and all the Opensuse one as well, still nothing :confused:

Notebook?? then probably a hybrid graphics Intel+NVIDIA (Optimus graphics). you must use bumblebee.

First you must remove the NVIDIA driver you installed

then follow instructions exactly here

https://en.opensuse.org/SDB:NVIDIA_Bumblebee

I’ve already tried that, I have KDE but it always freezes…

fixed updating the kernel