Acer Aspire M5 and OpenSuse

Hi to all, new to forum and OpenSuse. I put this on my Granddaughter’s older XP computer for her and she seems happy, only a few text messages so far. :wink: The reason for the post is to put something positive out. I recently purchased an Acer Aspire Mr-481PT Ultra book. It is running Windows 8 with UEFI. It has InsydeH20 v2.11, Intel Core i5-3337U with a 500g drive and a 20g SSD for fast boot. I tried to put Fedora 19 on it and failed miserably. Since I had just used OpenSuse recently I thought I would give it a try. I downloaded a netinstall version, burned to cd and installed. I had previously used a livecd of Fedora18 to run gparted and shrink the windows partition and free up 100g for this purpose. Everything went very smooth with the installer. When it finished I ejected the cd and rebooted. It went straight to Windows. Tried several more times to no avail. When I rebooted again I held F12 and it put me in Boot Manger. Windows and OpenSuse both showed but when I clicked on OpenSuse Windows booted. I tried again and held F2 to open bios/uefi. Under the security tab I created a password for admin which opened up several items that had been previously greyed out. One of them was labeled “Select and UEFI file as trusted for executing” . When I clicked on this it took me through several steps (like going through a directory) to grub.cfg. Authorized that, saved everything and rebooted, held F12 and selected OpenSuse. This time it booted right up. I am now running openSUSE 12.3 (Dartmouth) 64-bit, Kernel Linux 3.7.10-1.16-desktop with Xfce.

This was such a pleasant surprise I felt I should share this info with your community. I tend to come and read at forums without posting very often but this was something to share.


On 07/08/2013 05:16 PM, jbs1136 wrote:
> something to share.

yes it was, and thank you for doing so!!


I tried to edit my original entry but didn’t see how so I will add here.

Something that I failed to mention was that although I am using UEFI secure boot has to be disabled. If not, it boots straight to windows regardless what you click on.


I assume you mean you installed openSUSE-12.3 from the liveDVD (instead of from the installation DVD). To the best of my knowledge openSUSE no longer offers a liveCD (as the file is now too big to fit on a CD).

There are a number of threads going on currently about dual booting openSUSE-12.3 with Windows8. Some of us (like myself) have managed to dual boot openSUSE-12.3 with Windows8 with secure boot still enabled in the UEFI firmware. But the installation has not gone smoothly for all, and in some cases (such as my case where I installed from the installation DVD) some manual intervention was required to modify boot files (following advice of some of our forum’s UEFI firmware boot knowledgeable users).

I note not all laptops/PCs with UEFI firmware and Windows8 installed behave the same wrt UEFI boot while openSUSE-12.3 is installed. There area a number of the threads ongoing endeavoring to flush out the differences so as to pass this on to the SuSE-GmbH developers and improve the openSUSE distribution.

Actually I used the netinstall cd. I have Comcast cable running above 50Mbps so it goes pretty quick. Also, cd’s are cheaper lol!. I sometimes do a LiveCD/DVD but only if I trying something I know nothing about. Although I’ve never used openSuse I put it on another computer for someone and I know it’s been around a long time and isn’t just something thrown together. I saw the other threads and skimmed/read through some of them but couldn’t find my computer so just did it.

Downloaded from this site and clicked on “Network”, selected 64-bit and Direct Link. It was 252.7 MB downloaded.