Acer Aspire E1-522 no sound

Hello,

I’ve a new fresh installation of openSuse 13.1 on this notebook with kernel upgraded to version 3.16.1 and KDE 4.11.5. The problem is simple: no sound (even trying to play a waw file with the aplay command). I’m going crazy…

Here my alsa-util output: http://www.alsa-project.org/db/?f=b1dd9a324097dd016bfe9dfafacab7a08d75af51
Here below the rpm queries output:


liudmila@linux-js5j:~> [b]rpm -qa '*alsa*'[/b]
alsa-plugins-pulse-1.0.27-3.1.1.x86_64
alsa-1.0.27.2-3.5.1.x86_64
alsa-oss-1.0.25-8.4.1.x86_64
alsa-utils-1.0.27.2-4.2.1.x86_64
alsa-plugins-1.0.27-3.1.1.x86_64

liudmila@linux-js5j:~> [b]rpm -qa '*pulse*'[/b]
pulseaudio-module-x11-4.0.git.270.g9490a-12.1.x86_64
alsa-plugins-pulse-1.0.27-3.1.1.x86_64
pulseaudio-module-bluetooth-4.0.git.270.g9490a-12.1.x86_64
pulseaudio-module-jack-4.0.git.270.g9490a-12.1.x86_64
libxine2-pulse-1.2.3-3.1.3.x86_64
pulseaudio-utils-4.0.git.270.g9490a-12.1.x86_64
pulseaudio-module-lirc-4.0.git.270.g9490a-12.1.x86_64
libpulse0-4.0.git.270.g9490a-12.1.x86_64
libpulse-mainloop-glib0-4.0.git.270.g9490a-12.1.x86_64
pulseaudio-module-zeroconf-4.0.git.270.g9490a-12.1.x86_64
pulseaudio-4.0.git.270.g9490a-12.1.x86_64

liudmila@linux-js5j:~> [b]rpm -q libasound2[/b]
libasound2-1.0.27.2-3.5.1.x86_64

liudmila@linux-js5j:~> [b]uname -a[/b]
Linux linux-js5j.site 3.16.1-4.g8fc81d3-desktop #1 SMP PREEMPT Thu Aug 21 15:46:35 UTC 2014 (8fc81d3) x86_64 x86_64 x86_64 GNU/Linux

In Yast -> Sound I see two cards.
[img=http://s4.postimg.org/cz1psuoc9/snapshot2.jpg]

Any clue?:frowning:

Maybe the wrong device is set as default. This can be configured via YaST>>Hardware>>Sound, select the desired card, then ‘Other’>>‘Set as the Primary Card’

Test sound from there too. You might want to make sure that no channels are muted as well.

Click on the Other button. Set “card 1” as the primary card and Pulse Audio Configuration. Check the volume settings and click on the Test button for a sound check.
Note: The first card (card 0) is for hdmi.

Add the line below to the " .bashrc " file. Resave the changes. Log off and log on. Click on kmixer to see all of the channels.

export KMIX_PULSEAUDIO_DISABLE=1

That would be my guess also. I note from the script:


!!Aplay/Arecord output
!!--------------------

APLAY

**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 0: ALC282 Analog [ALC282 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

where the HDMI device is assigned card-0.

By default one’s sound comes out of card-0.

One can also install the application pavucontrol and use that to assign one’s applications to specific audio devices. Some blogs on this:

@deano,romanator,old_cpu

thanks for the help, but the sound card still doesn’t work… :frowning:

step 1
I’ve set the the ATI card as primary card using Yast, so now the HDMI card is card #1

step 2
I’ve disabled the “Pulse Audio Support” for primary card (results in disabling for “secondary” card too)

step 2
tested it with “Play Test Sound” -> no sound

step 3
tried to set Volume using the command “Volume…” and all as I see is an almost blank dialog with just a button “Test”
pressed the “Test” button → no sound
http://www.fotos-hochladen.net/thumbnail/yastvolumeset8dn0slb27u_thumb.jpg](http://www.fotos-hochladen.net/view/yastvolumeset8dn0slb27u.png)

step 4
rebooted the system and repeated step 2 and 3 → no sound…

In the meanwhile I have observed what follows:

A) the aplay command doesn’t work anymore

liudmila@linux-js5j:~> aplay /usr/share/sounds/alsa/Noise.wav 
ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
aplay: main:722: audio open error: No such file or directory
liudmila@linux-js5j:~> 

B) “Strange” generic audio sound cards appears now by selecting Configure Desktop -> Multimedia -> Video and audio settings

http://www.fotos-hochladen.net/uploads/desktopsetting9kp7yfh5tb.png](http://www.fotos-hochladen.net)

C) don’t laugh, but… if I now select in Yast the AMD (HDMI) card #1 and I press “Play Test Sound” then I hear trumpets! :\

I would enable Pulse Audio Support in Yast so that you can use the Phonon Audio and Video test button. Make sure you install pavucontrol.
Can you hear sound after clicking on the Test button?

FYI
The card numbering starts from “0 and up” so the card that you have set as primary card is card 0 .

Thanks, Romantor. I’m going to test your suggestions asap, as I return to home

Yes, I know that. I was just surprised that I can hear the test sound in Yast after marking the HDMI card as non-primary card (i.e. card number 1).

YaST sound menu is a front end to tuning one’s audio and it is not always perfect. So take its labelling with a grain of salt.

The script /usr/sbin/alsa-info.sh yields far more accurate information.

Note if sound works in YaST but not as a regular user, the problem could be permission related, and sometimes in such cases one simply needs to add their user to group ‘audio’, restart their PC and test.

@old_cpu

I tried to add the unique user (that’s my wife) to the “audio” group but… there’s no audio group at all displayed by Yast. So I added it to the “pulse” group (after enabling the pulse audio management on the cards and rebooting the system) but nothing is changed. No sound,even with the aplay command from terminal window.

More than this, I see a strange behaviour using Yast: if I select the primary card (#0) and I use the command “Volume” then the dialog window for volume regulation is empty (see one of my previous post), while if I select the secondary card (i.e. #1) the sound regulations are always displayed?

http://www.fotos-hochladen.net/thumbnail/volumecard1qaushgzol0_thumb.jpg](http://www.fotos-hochladen.net/view/volumecard1qaushgzol0.png)

Even the test sounds works always on the non-primary card, why?
I tried also to swap the two cards (HDMI as #0 and built-in as #1) and the same has happened. I have one idea: what happens if I delete one card???:shame:

Your speaker volume is set to 0.

Hi Romanator, I have installed the pavucontrol and now… it works!!! :slight_smile:

I mean, now I have more options when I access to “Configure Desktop” -> “Multimedia” -> “Audio and video Setting” -> “Audio Hardware Setup”.
http://www.fotos-hochladen.net/thumbnail/hdmionql8fx5e1zw_thumb.jpg](http://www.fotos-hochladen.net/view/hdmionql8fx5e1zw.png)
There I see two “Built-In Audio” sound cards, the first offers only the HDMI profile while the second offers different selectable profiles
So, I have disabled the HDMI profile (i.e. “off”)
http://www.fotos-hochladen.net/thumbnail/hdmioff9z2i7qlr5j_thumb.jpg](http://www.fotos-hochladen.net/view/hdmioff9z2i7qlr5j.png)

then I selected the second card and choosed the “analog stereo duplex” profile
http://www.fotos-hochladen.net/thumbnail/analogstereodxq2h8pm4u5_thumb.jpg](http://www.fotos-hochladen.net/view/analogstereodxq2h8pm4u5.png)
tested and… it works!
great!

Congratulations! Now you have full control.

I’m also using Analog Stereo Duplex.

Enjoy!

**[SOLVED]

**Here a roughly list of the steps
(it applies for kernel 3.16.1-blablabla, I don’t know if it holds for previous kernel)

  1. launch Yast -> Sound and you will see two cards: “ATI technologies Inc” and “AMD”.The AMD card is just for sound output through the HDMI connector.
  2. Assign the role of “Primary Card” to the ATI card
  3. Click on the ATI card and be sure that "Pulse Audio control"is enabled (i.e. checked)
  4. reboot
  5. launch Yast again and use the “Online Update” to install the *pavucontrol *
    utility (use the “search” dialog box) 1. reboot
  6. from the OpenSuse menu in the left-down corner of the desktop launch “Configure Desktop” -> “Multimedia” -> “Audio and video Setting” -> “Audio Hardware Setup”.
  7. you will see two “Built in audio” card
  8. select the first one and set the profile to “off”
  9. select the second one and set the profile to “analog stereo duplex”
  10. you’re done!

To see the new pavucontrol options navigate through the application menu (see below)
http://www.fotos-hochladen.net/thumbnail/pavucontrolse2yms83ihd_thumb.jpg](http://www.fotos-hochladen.net/view/pavucontrolse2yms83ihd.png)

Hope it helps! :nerd:

Very good. Now you can rate this thread. lol :wink:

You can add this tip to the Unreviewed -How-To-FAQs. https://forums.opensuse.org/forumdisplay.php/783-Unreviewed-How-To-and-FAQ