acer aspire 8930g resolution incorrect

Hi all,

I am running openSuSE 11.1 on Acer Aspire 8930g, I try to configure the nvidia drivers, the maximum resolution I currently get is only 1024x768 with sax2, also double-checked with

xwininfo -root

the screen is capable of going to 1920x1080 as it does without issue under Vista.

Then I tried the following code, while using the nvidia driver, (the modeline was calculated using cvt):

xrandr --newmode 1920x1080  220.64  1920 2056 2264 2608  1080 1081 1084 1128  -HSync +Vsync
xrandr --addmode default 1920x1080
xrandr --output default --mode 1920x1080

that returns me “configure crtc 0 failed”

then I switched to Driver “nv” in the /etc/X11/xorg.conf and restarted the X server (init 3 then init 5)
there the maximum default resolution is 1680x945
following the same xrandr method, I am unable to switch to the full 1920x1080

I am unsure what to do next to solve that.

That’s my current xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Fri Aug 14 17:54:58 PDT 2009

# /.../
# SaX generated X11 config file
# Created on: 2009-08-28T14:06:23+0100.
# Version: 8.1
# Contact: Marcus Schaefer <>, 2005
# Contact: SaX-User list <>
# Automatically generated by [ISaX] (8.1)

Section "ServerLayout"
    Identifier     "Layout[all]"
    Screen         "Screen[0]" 0 0
    InputDevice    "Keyboard[0]" "CoreKeyboard"
    InputDevice    "Mouse[1]" "CorePointer"
    InputDevice    "Mouse[3]" "SendCoreEvents"
    Option         "Clone" "off"
    Option         "Xinerama" "off"

Section "Files"
    InputDevices      "/dev/gpmdata"
    InputDevices      "/dev/input/mice"
    FontPath        "/usr/share/fonts/misc:unscaled"
    FontPath        "/usr/share/fonts/local"
    FontPath        "/usr/share/fonts/75dpi:unscaled"
    FontPath        "/usr/share/fonts/100dpi:unscaled"
    FontPath        "/usr/share/fonts/Type1"
    FontPath        "/usr/share/fonts/URW"
    FontPath        "/usr/share/fonts/Speedo"
    FontPath        "/usr/share/fonts/PEX"
    FontPath        "/usr/share/fonts/cyrillic"
    FontPath        "/usr/share/fonts/latin2/misc:unscaled"
    FontPath        "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath        "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath        "/usr/share/fonts/latin2/Type1"
    FontPath        "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath        "/usr/share/fonts/baekmuk:unscaled"
    FontPath        "/usr/share/fonts/japanese:unscaled"
    FontPath        "/usr/share/fonts/kwintv"
    FontPath        "/usr/share/fonts/truetype"
    FontPath        "/usr/share/fonts/uni:unscaled"
    FontPath        "/usr/share/fonts/CID"
    FontPath        "/usr/share/fonts/ucs/misc:unscaled"
    FontPath        "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath        "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/misc:unscaled"
    FontPath        "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/Type1"
    FontPath        "/usr/share/fonts/misc/sgi:unscaled"
    FontPath        "/usr/share/fonts/xtest"
    FontPath        "/opt/kde3/share/fonts"

Section "Module"
    Load           "freetype"
    Load           "dbe"
    Load           "glx"
    Load           "extmod"

Section "ServerFlags"
    Option         "AllowMouseOpenFail" "on"
    Option         "ZapWarning" "on"

Section "InputDevice"
    Identifier     "Keyboard[0]"
    Driver         "kbd"
    Option         "Protocol" "Standard"
    Option         "XkbLayout" "gb"
    Option         "XkbModel" "microsoftpro"
    Option         "XkbRules" "xfree86"

Section "InputDevice"
    Identifier     "Mouse[1]"
    Driver         "synaptics"
    Option         "Buttons" "5"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "on"
    Option         "HorizScrollDelta" "0"
    Option         "InputFashion" "Mouse"
    Option         "Name" "Synaptics;Touchpad"
    Option         "Protocol" "explorerps/2"
    Option         "SHMConfig" "on"
    Option         "Vendor" "Sysp"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    Identifier     "Mouse[3]"
    Driver         "mouse"
    Option         "Buttons" "5"
    Option         "Device" "/dev/input/mice"
    Option         "Name" "ImPS/2 Generic Wheel Mouse"
    Option         "Protocol" "explorerps/2"
    Option         "Vendor" "Sysp"
    Option         "ZAxisMapping" "4 5"

Section "Modes"
    Identifier         "Modes[0]"

Section "Monitor"
    Identifier     "Monitor[0]"
    VendorName     "--> LCD"
    ModelName      "1920X1080@60HZ"
    UseModes       "Modes[0]"
    DisplaySize     401    225
    HorizSync       66.0 - 69.0
    VertRefresh     59.0 - 61.0
    Option         "CalcAlgorithm" "XServerPool"
    Option         "DPMS"
    Option         "PreferredMode" "1920x1080"

Section "Device"
    Identifier     "Device[0]"
    Driver         "nvidia"
    VendorName     "NVidia"
    BoardName      "GeForce 9600M GT"
    Screen          0

Section "Screen"
    Identifier     "Screen[0]"
    Device         "Device[0]"
    Monitor        "Monitor[0]"
    DefaultDepth    24
    SubSection     "Display"
        Depth       15
        Modes      "1920x1080" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    SubSection     "Display"
        Depth       16
        Modes      "1920x1080" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    SubSection     "Display"
        Depth       24
        Modes      "1920x1080" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    SubSection     "Display"
        Depth       8
        Modes      "1920x1080" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1600x900" "1280x1024" "1440x900" "1280x960" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"

Section "Extensions"
    Option         "Composite" "on"

Have you tried working in Yast - Hardware - Graphics and Monitor

yes, yast monitor will list 1920x1080 but when it tests the setting with sax2 before exiting, then sax2 shows 1024x768 although I selected 1920x1080@60Hz with 24 bits depth

Are you using the Generic LCD–> setting, I do.

Sorry. To clarify, I do on my Box but my Laptop picks up as Lenovo brand and works OK. But selecting Generic LCD can work better often.

yes, with yast graphics/monitor, I see the card selected is nvidia 9600M GT as expected, then for monitor I press “change” and select
LCD → 1920x1080@60Hz
LCD is the top of the list of different brands of monitors.

But after clicking OK, the test screen comes up (with arrows and squares in each corner) and it shows 1024x768

So was there or is there any Acer option for the screen?

Have you rebooted since installing the driver? Or at least logout and back in?

yes I also tried all the “ACER ASPIRE” monitors listed. Everytime sax2 test comes back with 1024x768
I usually go to init 3 then init 5, I also rebooted a few times while I was playing with the xrandr command to try to force the resolution.

I have to hit the sack now. Check back 2mo;)

also I might need to add I am using the latest nvidia drivers v. 185.18.36
and that particular laptop has also been reported to work with ubuntu

some progress, with the nvidia-settings application, I managed to push the resolution to 1680x965, though it still does not offer the 1920x1080 option.
And even now if I run sax2 it still falls back to 1024x768

So are you actually installing manually?

And have you considered the nvidia beta 190 driver, many are using it.

yes manual because I have kernel 2.6.31-rc7 (in order to get support for the soundcard). anyway I am experiencing the same resolution issue with the default 2.6.27.
I just tried nvidia v. 190, I still can’t get higher than 1680x965 and now sax2 crashes when it tries to test a new screen resolution.
I don’t think it’s due to v. 190, I think sax2 just can’t cope with the resolution currently set by nvidia-settings

I still can’t get higher than 1680x965
And how does it look at that? Is it off screen at all?

have you tried the nvidia cuda
don’t know if it will make any difference.

the display is OK at 1680x965, centered correctly and covering the whole screen.

what is nvidia cuda?

CUDA Zone—Learn about CUDA

CUDA - Wikipedia, the free encyclopedia

If what you have is OK. Take your time reading up on things and options, use google to search for info.

I just tried cuda 190.18 and went in the nvidia-settings tool but it allows just the same resolutions as the beta 190.18 without cuda support

Hi, I am experiencing the exact same problem.
I bought this particular laptop only because
of the 1980p capability and the wide screen
and the disappointment that this expensive
hardware does not work is huge. Going for a
1680 screen could’ve saved 200 pounds.
Anyway, I have tried numerous nvidia drivers
manually and the only one that works reasonably
is the 185.18.14 but only in 1680.
I have contacted acer uk/europe but have received no help. The explanations and solutions to the problem seems to involve getting a new edid file and importing this in the xconf. Creating such an edid file is difficult (I tried). Is there really NO OTHER
USER with this laptop that has got a working configuration/driver installation? Could someone PLEASE verify that it is possible to get it to work?

Acer Aspire 8930G [Linux Laptop Wiki]
[all variants] Acer Aspire 8920G [Archive] - Ubuntu Forums](

A laptop without full res, card reader and spdif out is a very expensive toy…and
the number of hours spent on resolving these
problems is ridiculous, Bill is laughing from the other corner all the time.

Was able to try this on one 8920G last night and got it working by doing this:
Installed 185.18.36
ran ‘sax2 -r -m0=nvidia’ (to create a completely new xorg.conf based on usage of nvidia driver)
Choose Change Configuration
Set monitor to LCD@1920x1080
Did NOT test, just saved and exitted.

Machine’s not mine, so don’t have any screenshots available. Did not know about this post yesterday, but made a phone call and owner of the 8920 states that resolution is 1920x1080

Maybe you’ve been running sax2 without the -r option.