Acer Aspire 5738 -- SOLVED

This weekend I was asked to install OpenSUSE on a brand new Acer Aspire 5738-6993 laptop, and I had to jump through a few hoops to get it running. Disregarding several restarts, do-it-again-to-be-sure attempts, and knock-your-head-against-the-wall periods, this is how I got it to work.

I first tried with the OpenSUSE 11.1 Live CD, but I just got a black screen for my efforts. (This, I googled, was a common enough problem.) Linux started all right, and I could Alt+F1 to the console, but X wouldn’t run.

After many experiments, I decided to try another way of installation, and downloaded the Network Install ISO (less than 80Mb), burned it to a CD, and started again.

After a longish wait, I went through all the installation steps, eventually rebooted the machine… and a black screen again!

I rebooted, and decided to try the Failsafe boot option, which provided the first success: at least, I had a low resolution display! (The laptop has a 1366x768 display.)

I then updated all necessary packages --another wait-- and after that finished, I used SaX2 to check the display. I had to fix the monitor (which was unrecognized) and select “LCD 1366x768” and also disable the “Dual Head Mode” (which I don’t know why was selected).

Then, and only then, after yet another reboot, picking theI eventually got other than a black screen!

On the minus side, I must have rebooted the laptop dozens of times, and downloaded tens of gigabytes of updates and packages, plus all the (mostly worthless) googling.

On the plus side, apart from the video, everything else worked out of the box: sound, webcam, wireless, multimedia keys, etc.

I don’t know why the LiveCD doesn’t pick up the monitor type (that, it seems, was the problem with the black screen) or if there are some Acer-required drivers that are missing in it, or whatever…

Anyway, Acer being a well known brand, I think it should be used for tests for the LiveCD, and installation shouldn’t be such a chore!

What is the graphics chip/card?

Try this for now:

Pause the boot by moving the down arrow, then back up to the default boot. But now press backspace, it should delete any text where you can see: vga=0x…
Remove all text and now type just the number:
and hit enter

at the login type your user name and then password
now type:
then the root password

now type this:
sax2 -r -m 0=vesa
(N.B. the 0 is a zero not a letter)

now reboot: type: reboot
if you don’t get a gui login
login as user at cli and try this at the cli

were you by any chance using 64 bit system? Actuall I have also installed suse11.1 64 bit on my new HP Dv6 and I faced the same problem with 64 bit Live CD as well as DVD. I had to install 32 bit suse, but I do not know what happened after that but when I inserted suse 64 bit it ran fine… :slight_smile:

And I also faced the resolution problem, I had to install suse 11.1 3 or 4 times since yesterday and everytime it set the wrong display. I have just started updating my system and will have to configure for my ATI Radeon graphics card later. Hopr things go smoothly :slight_smile:

I was using the 32 bit version.