Acer Aspire 5715z Brightness Problem

Hello, I am a long-time Windows user who has recently - in the past two days - installed OpenSUSE with Gnome on my Acer Aspire 5715z. I am currently dual-booting both Windows 7 and the already specified Linux setup, however I have encountered a problem on OpenSUSE.

My problem is associated with the brightness of the laptop monitor. I may be incorrect, but it seems that Acer lack the courtesy of providing proper hardware drivers such as for the Atheros WiFi card (which did not perform on KDE, but on reinstalling OpenSUSE with Gnome it seems to work perfectly - unfortunately the monitor brightness problem was not as kind so as to fix itself) and, as obvious, the LCD monitor for those customers that want to use Linux over a Windows-based operating system.

I am posting in the hope that someone has either encountered this problem and is willing to help me overcome it or that someone is knowledgable enough to help me fix it without prior experience with the specific problem at hand.

Ok, enough rambling!

tl;dr: The main problem is that Linux acts, when I press my Fn + Brightness-Up/-Down buttons, as if nothing has been pressed. I cannot seem to find any option under Display settings or Power Management settings that allow me to change the brightness either. How can I fix this problem as it is almost impossible to use the operating system on the lowest brightness (which it is stuck on).

Thank you very much for any help you might be able to provide, it is appreciated.


Hi Moose,

as a starting workaround you may try to set a needed brightness level during the BIOS/GRUB boot sequence - and hopefully the same brightness will be kept till the next reboot - at least you’ll be able to see the screen :slight_smile:

The next step will be to check if “solid” is even able to manage it. Just execute from the command line:

$ solid-powermanagement brightness get

$ solid-powermanagement brightness set 60

and see what kind of values you see on “get” and if “set” will change anything…