Acer Aspire 5315 overheating still...

after upgrade from 11.1 to 11.2 my acer overheats.I cannot do anything to force cooling fan to work.

Recently I updated to newest kernel-default from Factory repo but still nothing.

Any suggestions?

Broken fan? If it realy overheats, have it repaired, you might cause more damage by keeping on trying.

Fan is OK. I have XP on the same machine and there everything is OK. It looks like something in new kernel causes fan no not work or maybe some broken module.
The problem is recognized on other forums and some bugs was submitted but for now I dont’see any results or new patches :frowning:

So I use now only XP and perhaps abandon Linux on this lap.

Go to a console and type dmidecode | less.
That will show you all kind of info about your hardware, slowly scroll down to the cpu section and find out what kind of cpu you have. If happens to be a Celerom M, chances are it is not really overheating. Those CPU’s (I have one myself) can reach 100 Celcius degrees before it is actually overheating, Acer uses them quite a bit, so it could be hot, but not necesarilly overheated…

I’ve got exactly the same issue: Upgrade 11.1 to 11.2 and the my Aspire 5315 suddenly shuts down! Sometimes the fan is normally working, but rarely.

I was seaching the web, but there’s no help and no solution. The only way is starting with “acpi=off noapic”. The fan is normally working, but Linux can’t control and show the temperature, like the battery.

Last week I was starting the Live-CD kubuntu 9.10 … no way, the fan wasn’t working.

Analysing the boot-messages (with acpi=on, the normal way) I found with “dmesg | grep acer” this line:

acerhdf: Acer Aspire One Fan driver, v.0.5.16
acerhdf: unknown (unsupported) BIOS version Acer      /Aspire 5315     /V1.33, please report, aborting!

Perhaps the problem? Actually I’m approching the auther of acerhdf (


i had this same problem,i have an acer aspire 5315,and had overheating issues with open suse 11.2,ubuntu 9.10,and every other distro with a new kernel!the fix was i had to update my bios sys.
i dont know the link right off,but ill look around,i found the fix and the bios flash on the ubuntu forums,but you may find an update on the acer site?not sure.hope this helps!!:wink:

another thing with the above post!!
WARNING!!make sure you get the right bios flash for your system.
flashing the bios with the wrong flash can permanently destroy your computer.also after i flashed my bios i got the blue screen of death in windows,and had to even though this will fix your problem,be prepared,back up everything on windows!!!

My wife had this problem and I searched high and low for the answer and finally came across it. I updated the bios to 1.45 and then, and this is the part everyone else is missing, went on to acers help and support centre and downloaded the acer epowerment management bar, this is what regulates the fans on the aspire, and if you have installed windows xp or 7 chances are you have overwritten and deleted the acer bar along with vista!!

My laptop had an overheating problem as well. It is not a software issue. Simply remove the bottom cover and remove the cpu fan. There is probably dust between the fan and the heat sink. Clean the dust from between the fan and heat sink and you’ll be amazed how much better it cools the cpu. Enjoy!

I also have an Aspire 5315. I have tried several linux distributions. The only one that allowed the fan to operate normally was a Crunchbang-9.04.01 another distro of Crunchbang did not operate the fan.

I too had this problem with my Acer Aspire 5315, but solved it using this solution: I am not an expert, but this worked:
I’m running OpenSuse 11.3 on this laptop as it’s sole OS.

Download acer_fancontrol.tar.gz from:
This tar.gz contains 2 files, acer_fancontrol and mempat.
Modify the acer_fancontrol script to match your hardware (It is set up for a 2GB 5720Z as it is).
Pick the memory size which matches your memory size
gedit acer_fancontrol

Install to /usr/bin/:
cp acer_fancontrol /usr/bin/acer_fancontrol
cp mempat /usr/bin/mempat

Create a new service in /etc/init.d (creates a new file for editing):
gedit /etc/init.d/acer_fan

Copy and paste the code below into acer_fan:

#! /bin/sh -e


Provides: acer_fan

Required-Start: $syslog $time $local_fs

Required-Stop: $syslog $time $local_fs

Default-Start: 2 3 4 5

Default-Stop: S 0 1 6

Short-Description: Acer fan control

Description: Make the bloody fan work so this laptop stops overheating and shutting down


set -e


test -x /usr/bin/acer_fancontrol || exit 0

. /etc/rc.status

case “$1” in
exec $DAEMON &
rc_status -v
killall -q $DAEMON
rc_status -v
$0 stop
$0 start
echo “Usage: /etc/init.d/acer_fan {start|stop|restart|force-reload}”
exit 1

exit 0

End of script ----------------------------------------------------------------------

Save the script.
Make sure acer_fan is set to executable:
chmod 700 /etc/init.d/acer_fan

In YAST->System->Services(Runlevel) Acer Fan Control will now be found as a service, enable it and start it. Job done (hopefully!).

Works on Acer Aspire 5715Z openSUSE 12.1 64bit ! Thank you