Acer Aspire 5022 wlan doesn;t work

Hello there guys

I installed 2 days ago openSuSE 11.1 Gnome on my laptop (acer aspire 5022) everything works great except 2 things. Media player and wlan.
So i followed all the instructions from the Sticky , installed new firmware but nothing works :frowning:

So here are my results from the terminal:
Vostok@linux-88ks:~> /sbin/lspci
.
.
.
06:05.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
06:06.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
06:06.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host Controller
06:06.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller
06:06.4 SD Host controller: Texas Instruments PCI6411/6421/6611/6621/7411/7421/7611/7621 Secure Digital Controller
06:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)

Vostok@linux-88ks:~> /sbin/lspci -n
06:05.0 0280: 14e4:4318 (rev 02)
.
.
.
06:06.0 0607: 104c:8031
06:06.2 0c00: 104c:8032
06:06.3 0180: 104c:8033
06:06.4 0805: 104c:8034
06:07.0 0200: 10ec:8169 (rev 10)

Vostok@linux-88ks:~> dmesg|less
.
.
.
input: b43-phy0 as /devices/virtual/input/input7
firmware: requesting b43/ucode5.fw
firmware: requesting b43/pcm5.fw
firmware: requesting b43/b0g0initvals5.fw
firmware: requesting b43/b0g0bsinitvals5.fw
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Registered led device: b43-phy0::tx
Registered led device: b43-phy0::rx
Registered led device: b43-phy0::radio
ADDRCONF(NETDEV_UP): wlan0: link is not ready
__ratelimit: 4 callbacks suppressed
b43-phy0: Radio hardware status changed to DISABLED

Vostok@linux-88ks:~> /usr/sbin/iwconfig
lo no wireless extensions.
eth0 no wireless extensions.
wmaster0 no wireless extensions.
wlan0 IEEE 802.11bg ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
pan0 no wireless extensions.

Vostok@linux-88ks:~> sudo /usr/sbin/iwlist scan
root’s password:
lo Interface doesn’t support scanning.
eth0 Interface doesn’t support scanning
wmaster0 Interface doesn’t support scanning.
wlan0 No scan results
pan0 Interface doesn’t support scanning.

Any suggestions of how can i fix my wlan?
Regards Leon

I suppose it is that there is not controller for the bus card that the wlan is plugged on so there that is why wlan is disabled :frowning: anyone know how i can fix this?

vostok leon wrote:
> I suppose it is that there is not controller for the bus card that the
> wlan is plugged on so there that is why wlan is disabled :frowning: anyone know
> how i can fix this?

When you entered ‘/sbin/lspci’, did you really get nothing? If so,
either your lspci is messed up or your computer doesn’t have a PCI
buss. The latter situation only happens for embedded machines and is
unlikely here.

Well when i type it i get this:
Vostok@linux-88ks:~> /sbin/lspci
.
.
.
06:05.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
06:06.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
06:06.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host Controller
06:06.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller
06:06.4 SD Host controller: Texas Instruments PCI6411/6421/6611/6621/7411/7421/7611/7621 Secure Digital Controller
06:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)

I am really noob with pcs so i don’t know what exactly happens , but it shows the wireless.
At least i think so. in the first post i have everything from the commands from the sticky and i copy-pasted my results.

:X

Looks like you need the b43 driver/firmware, have a look in the stickies for how to get/install

Andy

in post 6# in this listing

http://forums.opensuse.org/network-internet/wireless/405678-bcm4318-opensuse-11-1-a.html

larry finger commented

There are three different ways you can control the BCM4318:

(1) ndiswrapper with the Windows driver,

(2) the Broadcom wl driver and

(3) with b43.

These 3 are mutually exclusive - you may pick ONLY one of them.

In addition, only the third option needs external firmware. The other two have the firmware built into the driver. They can do that because Broadcom wrote the Windows driver.

… I recommend the b43 option as it will not need to be updated whenever the kernel is changed. If that is what you want, install the firmware using the method outlined in the stickies. Once that is done, you should see files in /lib/firmware/b43.

From there, all you need to do is set NetworkManager in control of your network devices and configure the connection using the NM applet.

One “gotcha” is that you will need wpa_supplicant to be installed. NM uses it, even when it isn’t needed.

the howto for b43 seems to be in deltaflyer’s stickie

Welcome - openSUSE Forums

and the summary, if he can accept such being posted, is:

if you have a broadcom chip-set, & a wired connection, this command, in a console, may help
Code:

sudo /usr/sbin/install_bcm43xx_firmware

To install the BCM43xx firmware if you do not have a connection in Linux, do the following:

Using any method that you have to access the Internet, download this
http://mirror2.openwrt.org/sources/b...0.10.5.tar.bz2

Then copy it into your home directory. Once you have it there, you should enter the following:

tar xjf broadcom-wl-4.150.10.5.tar.bz2
sudo mkdir -p /lib/firmware
sudo b43-fwcutter -w /lib/firmware \ broadcom-wl-4.150.10.5/driver/wl_apsta_mimo.o

These three commands will skip the download step and extract the firmware in the same way that the /usr/sbin/install_bcm43xx_firmware does.

good luck