Acer Aspire 4741 | OpenSuse 12.1 | Brightness Adjustment Problem

Hi, Guys. I’m new user of OpenSUSE

I have a Acer Aspire 4741 running openSUSE 12.1 GNOME version
And my Laptop run Intel Graphic

before using OpenSuse, I use Ubuntu as my Linux OS on Laptop. I got problem to adjusting screen brightness.
On Ubuntu I can run this command: sudo gedit /etc/default/grub

then I Change the line GRUB_CMDLINE_LINUX="" into
GRUB_CMDLINE_LINUX=“acpi_osi=Linux”

sudo update-grub

Restart my Ubuntu

My Question, can the same method used to adjusting my screen brightness?

Sorry for my bad english, I’m Indonesian :slight_smile:

On 11/28/2011 12:56 PM, troyarthurw wrote:
>
> My Question, can the same method used to adjusting my screen brightness

yes and NO!

yes: adding ‘acpi_osi=linux’ to the boot parameters is likely to do what
you wish (but, it may not because you undoubtedly are running a
different kernel in openSUSE…

you can check that it works ok by: when the first green boot screen
comes up just START typing acpi_osi=linux and the automatic boot
sequence will pause and what you type will be seen on the “Boot Options”
line…

give it a try, if that line doesn’t do what you want post again and
say so…

if that works with your new kernel then you do need to add the info to
the grub file, but you can not do it in the same way, instead do it this
way:

  • open YaST > System (on left) > Boot Loader (on right) and a new window
    pops up, in that window is the list of all the choices available to you
    when that first green screen comes during boot…most likely, the top
    line will have a check mark by it (meaning that is the line which was
    last booted and what will be default booted) and that line will be
    highlighted (blue here)…

-with that default, and checked, line highlighted single left click on
the “Edit” button at the bottom

-the window changes…look down in the “Section Settings” area and find
the “Optiona Kernel Command Line Parameter” (last line) and there will
be a long string of commands already there…

-CAREFULLY add at the very end, one space and then


acpi_osi=linux

and then click on “Ok”

NOTE: you had written ‘acpi_osi=Linux’ with a capital letter in
Linux…i believe it should be a small l…

> Sorry for my bad english, I’m Indonesian :slight_smile:

your english is great!!


DD http://tinyurl.com/DD-Caveat
openSUSE®, the “German Engineered Automobiles” of operating systems!

Thanks Guys, its work like a charm!!
God bless… :slight_smile:

On 11/29/2011 04:26 AM, troyarthurw wrote:
> Thanks Guys, its work like a charm!!

welcome!!!


DD