Acer 5830g no sound on speaker but headphones works.

my laptop is acer 5830g, i5 2450m ram 2gb, ive used linux mint for about 1 year, everything ok ,i have just installed opensuse 13.1 few days ago… it works perfectly but today, the speaker suddenly doesnt work…, but the headphone works… i dont know what is happening to my speaker, i try to add option model in 50-sound.conf to generic, acer, acer-sprite, try to change output to another output and headphones, try to change the volume from 0% to 100% , it also doesnt work, help me plz,im a newbie on linux, tks everybody… sorry about my bad English

Install pavucontrol. You should able to use this to point to the ouput you want the sound to go for each app that uses sound.

tks for your reply, i also installed pavucontrol, i opened it , sound control bar still work (hope you will know what i say :slight_smile: ), and i set output to speaker ,it still doesnt work, but headphone works… , i also update alsa, pulseaudio, but still doesnt work…

Could you run the diagnostic script alsa-info to provide more information ?

You can do so with your PC connected to the internet by opening an Xterm / konsole and typing:


and select the SHARE/UPLOAD option. When the script ends, in the konsole / terminal will be listed the web/internet address where the diagnostic information has been uploaded to. Post that web address here in this thread. We can look at that and see if it offers any insight to the problem.

Apologies for stating something obvious, but note that if headsets are plugged in, the speakers will be muted.

When you run the alsa-info diagnostic script, please ensure you have those options removed and have rebooted since removing them.

Do you show multiple sound devices in Yast? If so try changing the order

thank for reply :), this is my diagnostic information :, hope you find the solution :), thank you:)

oh,im sorry , i forgot that yesterday i removed alsa and pulse audio, then i reinstall them with the script : zypper in alsa and zypper in pulseaudio… then now the Sound selection in Hardware disappears… so many problem with the speaker…

I note this in the script:

!!Aplay/Arecord output

APLAY line 118: aplay: command not found

ARECORD line 122: arecord: command not found

!!Amixer output

!!-------Mixer controls for card 0 [PCH] line 143: amixer: command not found line 144: amixer: command not found

no amixer ?? no aplay ?? no arecord ??

It reads to me that you did not install all the packages that you removed. It reads that ‘amixer’ and ‘aplay’ and ‘arecord’ are missing, for one. Do you have alsa-utils installed ? If not , install that app (alsa-utils), reboot and then test again.

ive just installed alsa-utils, this is my new infomation :;)

and your PC’s speaker is muted in your mixer. From that script:

**Simple mixer control 'Speaker',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 74
  Front Left: Playback 0 **[0%]** -74.00dB] [on]
  Front Right: Playback 0 **[0%]** -74.00dB] [on]

You need to unmute your PC’s speaker.

Try this command in a konsole/xterm, to turn ON your speaker:

amixer -c0 sset 'Speaker' on 100%

In hindsight - 100% may be a bit too much. Try something smaller first, such as 70%:

amixer -c0 sset 'Speaker' on 70%

thank you,i tried this command, but it still doent have sound on speaker :frowning:

Its possible in doing such you affected another mixer setting. Please provide the output URL again of the diagnostic script so I can check the settings :


uhm, this is my new diagnostic infomation :

Your PC’s speaker is set to 0% volume. Its almost as if you sent that command to unmute/switch on the speaker, and then did something else to the mixer, which muted the speaker ?

Note this:

**Simple mixer control 'Speaker',0**
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 74
  Front Left: Playback 0 **[0%]** -74.00dB] **[on]**
  Front Right: Playback 0 **[0%]** -74.00dB] **[on]**

With 0% playback for volume , the sound from the speakers can not possibly be heard. It needs to be set to a higher % value. That control MUST be in your PC’s mixer.

Do you know why the volume was set back to 0% ? Can you retrace what actions you performed, after sending the ‘amixer’ command that I recommended you try ?

Did you get any error messages when you sent that command ? I may have had the syntax wrong.

after sending ‘amixer’ command, i found that my speaker didnt work, i did nothing and just restarted my laptop and checked mixer volume, the control volume bar didnt set as mute but the speaker didnt work… I remember that few days ago the speaker sometimes didnt work, i must restart my laptop several times to get it work, but now restart is useless, the speaker still doesnt work… oh, i’ve just remember that I also have same problems with Linux Mint and eOS disbtribution, but in windows ive never had this problem :. anyway, thank for your support, hope you can find the solution for me;)

few days ago, i update some software in Online Update, so does it cause any problem to my speaker…