ACER 5750 wireless

Thought wireless problems with Linux were a thing of the past but having bought a new Acer Aspire 5750 have tried for many many hours now, to get the laptop to connect through wireless to the net.

Have searched through the forums with various solutions trying some where familiar causes and googling various bash commands to try to understand what I am doing.

Network Manager shows the wireless option grayed out.
fn F3 key does not perform any action

Any help please because only two solutions I can see are sell laptop and buy toshiba (old one that ran wirelesss OK) or just use preloaded windows 7, both of which are ideally unpalitable.

Many thanks

iwconfig returns

stevenfuller@linux-ztt9:/> iwconfig
eth0 no wireless extensions.

lo no wireless extensions.

rfkill list returns

stevenfuller@linux-ztt9:/> /usr/sbin/rfkill list
0: acer-wireless: Wireless LAN
Soft blocked: no
Hard blocked: no

lspci -nnk returns

02:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57785 Gigabit Ethernet PCIe [14e4:16b5] (rev 10)
Subsystem: Acer Incorporated [ALI] Device [1025:0504]
Kernel driver in use: tg3
02:00.1 SD Host controller [0805]: Broadcom Corporation NetXtreme BCM57765 Memory Card Reader [14e4:16bc] (rev 10)
Subsystem: Acer Incorporated [ALI] Device [1025:0504]
Kernel driver in use: sdhci-pci
02:00.2 System peripheral [0880]: Broadcom Corporation Device [14e4:16be] (rev 10)
Subsystem: Acer Incorporated [ALI] Device [1025:0504]
02:00.3 System peripheral [0880]: Broadcom Corporation Device [14e4:16bf] (rev 10)
Subsystem: Acer Incorporated [ALI] Device [1025:0504]
03:00.0 Network controller [0280]: Broadcom Corporation BCM43227 802.11b/g/n [14e4:4358]
Subsystem: Foxconn International, Inc. Device [105b:e040]
Kernel driver in use: bcma-pci-bridge

/var/log/networkmanager shows

<info> NetworkManager (version 0.9.6.4) is starting…
2013-05-05T10:23:33.487095+01:00 linux-ztt9 NetworkManager[514]: <info> Read config file /etc/NetworkManager/NetworkManager.conf
2013-05-05T10:23:33.487643+01:00 linux-ztt9 NetworkManager[514]: <info> WEXT support is enabled
2013-05-05T10:23:33.748306+01:00 linux-ztt9 NetworkManager[514]: <info> VPN: loaded org.freedesktop.NetworkManager.openvpn
2013-05-05T10:23:33.749805+01:00 linux-ztt9 NetworkManager[514]: <info> VPN: loaded org.freedesktop.NetworkManager.pptp
2013-05-05T10:23:33.749815+01:00 linux-ztt9 NetworkManager[514]: <info> VPN: loaded org.freedesktop.NetworkManager.vpnc
2013-05-05T10:23:34.493541+01:00 linux-ztt9 NetworkManager[514]: <info> Loaded plugin ifcfg-suse: (C) 2008 Novell, Inc. To report bugs please use the NetworkManager mailing list.
2013-05-05T10:23:34.493826+01:00 linux-ztt9 NetworkManager[514]: <info> Loaded plugin keyfile: (c) 2007 - 2010 Red Hat, Inc. To report bugs please use the NetworkManager mailing list.
2013-05-05T10:23:34.494029+01:00 linux-ztt9 NetworkManager[514]: keyfile: parsing Wired connection 1 …
2013-05-05T10:23:34.495641+01:00 linux-ztt9 NetworkManager[514]: keyfile: read connection ‘Wired connection 1’
2013-05-05T10:23:34.587300+01:00 linux-ztt9 NetworkManager[514]: <info> trying to start the modem manager…
2013-05-05T10:23:34.590151+01:00 linux-ztt9 NetworkManager[514]: <info> monitoring kernel firmware directory ‘/lib/firmware’.
2013-05-05T10:23:34.591932+01:00 linux-ztt9 NetworkManager[514]: <info> rfkill0: found WiFi radio killswitch (at /sys/devices/platform/acer-wmi/rfkill/rfkill0) (platform driver acer-wmi)
2013-05-05T10:23:34.593106+01:00 linux-ztt9 NetworkManager[514]: <info> WiFi enabled by radio killswitch; enabled by state file
2013-05-05T10:23:34.595310+01:00 linux-ztt9 NetworkManager[514]: <info> WWAN enabled by radio killswitch; enabled by state file
2013-05-05T10:23:34.595319+01:00 linux-ztt9 NetworkManager[514]: <info> WiMAX enabled by radio killswitch; enabled by state file
2013-05-05T10:23:34.595323+01:00 linux-ztt9 NetworkManager[514]: <info> Networking is enabled by state file
2013-05-05T10:23:34.595330+01:00 linux-ztt9 NetworkManager[514]: <warn> failed to allocate link cache: (-10) Operation not supported
2013-05-05T10:23:34.595334+01:00 linux-ztt9 NetworkManager[514]: <info> (eth0): carrier is OFF
2013-05-05T10:23:34.597288+01:00 linux-ztt9 NetworkManager[514]: <info> (eth0): new Ethernet device (driver: ‘tg3’ ifindex: 2)
2013-05-05T10:23:34.597305+01:00 linux-ztt9 NetworkManager[514]: <info> (eth0): exported as /org/freedesktop/NetworkManager/Devices/0
2013-05-05T10:23:34.597309+01:00 linux-ztt9 NetworkManager[514]: <info> (eth0): now managed

Steven no one will see this here. I’ll move it to the wireless forum. Check it there.

Please use CODE tags around every of your compter text parts. It is the # button in the toolbar of the editor.

Thanks for the replies guys

Is it something I’m doing wrong on the forum or such an odd problem?

On 05/08/2013 03:56 PM, StevenFuller wrote:
>
> Thanks for the replies guys
>
> Is it something I’m doing wrong on the forum or such an odd problem?

I do not see any posts regarding your problem. The only previous post has to do
with using code tags. Keep in mind that I do not, in general, read any wireless
posts not in the wireless forum - that is a quirk of mine.

I have no idea what wireless card is in an Acer 5750, and I do not plan on doing
any research about it. That is also a quirk of mine.

Dear StevenFuller,

To begin with you started your thread, that clearly (to me, not to you?) was a question about wireless, not in the Wireless subforum. Thus you should not wonder that those that are fluent with wireless problems did not see it.

Second thing to draw the attention of the people you need is of course a good title to your subject. And the subject is the wireless, not the box. Thus mention the wirelass card in your title.

And the “sticky” threads at the top of the Wireless forums do tell you how to gather the information that is needed to help you.

Third is not an error of you in person, because it is not obvious from the forums when you use them, but to make coomputer text readable here, you should use CODE tags as said above. And the copy/paste should include the prompt and the command and the next prompt so that one can see this is complete. And then there is not need to say superfluous things like

iwconfig returns

because it is all between theCODE tags.

Some people lost track of your problem whjile it being moved to wireless. Maybe you can add a new post with the information as required by the stickies (and using the CODE tags) to make a fresh start.

Thanks for the reply Henk.

Obviously the forums are more formatted than I had gathered from using them 8 times or so.
Looks like I had cut short the extract detailing the wireless card, error on my part, otherwise thought I had tried to give as much info as I was aware of.
The title was wrt Acer 5750 because having spent a looong period (in excess of 12 hours) trying to sort this myself with limited knowledge I believed the problem was one of actually enabling the card which I pressumed was a fn key on the Acer not working correctly,

Never mind at least windows 7 works, pains me to say it, but yes worked straight out of the box.

Cheers lads