Accidentally removed kdm. how to fix it?


I have opensuse 12.3 with kde desktop installed.
Accidentally I removed the kdm package and some xorg packages along with it. Now I can only login through the console.

I can’t exactly find out what packages are lost. there were 10-15 packages in the list as far as I can recall!
Is it possible to install and configure the kdm and x windows from command line to bring back the kde desktop?

You can use YaST ncurses interface to correct the issue, or perhaps use zypper to verify/rectify the missing packages

zypper ve

Hm, if I try to remove the kdm package on my system, no other packages would get removed…

Just install it again:

sudo zypper in kdm

Needed xorg packages should be installed as well automatically.

I can’t exactly find out what packages are lost. there were 10-15 packages in the list as far as I can recall!

Well, how did you remove it?
The removed packages should be listed in some logfile.


$sudo -u root /sbin/yast
root's password:

This will open yast-ncurses
press tab once and then press down arrow to choose “software management”
There under Alt+D menu you will find verify

Thanks for the answers.
I managed to install the lost packages. There was a list of removed packages in /var/log/zypp/history.

Now i can log into the kde plasma desktop but there is another problem.
Everything seems to be flipped upsidedown!
I took a picture of the bottom corner of the screeen. it’s part of the taskbar and a Konsole window:

Glad you sorted it out! :slight_smile:

Everything seems to be flipped upsidedown!

Seems like your screen is rotated.
Please have a look in Configure Desktop (aka systemsettings)->Display and Monitor->Size and Orientation.
Or try to type this in the konsole:

xrandr --output VGA-0 --rotate normal

Of course you have to exchange “VGA-0” with the input your monitor is connected to.
You could also use krandrtray for this.

none of the --reflect & --rotate parameters of xrandr could set the screen to normal, neither did setting rotation in the Size & Orientation panel.

I’m guessing something’s wrong with my configurations. I have the gnome desktop too and it’s fine. Even in KDE, it’s ok at the begening of the login screen while the splash screen is being displayed. partway through the splash screen it gets flipped!

You can try to rename ~/.kde4 to .kde4_old and start with a default KDE configuration.

Do you have anything in ~/.kde4/env/ that could cause this?

ls -la ~/.kde4/env

I just renamed every .kde & .kde4 directory from the root and the user directory even tried new user, still no luck :frowning:

Did you do this correct. Notice the red part

Screen 0: minimum 320 x 200, current 1360 x 768, maximum 8192 x 8192
**VGA1** connected primary 1360x768+0+0 (normal left inverted right x axis y axis) 410mm x 230mm
   1360x768       60.0*+
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1280x800       74.9     59.8  
   1152x864       75.0  
   1280x768       74.9     59.9  
   1024x768       75.1     70.1     60.0  
   1024x576       60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   848x480        60.0  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
$xrandr --output **VGA1** --rotate normal

Well, does the problem persist if you create a new user (in YaST f.e.) and login with that?
Edit: Sorry, missed the part about the new user…

So it’s a system wide problem, but only with KDE?
Is there anything suspicious in /etc/xdg/autostart/ or /usr/share/autostart/ ?

Finally I found the problem rotfl!rotfl!
it was Nvidia proprietary driver! after removing it everything is alright again.

Thank you guys, I learned a lot today :slight_smile:

Hm, never heard of that.
And strange that this didn’t occur on the login screen and in GNOME then.

If I were you, I would try to install the nvidia driver again and see if the problem reoccurs…:wink:

Now that the driver is gone I can see the gnome environment is smoother than it was before! So in general it did affect the gnome too but in a different way. I didn’t notice it because I only installed gnome to have a desktop to work with while I was trying to fix the KDE.

I will definitely install it again to make my video card switchable. But not now, I’ve had enough troubles for the time being :smiley:

Then there definitely must have been something wrong with your driver installation! :wink:
If you do install it again, make sure your user is in the “video” group.
See the openSUSE release notes

Removing and reinstalling KDE may have reset some graphic programs that NVIDIA modifies. Reinstall NVIDIA should put thing back right for the driver.

Yeah, right. AFAIK the nvidia driver overrides some Mesa libraries on installation (libGL).