Accessing wireless netork totally crashes the machine

Hello,

Perhaps you can help me with a strange new problem I have with my laptop (an MSI GT735, AMD processor, ATI Graphics, 4GB ram).

I have installed 11.2 some time ago and, after some of the ususal teething problems, everything worked OK.

I could connect to my wireless network without any problems.

However, since about a week ago, whenever I make a connection to the wireless network, the machine totally crashes- no keybord ou mouse, CTRL-ALT-Backspace doesn’t work, CTRL-DEL-ALT doesn’t work, in short I have to reboot the machine with the powerswitch.

The problem arises whether I use KDE (4.3.1) or Gnome.

I’m sure that it is the wireless network connection that causes the crash, connecting through Ethernet is not a problem.

I can reproduce the problem by doing the following:

First, I switch off the wireless network with the button provided for to this effect. This is to stop the machine crashing soon after booting into my user account. (I’m always a normal user, not root).

Then I untick “enable wireless” in Knetwork manager (left click on the icon in the tray). Now I’m sure that the machien doesn’t try to connect. I can use the machine now without it crashing at all (and have, several hours - no crash).
N
Then I switch the wireless on again with the button. After that I tick the “enable wireless” icon in Knetwork manager. Then I can see that the machine tries to connect (avtivating the network connection". As soon as it connects - total crash.

I didn’t install anything in the machine at least a week prior to the problem arising. I only update the machine following the recommandations of the update manager.

I also created a new user “test” to see whether it wasn’t something in the configuration of my normal account thatcauses this crash and there I have the same problem.

Even though I don’t usually use Gnome, the problem is there when I log into a Gnome session.

Any ideas, anyone?

Thanks in advance

Lenwolf

There’s a couple of things you can do, to try and solve this.

A week ago, there was a kernel-update. Try rolling it back to the 2.6.31-5 kernel; mind, you may have to downgrade kernel-source manually.

Next, upgrade your KDE4 to 4.3.3; this will include a better knetworkmanager.

What is the wireless card model/chip

Please post output here of ‘dmesg | tail’ right after switching on the wireless.

OK, thanks, I’ll do what you say and roll back to the older Kernel once I find out how, also update to KDE 4.3.3.

I’ll only be able to do that later in the day, when I get home to access the Internet via Ethernet.

Sorry for the missing info, the chip is a Ralink RT 2680 configured as wlan0.

Thanks!

Lenwolf

And here is the dmseg info you asked for:

After switching on wireless with the button:
40.470322] wlan0: no IPv6 routers present
55.080162] atkbd.c: Unknown key pressed (translated set 2, code 0xf6 on isa0060/serio0).
55.080201] atkbd.c: Use ‘setkeycodes e076 <keycode>’ to make it known.
55.085358] atkbd.c: Unknown key released (translated set 2, code 0xf6 on isa0060/serio0).
55.085393] atkbd.c: Use ‘setkeycodes e076 <keycode>’ to make it known.
55.977196] ===>rt_ioctl_giwscan. 13(13) BSS returned, data->length = 2198
110.313956] atkbd.c: Unknown key pressed (translated set 2, code 0xf6 on isa0060/serio0).
110.313996] atkbd.c: Use ‘setkeycodes e076 <keycode>’ to make it known.
110.318835] atkbd.c: Unknown key released (translated set 2, code 0xf6 on isa0060/serio0).
110.318870] atkbd.c: Use ‘setkeycodes e076 <keycode>’ to make it known.

After enabling wireless in knetworkmanager:
223.128449] I/F(wlan0) Key2Str is Invalid key length! KeyLen = 0!
223.128470] I/F(wlan0) Key3Str is Invalid key length! KeyLen = 0!
223.128492] I/F(wlan0) Key4Str is Invalid key length! KeyLen = 0!
223.128746] 1. Phy Mode = 9
223.128753] 2. Phy Mode = 9
223.151772] 3. Phy Mode = 9
223.155355] RTMPSetPhyMode: channel is out of range, use first channel=1
223.156492] MCS Set = ff ff 00 00 01
223.158101] <==== RTMPInitialize, Status=0
223.158225] 0x1300 = 00064300

After asking Knetworkmanager to activate the connection:
285.142616] I/F(wlan0) Key3Str is Invalid key length! KeyLen = 0!
285.142636] I/F(wlan0) Key4Str is Invalid key length! KeyLen = 0!
285.142902] 1. Phy Mode = 9
285.142908] 2. Phy Mode = 9
285.163153] 3. Phy Mode = 9
285.165608] RTMPSetPhyMode: channel is out of range, use first channel=1
285.166728] MCS Set = ff ff 00 00 01
285.168462] <==== RTMPInitialize, Status=0
285.168586] 0x1300 = 00064300
290.235413] ===>rt_ioctl_giwscan. 14(14) BSS returned, data->length = 2368

(then there is the crash)
NB I disabled IP v6 just a few moment ago, hoping it would make a diference, it doesn,'t.

Thanks

Lenwolf

This is going beyond me. Try rolling back to previous kernel first.
Did you have to install a driver for the wireless card? Or compile it yourself? Then the kernel-update may very well be the reason. You would have to rebuild the driver to run with your current kernel.

Thanks for your answer.

The network worked out of the box as soon as 11.2 was installed.

I did not compile any sort of driver or kernel etc…
I just have the plain vanilla system.

This seems to be the same problem as in this thread (?)
openSUSE 11.2 (KDE) freeze on Asus EEE 1000H - openSUSE Forums

I’ll do the kernel rollback this evening.

Thanks for your help!

Lenwolf

One note: you don’t have a plain vanilla system. You have openSUSE, with their kernel-patches etc. Plain vanilla is what Linus Torvald builds.

OK, I was thinking more along the lines of a plain vanilla OpenSuse system (but should have said so…)

Lenwolf.

On 01/14/2010 04:06 AM, lenwolf wrote:
>
> (then there is the crash)
> NB I disabled IP v6 just a few moment ago, hoping it would make a
> diference, it doesn,'t.

As you have some time between switching on the wireless and the crash, it would
be most helpful if someone with an RT2670/RT2680 would do the following:

  1. Before switching on the radio, change to the log console by pressing
    CTRL/ALT/F10.

  2. Write down or photograph the screen contents when the crash occurs.

Thanks.

Rolling back to an earlier kernel did the trick.

See Nabble - opensuse-factory - System freeze with kernel 2.6.31.8 and ralink rt2860/rt2870 on 11.2

Thanks Knurpht!

@lwfinger

OK, I’ve re-installed the newest kernel, reproduced the error and taken photographs of the CTRL-ALT-F10 screen.

Where do I upload them/it (3 x 6 MB, they’re photos of the same screen)?

Lenwolf

On 01/16/2010 01:36 AM, lenwolf wrote:
>
> @lwfinger
>
> OK, I’ve re-installed the newest kernel, reproduced the error and taken
> photographs of the CTRL-ALT-F10 screen.
>
>
> Where do I upload them/it (3 x 6 MB, they’re photos of the same
> screen)?

Thanks, but I already got a usable picture. Please check yours for the following
entries in the middle of the dump trace:

skb_under_panic
skb_push
wlan_802_11_to_802_3_packet
Indicate_Legacy_Packet

If you have those entries and are using a 32-bit system, there is a test kernel
at
http://beta.suse.com/private/bphilips//540589/kernel-desktop-2.6.31.11-bnc540589.0.i586.rpm
for testing. AFAIK, no 64-bit kernel with this test fix is available.

If your dump does not include those entries, please post your photos at
http://pastebin.com/ and post the links.

Alright, I only have the skb_under_panic line, not the others, but I presume that is the same thing.

I can’t post photos to pastebin…

Since I have a 64 bit version of 11.2 I can’t use the patch…

lenwolf