Accessing WAN from Rescue System

Problem: When helping users diagnose a problem, often the DVD Rescue System is used. However, if the user is asked to do a dmsg, lspci, lsmod, cat, etc. - the user does not have a network connection (let alone browser) for posting the output back here, and so is left to doing that by hand. My intention is to use a technique such as curl with to upload the output. Or, sometimes the requirement is to reinstall a broken package or install a missing package or download a needed driver from the net, etc.; my solution would be to mount the user’s root, chroot there, and use zypper or wget - but again, no network connection in the Rescue System.

Question: Is there a straightforward method to establish a WAN connection from the Rescue System?

It appears that, if on the DVD menu a network repository is requested rather than the DVD, the Rescue System will load the network services. However, ifup does not load the network device because there is no ifcfg for it. I worked around this by copying ifcfg-eth<n> from the mounted root, and this did provide a LAN connection; I can ping other machines on the local network. But no WAN - pinging an IP (i.e., not using DNS) returns “network is unreachable”. The connection is through a router, but I am doing nothing different than when making the connection if booted into the production system.

I attempted to get this working with the ip command, but frankly I struggled with the syntax and was left to fall back on getting ifup working.

Any help would be appreciated. Or perhaps there is a much easier approach to accomplish the same end result? (By the way, I also tried making this work through linuxrc, only to have the same result.)