Accessing Samba shares in KDE

Hey,

I’m quite new to KDE. And OpenSUSE. I wonder how to get Samba share access working well…

Dolphin supports Samba but it doesn’t really mount anything, it seems… Non-KDE Applications therefor can’t access samba that way. In Gnome there was a workaround for the same problem. You could simply go to ~/.gvfs in any application and find the samba mounted there.

Is there anything like that in KDE?

I set up a Samba mount via /etc/fstab for now but that is quite annoying because it fails after each Suspend, changing WLAN Access Points, etc. Then I have to go to the console and manually launch sudo mount -a to get it working again.

How can I make things more comfortable?

Thanks
Hachre

P.S.: I’m even up for using something else than Samba to talk to my fileserver. However I don’t know of anything that would work better in this regard. (NFS would have the exactly same problem for example)

you could make sure ssh is enabled and do:

fish://remote_user@LAN_IP
eg:

fish://bob@192.168.0.2

@swerdna has some info on samba
Linux HOWTOs and Tutorials: Suse Linux 10.0, 10.1 openSUSE 10.2, 10.3, 11.0, 11.1

This is a KDE only feature again, isn’t it? I need a solution that also works with Gnome Programs and File Open dialogs that don’t allow you to enter any address.

I’ve read it all. Their solution is also to set it up via /etc/fstab with the resulting problems I mentioned in my original post.

On Wed January 6 2010 04:56 am, hachre wrote:

>
> caf4926;2098980 Wrote:
>> you could make sure ssh is enabled and do:
>>
>> fish://remote_user@LAN_IP
>
> This is a KDE only feature again, isn’t it? I need a solution that also
> works with Gnome Programs and File Open dialogs that don’t allow you to
> enter any address.
>
> caf4926;2098980 Wrote:
>>
>> @swerdna has some info on samba
>> ‘Linux HOWTOs and Tutorials: Suse Linux 10.0, 10.1 openSUSE 10.2, 10.3,
>> 11.0, 11.1’ (http://opensuse.swerdna.org/index.html)
>
> I’ve read it all. Their solution is also to set it up via /etc/fstab
> with the resulting problems I mentioned in my original post.
>
>
hachre;

If you read this:
http://opensuse.swerdna.org/susesambacifs.html
and stop after the discussion of “Temporary Mounts: Prescribing the owner of
the mount on the client” it should meet your criteria. It does require the
use of the terminal to mount the share and as such is not a pure KDE
solution. But it does what you want.

P. V.
“We’re all in this together, I’m pulling for you.” Red Green

On Wed January 6 2010 05:04 pm, PV wrote:

> On Wed January 6 2010 04:56 am, hachre wrote:
>
<snip>
>>
>> I’ve read it all. Their solution is also to set it up via /etc/fstab
>> with the resulting problems I mentioned in my original post.
>>
>>
> hachre;
>
> If you read this:
> http://opensuse.swerdna.org/susesambacifs.html
> and stop after the discussion of “Temporary Mounts: Prescribing the owner of
> the mount on the client” it should meet your criteria. It does require the
> use of the terminal to mount the share and as such is not a pure KDE
> solution. But it does what you want.
hachre;

In retrospect the above comment is likely wrong and does not solve your
problem with suspend.

P. V.
“We’re all in this together, I’m pulling for you.” Red Green

Yea that’s exactly the problem…

I have a workaround now that is quite comfortable… I have put a shell script (kdesu mount -a) into the empty mount point. If the samba is mounted and I enter the mount point I get the data. If it isn’t all I see is the shell script. Once I click that it gets mounted and all is well.