Accessing files on /home/myaccount requires a root password

Duders and Duderettes
Hello all who have helped in the past I do so appreciate it very much!:wink: Thank you.

This is new problem, I was wanting to access some .txt files on my /home/me-account folder and when I did try to open the file it asked for my /root password??? OK,I thought just add me to the root group-nope no go.
This process of accessing a file worked after my 13.2 upgrade from 13.1 so I don’t believe it’s from that process, but I believe it might have happened through one of the online updates.

Any info you need I get let me know.
system is intel duo Q6600
Nvidia 9800 gtx+
Opensuse Harliquin 13.2
KDE, Gnome, E19, and a few others.
It does it in all desktop GUI’s.

thnaks
man
“I’m sure its a easy fix. It always is.”

On 11/17/2014 02:16 PM, bigtrains67 wrote:
>
> Duders and Duderettes
> Hello all who have helped in the past I do so appreciate it very much!:wink:
> Thank you.
>
> This is new problem, I was wanting to access some .txt files on my
> /home/me-account folder and when I did try to open the file it asked for
> my /root password??? OK,I thought just add me to the root group-nope
> no go.
> This process of accessing a file worked after my 13.2 upgrade from 13.1
> so I don’t believe it’s from that process, but I believe it might have
> happened through one of the online updates.
>
> Any info you need I get let me know.
> system is intel duo Q6600
> Nvidia 9800 gtx+
> Opensuse Harliquin 13.2
> KDE, Gnome, E19, and a few others.
> It does it in all desktop GUI’s.
>
> thnaks
> man
> “I’m sure its a easy fix. It always is.”
>
>

Did you check the permissions for the folder? What are they? Its
possible you accidentally set them to something strange.


openSUSE Factory 64 bit
KDE 4.14.1

Thanks for your enquiry. Yes the folders are owned by me and my group. So is the perticulart .txt file I’m opening. I have never had to enter root password for thus particular file since 13.1.

Oh and you should NOT be in the root group. You will break things.

Are you absolutely sure that the file is not owned by root or some other user account??

Does it ask you for the root password or do you just have to become root. Nothing in your home should normally be owned by root or any other user. An old Unix admin trick was to set the rc files owner in the users home to root to keep the user from fiddling with their default settings. But unless you changed it no file or directory should be owned by any but the user and the user group

And even if the file was really owned by root, you shouldn’t be asked for the root password if you try to open it. It should just fail.
So can you please explain how exactly you try to open it?
What exactly are you doing?
What exact error message/dialog/whatever are you getting?

Maybe post a screenshot.

Is this file possibly marked as executable? So it is an script like issue?

then try to open with right click open with gedit/kwrite or push it into the opened editor

Max_Spam wrote
"Is this file possibly marked as executable? So it is an script like issue?

then try to open with right click open with gedit/kwrite or push it into the opened editor "

  1. I checked the file as executable-no!
  2. script issue-no!
  3. try to open with right click to open with gedit/krite. bingo.
    BUT…
    I learnt, hahaha a new trick today! lol!

It seems that a right click on the file in question, and go to properties, there is a selection called “file type options” bring up a window with selection named Application Preference Order!
At the top of my list was guess??? File Manager - Super User. I selected it moved it to the bottom and now all is right with the world.

This is solved
Thanks
everyone

Not sure that the problem is really solved. It could very well raise it’s head again in some other file. You are doing something extremely odd to get things that messed up :stuck_out_tongue:

You appear to have done something very unusual along the way to permissions, groups, owner, or user.

… or a combination of those.

… or, are trying to open in some peculiar way.

The exact operation that you are doing, or full detailed explanation, is required in order to solve the problem permanently. Answer Wolfi’s questions, get further help.

Your little workaround is just that, a workaround. I sense that it will come back to bite you, maybe even quite seriously, down the road.

Good luck.:wink:

Not a bug, but a feature

;)First off thank for the help all!

I haven’t really changed any permissions in Yast or the system. I have a /local folder on /usr that is mine for my flight sim. As far as i can gather the box for File Type Options is allowable for any type file and does effect how the system sees that particular file. The the whole file network.
It was a .txt file that I just pointed to and click on. It would ask for the root password. I just went to File Type Options and moved superuser down the list a bit. the rest of the selections in the list are file opening software. So the system knows what it should use to open it, but Super user was on the top of the list.

Its working now, and if it breaks later I’ll write then. HEY!!! I really like spending time with you peeps. It’s fun gets my head out of work!

Thanks
man

someone in hear i cant remember who is hailing from west by god Virginia. I’m org from VA. want to get back soon miss the mountains. GO HOKIES!!!
hope i don’t get in trouble for that.rotfl!