Access to repository servers blocked.

For the last 6 weeks or more, I am unable to download or update software.
It appears as if the repository servers are simply offline.

The software manager says either “Your system is up to date”, or “You are offline”, depending from which computer I look.

After checking for new software it returns: "Problem connecting to software origin… ".

I am working in the Philippines (South-East Asia), Several computers are connected to the internet via one LAN. The network generally is accessible.
All computers tested are running openSUSE 42.2, Leap and Tumbleweed, and all have been kept updated until the repository servers became inaccessible.

Otherwise the network is accessible without any problems.

I desperately need to download some additional software, which is now impossible.

Can anybody explane what is going on, and whether and when access to the servers will be restored? This could perhaps be a problem with our LAN sytem, but this is unlikely, since no changes have been made to its setup or configuration.

Is it now necessary to open additional ports in the firewalls, which was not necessary before? If so, what are the port numbers?

Thanks in advance for any help.

First course of action - have you checked whether zypper from the command line reports available updates?

Terminal ->
sudo zypper ref; sudo zypper up

Thanks for your answer.
I have been running the following command almost daily on my tumbleweed system:
sudo zypper dup --no-allow-vendor-change
but this has not been working for the last 6 weeks or so. The connection to the
repository server is simply off-line.

Sorry, but showing is better then telling. Thus when you are doing such a zypper statement, then please copy/paste all (the prompt, the command, the output, the next prompt) into your post and between CODE tags (you get them by clicking on the # button in the tool bar of the post editor). Only then we can see exactly what you see and do and we can come to our own conclusions instead of depending on your interpretation and story.

This sounds a bit like we do not trust you, but it is in fact true: we do trust the computer more then people when it comes to analyzing computer problems :wink:

Since there is no connection to the repository server, the only output I get is error messages.
Here follows the output from the zypper command:

egbert@linux-68pt:~/bin> sudo zypper dup --no-allow-vendor-change
[sudo] password for root: 
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Timeout exceeded when accessing 'http://download.opensuse.org/tumbleweed/repo/non-oss/content'.

Abort, retry, ignore? [a/r/i] (r): 
Trying again...
Timeout exceeded when accessing 'http://download.opensuse.org/tumbleweed/repo/non-oss/content'.

Abort, retry, ignore? [a/r/i] (r): 
Trying again...
Timeout exceeded when accessing 'http://download.opensuse.org/tumbleweed/repo/non-oss/content'.

Abort, retry, ignore? [a/r/i] (r): 
Trying again...
Timeout exceeded when accessing 'http://download.opensuse.org/tumbleweed/repo/non-oss/content'.

Abort, retry, ignore? [a/r/i] (a): 
Trying again...
ABORT request: Aborting requested by user
egbert@linux-68pt:~/bin> 

I noticed a news item on the openSUSE website informing that there are activities resulting in reduced
availability or downtime of online services. Could my problem be connected with this? If so, the problem
may be resolved soon. That’s what I am hoping.
Regards
Egbert

No problems accessing “download.opensuse.org” from here in the UK.

Can you access it via a web browser?

Maybe try a traceroute to see where your delay is.

It is most important that we see the error messages. And all around it. And it spares you an extensive explanation. Just post what you see and your helpers can start helping. And that is of course true for all problems, not just for this one. The best way to help your helpers is posting as exact as possible what you do and see.

I tried http://download.opensuse.org/tumbleweed/repo/non-oss/content in Firefox and it shows the contents, thus from my system I can connect. Can you try this URL in a browser and tell us the results?

Or maybe first try

ping -c1 download.opensuse.org

I do not think it is the down time of some services. Nobody else reports this (as you can see in these forums) and it should not be for the long time you experience.

Edit. Just saw tannington’s post. A traceroute is also a good idea.

Since you are located in Asia, perhaps it’s worth trying to change one machines URI’s to point from download.opensuse.org to something else, for example:

http://ftp.kaist.ac.kr/opensuse/

It’s located in Korea and offers normal Leap, Update and Tumbleweed mirrors.

If you want to test this on one machine, please make a backup of the .repo files in advance from /etc/zypp/repos.d/ (copy them somewhere safe!) and run this command;

sudo sed -i 's/download.opensuse.org/ftp.kaist.ac.kr\/opensuse\//g' /etc/zypp/repos.d/*.repo

Do not run this command if you have 3rd party and/or home: repositories added.

If even that doesn’t work, then something is blocking outgoing http connections.

I tried the ping function. here is the result:


egbert@linux-68pt:~> ping -c1 download.opensuse.org
PING download.opensuse.org (195.135.221.134) 56(84) bytes of data.
64 bytes from ftp.opensuse.org (195.135.221.134): icmp_seq=1 ttl=52 time=383 ms

--- download.opensuse.org ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 383.392/383.392/383.392/0.000 ms

after this i tried it without the “-c1”. The result is like this:


egbert@linux-68pt:~> ping download.opensuse.org
PING download.opensuse.org (195.135.221.134) 56(84) bytes of data.
64 bytes from ftp.opensuse.org (195.135.221.134): icmp_seq=1 ttl=52 time=383 ms
64 bytes from ftp.opensuse.org (195.135.221.134): icmp_seq=2 ttl=52 time=382 ms
64 bytes from ftp.opensuse.org (195.135.221.134): icmp_seq=3 ttl=52 time=383 ms
64 bytes from ftp.opensuse.org (195.135.221.134): icmp_seq=4 ttl=52 time=381 ms
64 bytes from ftp.opensuse.org (195.135.221.134): icmp_seq=5 ttl=52 time=382 ms
64 bytes from ftp.opensuse.org (195.135.221.134): icmp_seq=6 ttl=52 time=382 ms
64 bytes from ftp.opensuse.org (195.135.221.134): icmp_seq=7 ttl=52 time=382 ms
64 bytes from ftp.opensuse.org (195.135.221.134): icmp_seq=8 ttl=52 time=382 ms
^C
--- download.opensuse.org ping statistics ---
8 packets transmitted, 8 received, 0% packet loss, time 7002ms
rtt min/avg/max/mdev = 381.876/382.593/383.518/0.615 ms

ping works, but updating and software management is still “update”.

I have tried to access “download.opensuse.org” with browsers. The results were as follows:
Firefox: tried to connect for about 120 seconds, then stopped silently.
SeaMonkey: the same as Firefox.
Konqueror: after about 20 seconds “The requested operation could not be completed. Timeout Error”
This is all very strange indeed.
Egbert

(Why to do multi pinging, one ping is enough to test)

My conclusions from this: you can reach the system, but you are not allowed to connect to port 80 (HTTP) there.

Did you try Miuku’s suggestions to use a different mirror?

It looks indeed that somewhere the system connecting to web sites (ate least this one) is blocked. Your router, your ISP, ???

Hi
Add some verbosity and force a refresh to your commands so can see what it’s trying to do…


zypper -vvvvv ref -f

Thanks very much indeed for your kind help!!!
I was able to access the Korean openSUSE mirror without any problem.

Since it was now obvious that either the modem (ISP) or the router must be faulty in some way, I bought a new router and replaced the previous router. After that, the problem was solved. It was obviously not enough to restart modem and router, which I have done many times.

I’m also in the Philippines, and I’m having the same exact problem. So I’m now reporting it as you can see here.
Here’s some things I tried:

# **traceroute download.opensuse.org**       
traceroute to download.opensuse.org (195.135.221.134), 30 hops max, 60 byte packets
 1  192.168.1.1 (192.168.1.1)  0.955 ms  1.404 ms  1.859 ms
 2  112.208.192.1.pldt.net (112.208.192.1)  21.373 ms  21.893 ms  22.277 ms
 3  * * *
 4  210.213.130.197.static.pldt.net (210.213.130.197)  62.112 ms  62.911 ms  62.502 ms
 5  las-b3-link.telia.net (62.115.13.128)  198.325 ms  197.104 ms  193.795 ms
 6  las-b24-link.telia.net (62.115.115.144)  195.880 ms  175.631 ms  179.814 ms
 7  nyk-bb3-link.telia.net (62.115.138.100)  265.957 ms  262.817 ms *
 8  nyk-b5-link.telia.net (62.115.115.1)  263.315 ms nyk-b5-link.telia.net (80.91.254.14)  270.261 ms  269.762 ms
 9  ae1-1299.nyk10.core-backbone.com (80.239.161.218)  327.401 ms  323.700 ms  323.392 ms
10  ae2-2001.nbg30.core-backbone.com (81.95.15.161)  337.048 ms  338.894 ms  336.162 ms
11  core-backbone.microfocus.com (5.56.18.210)  330.148 ms  325.650 ms  326.391 ms
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

# **ping -c3 download.opensuse.org**
PING download.opensuse.org (195.135.221.134) 56(84) bytes of data.
64 bytes from ftp.opensuse.org (195.135.221.134): icmp_seq=1 ttl=44 time=330 ms
64 bytes from ftp.opensuse.org (195.135.221.134): icmp_seq=2 ttl=44 time=330 ms
64 bytes from ftp.opensuse.org (195.135.221.134): icmp_seq=3 ttl=44 time=327 ms

--- download.opensuse.org ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2001ms
rtt min/avg/max/mdev = 327.941/329.601/330.627/1.274 ms

# **lynx http://download.opensuse.org**
                                                                                                                                              
Looking up download.opensuse.org
Making HTTP connection to download.opensuse.org
Alert!: Unable to connect to remote host.

lynx: Can't access startfile http://download.opensuse.org/
#