Access to network backup HDD asking for user & password

Since the update and a reinstall, I have to enter credentials to access my network back up HDD connected to my router.
I didn’t have to do this before the update(& re-install).

Anyway to automate this login to the Network HDD?

ADDED> I just checked the router again and it has NO password needed for Read & Write access for network units.

Still looking for help with this. Regardless what how I set it up, it always wants a UID and PWD the first time I open the storage HDD. PITA!!
As stated in post #2, my router does not require this information to access it.

Is the system(since the latest Leap upgrade) requiring that?
I do have that nagging KDE Wallet thing disabled!

Any help to bypass the stupid login requirement?

I already do not quite understand this. Are you talking about an update and then reinstallation of openSUSE 15.3? What is the reason of mentioning that update when you reinstalled over it?

**NO! I’m talking about an UPGRADE!
I had 15.2, and a link to my external storage drive THAT DID NOT ask for credentials!
Then along came the UPGRADE(NOT fresh install) to Leap 15.3 and when I opened Dolphin, clicked on the External Drive in ‘places’
IT Didn’t do that from Leap 42.2 through Leap 15.2.? (And BTW, I have always had that nagging KDE Wallet thing disabled)

SO? WHY is it now after the UPGRADE from 15.2 to 15.3 , I am asked for UID and PWD to MY External storage drive?

CLEAR NOW? or still muddy waters??

BTW, It does the same thing in a fresh install on my HP AIO.

Hi Bill. I think this is a KDE thing.

From a terminal, passwordless share access can be tested using smbclient with something like

smbclient //<server>/<share> -N

That should result in the ‘smb: &gt;’ prompt, where you can list files etc. Type ‘exit’ to get back to the shell prompt.

However, with the Dolphin file manager, I get the authentication prompt for such a share as well. Entering any username and password suffices. However, I do use KWallet so not an issue for me. (That can be made to be open on login for convenience if desired.)

FWIW, A long-running KDE thread discussing the same…

No need to start shouting. You first said in post #1

Since the update and a reinstall

It is not my fault when you say the one and mean the other.