Access to drive after reboot

I have a dual boot setup with the OSs on an SSD and data on an older, larger HD. My “real” home directory is on this second drive. Each time I want to access the drive to get to my documents, I have to find it in dolphin and give the root password to access the drive. I tried to put a shortcut to the document folder in “places” in dolphin and to link to the folder on the desktop. Neither will survive a reboot. Clicking on either gives a file not found message that starts with “run/media and a very long string of numbers”

I’m assuming this is a permissions issue. How can I fix it?

It is a bit confusiing.

Are you talking about /home or about /home/prexy? What is a “real” home?

When you want a file system to be mounted at boot, it should of course be in your /etc/fstab. Best to do this using YaST > System > Partitioner. Find the partition and edit it. You should of course check that it is NOT FORMATTED anew! But you can enter the mount point there. YaST will create the mount point when needed (but I guess it is already there as you use it by manualy mounting on it), create the fstab entry (for mounting at each boot) and mount it then and there.

I thought I answered this post… but don’t see it. Once again, I have to hit the return key to get the space bar to work on this forum. Odd, but not aggravating.

I put “home” in quotes because I realize it is not the home recognized by 42.2, but the leftover from a previous install. I set it up that way to save space on the SSD. I sometimes have to give the root password to access this drive in dolphin. Any link I use in dolphin or directly on the desktop does not persist. I am leaving a copy of dolphin open so that the data on the HD is more easily accessible to me. What I am trying to accomplish is to be able to make a link in dolphin or the desktop that persists through reboots or the closing of the dolphin window.

When you want to mount a file system (on a partition) on a mount point every time the system boots, it should be configured in /etc/fstab. Like all “permanent” file systems are (e.g. / and on most systems /home)

YaST can help you there.

I may be wrong, but I have the idea that this might provide you with some basic knowledge:,_filesystems,_mount_points

If you’re not logged in as root by default (which would be reasonable) then dolphin can not do that job for you.

As Henk wrote before, use YaST->partitioner.

On the left hand side in YaST->partitioner in “System View” click on “Hard Disks”.

Then you can edit any partition and its mount point (take care not to format a partition then which you might still need), and you can there select that some partition is mounted at boot, which to me seems what you want to achieve.

You can not achieve this using dolphin as a standard (non-root) user.

I went to the yast partitioner to set the drive in question (sbd7) to mount. It was already set to mount. I changed nothing and backed out of the partitioner. I saw no other options in yast either.

On a separate issue, each time I reboot and open Google Chrome, it asks if I want it to be the default browser and I always check “yes” but that also does not survive a reboot. So, I opened System—>Configure Desktop and set it as the default application. While there, I changed the default Document path to the one I wanted, hoping that would be the answer.

However, when I rebooted, I got the familiar error of “file not found” or “does not exist” when I tried to open dolphin in the desired location. I tried to open a doc and then save a doc in LibreOffice in the desired location but it had reverted to the old, undesired, location. Similarly, Google Chrome was no longer the default app.

To further confuse things: after having set the path to the desired location, when I click on the HOME icon on the desktop, I hear the HD (sdb) spin up. Yet it opens to the HOME on the SSD. I put a link, labeled prexy, in the left hand panel of dolphin to my desired documents location and when clicked gives this familiar error message

The file or folder /run/media/prexy/35180773-6643-49c5-86b9-6d6d29e458d5/prexy does not exist

I just opened a root dolphin and confirmed that the path shown in the error message exists and is the location of my docs etc.

This is really inconvenient.

I am loosing contact with what you are trying to tell us. I get the idea that you are mixing two different problems in one thread. When that is the case, please stop that, it is very confusing. When that is not the case, the I applogize, but I find your whole story very confusing and without factual and logical steps.

Then please show us things. When it is already in your /etc/fstab we (and you) can only prove that to our/yourselve by looking there:

cat /etc/fstab

And when your conclusion is that it is not mounted, the again show us:


I admit that describing what one does and sees in a GUI interface in a way that others can understand it is not very easy. Not at last because many people may never do what you try to do. E.g., when you say you"click on the HOME icon", I am already lost.

When you want to see for yourself and in the same time to us, if a file does or doesn’t exist, use

ls -l /run/media/prexy/35180773-6643-49c5-86b9-6d6d29e458d5/prexy

Telling us what you think that some desktop application shows you, isn’t really showing hard facts.

The first requested item

cat /etc/fstab
UUID=2a06d368-f173-4d76-9094-e7959565072f swap swap defaults 0 0
UUID=09572f52-e05e-44bd-bfa7-2a4d533e6aa3 swap swap defaults 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e / btrfs defaults 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /boot/grub2/i386-pc btrfs subvol=@/boot/grub2/
i386-pc 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /boot/grub2/x86_64-efi btrfs subvol=@/boot/gru
b2/x86_64-efi 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /opt btrfs subvol=@/opt 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /srv btrfs subvol=@/srv 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /tmp btrfs subvol=@/tmp 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /usr/local btrfs subvol=@/usr/local 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /var/cache btrfs subvol=@/var/cache 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /var/crash btrfs subvol=@/var/crash 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /var/lib/libvirt/images btrfs subvol=@/var/lib
/libvirt/images 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /var/lib/machines btrfs subvol=@/var/lib/machi
nes 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /var/lib/mailman btrfs subvol=@/var/lib/mailma
n 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /var/lib/mariadb btrfs subvol=@/var/lib/mariad
b 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /var/lib/mysql btrfs subvol=@/var/lib/mysql 0 
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /var/lib/named btrfs subvol=@/var/lib/named 0 
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /var/lib/pgsql btrfs subvol=@/var/lib/pgsql 0 
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /var/log btrfs subvol=@/var/log 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /var/opt btrfs subvol=@/var/opt 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /var/spool btrfs subvol=@/var/spool 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /var/tmp btrfs subvol=@/var/tmp 0 0
UUID=e6be1fa7-1995-4ada-923b-d9d2ad44949e /.snapshots btrfs subvol=@/.snapshots 0 0
UUID=189626b6-cd9f-4ddd-8cb1-7b1b9ede8f9c /home                xfs        defaults      
        1 2


The mount command gives

sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
devtmpfs on /dev type devtmpfs (rw,nosuid,size=1932068k,nr_inodes=483017,mode=755)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,rele
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cp
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,n
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_ev
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
/dev/sda7 on / type btrfs (rw,relatime,ssd,space_cache,subvolid=259,subvol=/@/.snapshots
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=26,pgrp=1,timeout=0,mi
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
/dev/sda4 on /home type xfs (rw,relatime,attr2,inode64,noquota)
/dev/sda7 on /var/opt type btrfs (rw,relatime,ssd,space_cache,subvolid=276,subvol=/@/var
/dev/sda7 on /var/log type btrfs (rw,relatime,ssd,space_cache,subvolid=275,subvol=/@/var
/dev/sda7 on /var/lib/named type btrfs (rw,relatime,ssd,space_cache,subvolid=273,subvol=
/dev/sda7 on /tmp type btrfs (rw,relatime,ssd,space_cache,subvolid=264,subvol=/@/tmp)
/dev/sda7 on /var/lib/mailman type btrfs (rw,relatime,ssd,space_cache,subvolid=270,subvo
/dev/sda7 on /opt type btrfs (rw,relatime,ssd,space_cache,subvolid=262,subvol=/@/opt)
/dev/sda7 on /var/spool type btrfs (rw,relatime,ssd,space_cache,subvolid=277,subvol=/@/v
/dev/sda7 on /var/lib/machines type btrfs (rw,relatime,ssd,space_cache,subvolid=269,subv
/dev/sda7 on /boot/grub2/x86_64-efi type btrfs (rw,relatime,ssd,space_cache,subvolid=261
/dev/sda7 on /srv type btrfs (rw,relatime,ssd,space_cache,subvolid=263,subvol=/@/srv)
/dev/sda7 on /usr/local type btrfs (rw,relatime,ssd,space_cache,subvolid=265,subvol=/@/u
/dev/sda7 on /boot/grub2/i386-pc type btrfs (rw,relatime,ssd,space_cache,subvolid=260,su
/dev/sda7 on /var/tmp type btrfs (rw,relatime,ssd,space_cache,subvolid=278,subvol=/@/var
/dev/sda7 on /.snapshots type btrfs (rw,relatime,ssd,space_cache,subvolid=258,subvol=/@/
/dev/sda7 on /var/crash type btrfs (rw,relatime,ssd,space_cache,subvolid=267,subvol=/@/v
/dev/sda7 on /var/lib/libvirt/images type btrfs (rw,relatime,ssd,space_cache,subvolid=26
/dev/sda7 on /var/lib/mysql type btrfs (rw,relatime,ssd,space_cache,subvolid=272,subvol=
/dev/sda7 on /var/lib/pgsql type btrfs (rw,relatime,ssd,space_cache,subvolid=274,subvol=
/dev/sda7 on /var/lib/mariadb type btrfs (rw,relatime,ssd,space_cache,subvolid=271,subvo
/dev/sda7 on /var/cache type btrfs (rw,relatime,ssd,space_cache,subvolid=266,subvol=/@/v
tmpfs on /run/user/481 type tmpfs (rw,nosuid,nodev,relatime,size=387920k,mode=700,uid=48
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=387920k,mode=700,uid=1
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/sdb7 on /run/media/root/35180773-6643-49c5-86b9-6d6d29e458d5 type xfs (rw,nosuid,no
tracefs on /sys/kernel/debug/tracing type tracefs (rw,relatime)

the ls command gives the message that the file doesn’t exist. When I try to access it via dolphin, the message says I cannot enter the drive. I open a root dolphin, click on the drive and it opens. Here is the full path shown when it opens:


You can see my real name isn’t Prexy.

I apologize for not being clearer. I mentioned the issue with Chrome for two reasons: 1) to show that a default also does not survive a reboot, and 2) to show that I tried a different method (via Configure Desktop) to get the path to the Docs I want to have, not to cure a Chrome issue.

Finally, I am using the KDE Plasma 5 desktop. When I installed 42.2, it gave me two icons on the desktop: Home and Trash. That is what I was referring to when I typed “Home icon.” When I upgraded to 42.2, I thought it would be trivial to have the OS on a smaller, faster SSD and the data on a slower, larger, HD. This is all I want to accomplish. I’m sorry it is causing so much difficulty to help with this. :frowning:

I removed all fuss from btrfs subvolumes and other extras, to keep only those entries that are about real disks.
They use UUIDs, thus the link to real disk (partitions) is not obvious, but we will make intelligent guesses later.
We can then see that you have two (2!) partitions in use for Swap (Is that your intention?)
One partition is a btrfs file system mounted on /.
One partition is an xfs file system mounted on /home.
There is no entry to mount permanently any other partition anywhere (as I said, you can create that yourself or use YaST, but read on for the reason that you was not able to do that with YaST).

First, you should not say “The mount command gives”. Like the listing of the fstab, you should include the command within your copy/paste. It is there! What is easier?
And when you do that next time, please also include the prompts before and after. It is all we need, no talking, but computer facts.

Again, after removing a lot, what we see is what is mounted at the very moment the command was given. We also now see real disk partitions and thus will come nearer to you hardware.
sda7 contains your btrfs / file system (and it is mounted, very logical else you would not have a system at all).
sda4 contains your xfs /home system.
sdb7 (thus on another disk then the two above) is mounted by the desktop on /run/media/root/35180773-6643-49c5-86b9-6d6d29e458d5 for user root. I am not sure how this happened, I can only assume that root used GUI tools to let this happen. I am also not sure if this desktop mounting by root will allow other users (e.g. bill) to access any files in there, even if bill might own them.
What I am sure of is that as long as the file system on /dev/sdb7 is mounted, YaST will not be able to manage it (e.g. by creating en antry for it in /etc/fstab. Thus when you retry using YaST for crating an fstab entry for it, first umount it.

As you may understand now we do not like stories like this. We like a copy/paste of prompt, command, output, next prompt from the terminal in between CODE tags in the post. We are very able to come to conclusions ourselves.

I more or less skipped all the talking about Dolphin, Chrome, etc. I do not think they will help much here.

My assumptions:

Your system is on /dev/sda using sda4 as / and sda7 as /home (and one or maybe two partitions for swap on that disk). No idea what sda1, sda2, sda3, sda5, sda6 are used for.

On a second disk /dev/sdb7, you have at least one partition sdb7 (no idae about the others, Swap amongst them?). I assume that sdb7 contains the /home file system of an earlier installation.
I also assume that user bill wants easy and permanent access to his old home directory (and al that is in there). This home directory is /bill on that file system.

When these assumption are correct (and please try to tell me if I am wrong!), my advice would be:

  • as root create a directory inside /mnt, e.g.
mkdir -p /mnt/oldhome
  • as root, check if that file system is still mounted, when yes, umount it
umount /dev/sdb7
  • use YaST > partitioner to create a permanent mount: NO FORMATTING OF COURSE, type /mnt/oldhome in the mountpoint field, the rest is obvious imho, but ask here first if in doubt.

It should now be there (at the worst after a reboot).
I would also advice a symlink from somewhere in bill’s home directory to his old home directory. As user bill do

ln -s /mnt/oldhome/bill my-old-home

(the name is of bill’s choice). bill can then access all old stuff drilling down from his home directory > my-old-home > … Even with Dolphin.creatercre

To keep conversation to a minimum:

**linux:/home/bill#**mkdir -p /mnt/oldhome 
**linux:/home/bill#**umount /dev/sdb7 

bill@linux:~> ln -s /mnt/oldhome/billmydata 

It worked! Thank you for your patience and this solution. It makes things much easier.

I would like to make things more simple now.

Let’s put aside the thing with Chrome for the moment.

One thing that very likely could help is the output that you get in a terminal from

sudo parted -l

That would as well show if your disks have the same kind of partition table / disk label (msdos or GPT).

Another thing that you could change to your own benefit and your own improved overview, is that you mount the partitions by ‘Device ID’ instead of ‘UUID’.
Yes, OK, this means a bit of time and work, to enter YaST’s partitioner and to manually change these mount options from ‘UUID’ to ‘Device ID’ for every mount point for every partition on every disk.
But it may be worth it :wink:
I myself always change mount options to mount by ‘Device ID’ even during installation.

Don’t change anything else, don’t format partitions etc., you may loose data otherwise.

UUIDs may well be readable for computers, and in some instances they can’t be avoided, but …

Congratulations. Nice you are satisfied.

And to be consistent with your Arthur C. Clarke quote: try to understand what you did, what you got out of it (in terms of what is mounted where as what, not in terms of Dolphin) and why that s what you wanted.
This to clean up the mist of magic.

You will then, I hope, also understand while your talking about all sorts of Home/Home/home/icons-of-home were confusing. It is only about a file system that you want to be mounted permanent and access to it by an end-user that owns a subdirectory of that file system. What is inside (the former home directory of the user) is very secondary.
I admit that some background information may help in providing solutions, but here IMHO we had only background information (particulary things you see in your GUI that nobody else may ever have seen, because it is peculiar to the use bill) and very few facts in the beginning.