If you ran “dmesg > dmesg.txt” then please open a browser to pastebin - Type, paste, share., then open the file dmesg.txt with a text editor, select ALL of it, copy all of it, and paste it in pastebin - Type, paste, share.. Submit it.

That pastebin - Type, paste, share. web site will give you a URL. Please post that URL here.

We watched some Star Gate.

Sorry the late reply, had some problems with guess what? windowssss >:(

maybe i cant get this thing about the pastebin … its been an entire day opening the page and nothing happens …

so i decided to just share it with you in another way - document sharing - download dmesg.txt

hope that can help in some how

star gate is cool, but i like more battlestar galactica … pitty they are not going to do more seasons …

There is not much there wrt sound, … just this:

    8.478267] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
    8.478311] HDA Intel 0000:00:1b.0: setting latency timer to 64


  124.249540] HDA Intel 0000:00:1b.0: PCI INT A disabled
  124.483716] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
  124.483771] HDA Intel 0000:00:1b.0: setting latency timer to 64

since you have re-installed, I need to see again the output of:

rpm -qa '*alsa*'
rpm -q libasound2

and also the output URL provided by running the script:


also, do you have sound when you boot to failsafe settings?

and are you using KDE or Gnome this time around?

The work you make me do OldCPU … lol

ok hardware diagnosis:


rpm -qa '*alsa*'


rpm -qa '*pulse*'


rpm -q libasound2


uname -a

Linux linux-szwl #1 SMP 2009-10-26 15:49:03 +0100 i686 i686 i386 GNU/Linux

pastebin - Something - post number 1693015

for the dmesg.txt file … at the end i did understand lol …

i’m running KDE4 11.2

I alsow installed jakarta-commons-codec from the “get software” from … but yet no sound …

Please remove “options snd-hda-intel model=test” from your /etc/modprobe.d/50-sound.conf file, restart your PC, and then try again.

And please run that diagnostic script again:
and give the script output URL again after running that.

Note, you can not just throw anything you want in the /etc/modprobe.d/50-sound.conf file and expect things to function. I always try to be very careful in my recommendations, following documentation as much as practical.

I am sincerely sorry, i did not think that the changed made would be resilient in the pci card, please have patience with me I am still intoxicated with windows fumes where changes were only at a software level …

as you asked i have made the changed and posted them:

Your master volume control is rather low at 53%
Simple mixer control ‘Master’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 30
Mono: Playback 16 [53%] -21.00dB] [on]Can you move that up to 95% and test?

That dmesg you gave me … was that with the model=test in place? If so, you can do that again ( dmesg > dmesg.txt and upload ) without that incorrect model option in place ?

Or , … you can simply report this as a bug on openSUSE component “sound” (be sure to specify that) where there is guidance for writing bug reports here: Submitting Bug Reports - openSUSE

To support your bug report, please run with the no-upload option:
/usr/sbin/ --no-upload
which will create the file /tmp/alsa-info.txt. Please attach alsa-info.txt to your bug report.

By writing a bug report, you bring your sound problem to the immediate attention of an openSUSE packager for sound, who is also an alsa sound driver developer. If anyone can sort the problem you have, he can.

A silly question, but are you certain your laptop’s sound hardware is good?

sorry what line is that?

i re-created the dmesg.txt and uploaded it again and the url:

pastebin - Untitled - post number 1693082

the other one was actually with the options…test still in the 50-sound.conf file, sorry again for my ignorance …

the hardware actually was working great with either ubuntu 7 and opensuse 10.1 … but then i couldnt find a suitable cad software that soddisfied my requirements and gone back to windows, tonight i just installed a few new versions of cad software i want to test and since the old versions linux has improved drastically … and with windows also it works

That dmesg is full of errors with your sound system.

I recommend you raise a bug report, like I described above.

yep i did see that… will report the bug and hope for the best, would you like to be informed of the out come in time or not?

OlCPU as always you have been an unvaluable resource and an extremely good teacher …

thank you. :slight_smile:

You could post the URL of the bug report here, and from time to time I’ll drop in and look at the exchange between you and the alsa developer. Note you need to be careful to clear the “Need Info” flag in the bug report when ever you answer one of the support staff’s questions (else they will miss your response).

I do not recall your answer … did you try booting to failsafe to see if your sound worked under failsafe settings?

nothing not even in failsafe mode neither as normal user or as super user … did all the procedure of testing (speaker-test) and tried playing a wav sound … identical to normal mode …

i double checked if there were other bug reports about this,

Bug 556102 - Intel 82801G (ICH7 family) soundcard not correctly configure


Bug 546695 - no sound in toshiba nb205, 82801G (ICH7 Family) High Definition Audio Controller

that could be refered to… i will try some solutions in there before reporting another bug … as you said follow the documentations as much as possible …

or they are of no use?

Bug report number

559062 - - AC97 ICH7 no sound in any way with any type of file and program on toshiba satellite p100 240 but micrphone works

Lets hope this will help in some how!!

OK, I note the bug report:
The very first thing the openSUSE sound packager/alsa developer will do is ask you to run:
/usr/sbin/ --no-upload
which will create the file /tmp/alsa-info.txt

They will ask you to attach that file to the bug report. Why not add that NOW and save time?

Adding the dmesg output as an attachment was a good idea.

They will NOT surf this thread looking for information.

So you WILL save time by running that script and upload that text file now. I tried to explain the need to include that file as an attachment in my previous post.

I repeat, they will NOT surf this forum thread looking for gems of information.

Thank you for the suggestion, i did upload the file as you asked, Im starting to get the hang of this command line, much more powerful then windows were you had to search and hoped to find a free application patch or some sort of how to do to sort out a single little problem without choice between different solutions …

how long you think it will take them to reply? days right?

Typically Takashi responds to a thread in 2 working days. BUT if he is on vacation, or on a business trip, it could be a week or two.

… ah … I see he has responded already. He wants more info !!

His two posts:

Through a quick glance, I don’t find anything wrong.

It’d be helpful if you can get output for the working (old) kernel
so that we can compare the HD-audio codec registers.

For example, you can install the old kernel via rpm -i additionally without
replacing the running one.
… You are running 11.2 ?? Hence I am a bit confused as to what old kernel he has in mind. You could ask him to point to a repos with the kernel he is thinking of. I can walk you thru installing this 2nd kernel (while keeping your old) if necessary.

Also, it’s not clear which output doesn’t work. Doesn’t the headphone work?
Or only the speaker output, or both?

Another check is to avoid the PulseAudio (if it’s used).
For example, login as root on linux console (runlevel 3). Adjust the mixer via
“alsamixer -c0”. Then run like
aplay -Dplughw -vv /usr/share/sound/alsa/test.wav

Please reply to him in the Buzzilla thread , and NOT here.

Yes i did understand that i should reply him on the bug report page and not on here :stuck_out_tongue:

maybe he is referring to the older version of opensuse 10 and/or ubuntu 7 … but don’t know were to find them anymore … and your help to install it would be as allays “VITAL” support …

yes i am using the latest KDE4 11.2 … BTW i did state:

the sound system does not
work as out put with or without head set and onboard speakers. The microphone
works fine, this has been tested with skype,

think this is pritty clear there is no sound with speakers, head set and that the microphone does work, right?

He is reviewing a lot of data (plus a lot of other bug reports). He may have missed that. Just let him know you tried both speakers ad headphones as a regular user (and also with root permissions, assuming you tried that).

Don’t forget to remove the “need info” flag after replying.