I recently installed 11.1 on my laptop and cannot get any sound. I am using a realtek sound card that utilizes the AC97 Driver. I have downloaded the Linux driver from the Realtek site, but the installation failed. Does anyone have any ideas?


SDB:AudioTroubleshooting - openSUSE

You shouldn’t need to install a special driver.

Thanks for the reply. I figured out how to get my sound card working by running ‘alsaconf’. I have sound but lose it every time that I restart the machine. I have to go into Yast and reconfigure the card with each new session. Any thoughts?

SDB:AudioTroubleshooting - openSUSE

if instead of running alsaconf, what happens if you type:
su -c 'rcalsasound restart’
enter root password and test your sound. Does that work? If that works, we can have that run every time your boot your pc.

That worked, how do I get that command into the boot sequence.

Add the line:
rcalsasound restart
at the end of the file /etc/init.d/boot.local and save the change. If you have difficulty making that change, post and I’ll explain how to do that with a text editor.

I have tried editing the file through KWrite, but it will not let me save the file. I am the only user on this system and I thought that I would have full privileges, but apparently not.

kdesu kwrite /path/to/file

Its very IMPORTANT in Linux that a regular user, even if the ONLY user does NOT have full privileges. That is a fundamental Linux concept, and please do not take this the wrong way, but if that is unacceptable to you, then Linux is not the operating system for you. We would hate to see you go, but thats just the way it is with Linux. I have windoze friends who dislike this about Linux, and who stay in windoze which they prefer. So be it and I don’t blaime them. One should go with what works for them. This is truly a fundamental Linux concept, and operating Linux with full permissions as a user will cause problems for even the most expert and experienced guru.

You can edit the file

  • in gnome with: gnomesu gedit /etc/init.d/boot.local
    #and enter root password when prompted, or
  • in kde with: kdesu 'kwrite /etc/init.d/boot.local’

and enter root password when prompted

Good luck!

That seems to work beautifully. And as far as your comment about Linux vs. Windows, Microsoft doesn’t care if you screw up the operating system. That’s why they have all those highly trained (paid) tech support personnel. Thanks again.

Hi there, Thank you for the help on AC97 sound card but mine doesn’t work … HELP …

I followed what you suggest " su -c ‘rcalsasound restart’ " and it restarts fine but yet no sound coming out of the speakers or the headsets … I was using skype on KDE4 and the other person can hear my voice but I can not hear my caller, by the way i must do the compliments with the developers, never ever seen a clearer and better frame rate with a cam over conferencing with a 3g connection … it’s just WOW … not even in windows it works so good …

ok going through all the wiki i can find on google, very little.

On here i followed the link to the SDB:Audio TroubleShooting from there i whent to the Alsa Config TXT page but can not find any config for the sound so when to search for Intel AC97 wiki and found SDB:Intel-HDA sound problems - openSUSE and yes indeed i can not hear any sound,

In the terminal with:

head -n 1 /proc/asound/card0/codec*

i have as a resoult:

Codec: Conexant CX20551 (Waikiki)

now searching the ALSA-Configuration.txt i find nill even under root… so

/usr/src/KERNEL_VERSION/Documentation/alsa/ALSA-Configuration.txt : No Such File or Directory

and i get stuck … but i checked the sound.conf files …


options snd slots=snd-hda-intel

u1Nb.4+ZJ+hDjta3:AC97 Data Fax SoftModem with SmartCP

alias snd-card-0 snd-hda-intel



options snd slots=snd-hda-intel

u1Nb.4+ZJ+hDjta3:AC97 Data Fax SoftModem with SmartCP

alias snd-card-0 snd-hda-intel

So alias is installed and working, as I said earlier YaST does detect and installs it correctly, the Codec is checked but before i do anything really silly i would like to check with you guys what i have to do?

in YaST sound card advance options i set “fix DMA pointer” option - position fix i input 0 as auto check, its starts checking everything, looks like its fixing something afte all looks everything works but … no sound … why???

i was thinking to write in the codex in the 50-sound.conf.YaST2save as it shows in SDB:Intel-HDA_sound_problems but really do not want to do something really stupid … help, please…

OK, the CX20551 (waikki) is, I believe, also referred to as the Conexant 5047.

But before I give any recommendations, I would like to see more information on your PC’s setup.

For openSUSE-11.2, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and copy and paste the following into that terminal/konsole


It will diagnose your PC’s hardware and software configuration for audio, and it will ask if you wish to SHARE/UPLOAD the information. Please select that. It will then post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa ‘alsa
rpm -qa ‘pulse
rpm -q libasound2
uname -a

This is per the standard information request as in our stickie: Welcome to multimedia sub-area - openSUSE Forums … with that information I may be able to make a recommendation.

Thank you OldCPU, as always you help,

the resoults from:



Your ALSA information is located at

rpm -qa ‘alsa

rpm -qa ‘pulse

rpm -q libasound2

uname -a
Linux linux-72n3 #1 SMP 2009-10-26 15:49:03 +0100 i686 i686 i386 GNU/Linux

I think all the libraries are there … now?

I did a little research and i would like to try the update the DSDT of the bios maybe that helps?

According to your mixer, you should be getting sound. Is it only in Skype that you get no sound? Or do you get no sound with openSUSE?

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:

aplay -vv somefile.wav

With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Do any of those give sound ?

Thank you OldCPU …

No sound what so ever, skype, youtube, music cd, mp3, mpg4 avi … right up to flv files… nothing but the microphone they tell me works great…

resoults of the suggested tests:

speaker-test -Dplug:front -c2 -l5 -twav

speaker-test 1.0.21

Playback device is plug:front
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)                                      
Rate set to 48000Hz (requested 48000Hz)          
Buffer size range from 64 to 262144              
Period size range from 32 to 131072              
Using max buffer size 262144                     
Periods = 4                                      
was set period_size = 65536                      
was set buffer_size = 262144                     
 0 - Front Left                                  
 1 - Front Right                                 
Time per period = 5.521161                       
 0 - Front Left                                  
 1 - Front Right                                 
Time per period = 5.511937                       
 0 - Front Left                                  
 1 - Front Right                                 
Time per period = 5.511946                       
 0 - Front Left                                  
 1 - Front Right                                 
Time per period = 5.507944                       
 0 - Front Left                                  
 1 - Front Right                                 
Time per period = 5.511938                       
edward@linux-72n3:~> speaker-test -c2 -l5 -twav

speaker-test 1.0.21

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels                                             
WAV file(s)                                                                                   
Rate set to 48000Hz (requested 48000Hz)                                                       
Buffer size range from 2048 to 16384                                                          
Period size range from 1024 to 1024                                                           
Using max buffer size 16384                                                                   
Periods = 4                                                                                   
was set period_size = 1024                                                                    
was set buffer_size = 16384                                                                   
 0 - Front Left                                                                               
 1 - Front Right                                                                              
Time per period = 2.706653                                                                    
 0 - Front Left                                                                               
 1 - Front Right                                                                              
Time per period = 2.986736                                                                    
 0 - Front Left                                                                               
 1 - Front Right                                                                              
Time per period = 3.007974                                                                    
 0 - Front Left                                                                               
 1 - Front Right                                                                              
Time per period = 3.007913                                                                    
 0 - Front Left                                                                               
 1 - Front Right                                                                              
Time per period = 3.008185                                                                    

edward@linux-72n3:~> aplay -vv cartman_01.wav
aplay: test_wavefile:807: can't play WAVE-file format 0x0055 which is not PCM or FLOAT encoded

Identical as with spuer user root … no sound, no errors except for the codec for the wav file …

OldCPU i know my sound card should work, its accepted by YaST, i can play arround with the wixer in YaST, alsa reveals it, i have one of the latest kernels installed … i followed all the forums, wiki and any other peace of information i could find … and over all this in windows it works great (as usual) so no hardware problems … really going crazy here … i am going to try ubuntu enhanced for laptops and see if that works, if not that i am stuck as a stone … but it is very strange this cant work since intel after the introduction of the HD drivers is automatically setup by any linux … shall i try a hammer?? >:)

We are into bug reporting territory here, even if we get this working.

Lets see if we can get more information. Please type as a regular user in your home directory:

dmesg > dmesg.txt

then open dmesg.txt with a text editor and paste its contents to pastebin - Type, paste, share. and provide here the URL. Just the URL. Maybe that file indicates the problem.

What we know is the speaker-test above appeared to run, but no sound came out. We checked your mixer settings, and they looked ok. This is a laptop, so its not possible to have the cables mis-wired. You did not state whether you tried with a headset, so that is an unknown.

I have also read these P100 laptop’s have annoying BIOS dsdt problems, that impact sound. Some of the earlier kernel versions had problems with this make, then an update to the kernel fixed it. But has the problem come back with the more recent kernel? I don’t know.

Lets also make an hypothesis (that we will try to prove wrong) that the auto probe of alsa failed and see if forcing the alsa configuration upon alsa start will help. So I note for the CX20551 (waikki) , also referred to as the Conexant 5047 the following model options can be applied (but only one at a time) from alsa 1.0.21 hd-audio-models.txt file:

Conexant 5047 
  laptop	Basic Laptop config 
  laptop-hp	Laptop config for some HP models (subdevice 30A5)
  laptop-eapd	Laptop config with EAPD support
  test		for testing/debugging purpose, almost all controls
		can be adjusted.  Appearing only when compiled with

On openSUSE-11.2, lets start with the model option “laptop” from that list. So lets upon up an editor with root permissions to edit the file /etc/modprobe.d/50-sound.conf as follows:

  • in gnome type: gnomesu gedit /etc/modprobe.d/50-sound.conf

  • in kde type: kdesu 'kwrite /etc/modprobe.d/50-sound.conf’
    and enter root password when prompted and add a line at the start of the 50-sound.conf file so that the file looks like:

options snd-hda-intel model=laptop
options snd slots=snd-hda-intel
# u1Nb.4+ZJ+hDjta3:AC97 Data Fax SoftModem with SmartCP
alias snd-card-0 snd-hda-intel

save that change and then restart your alsa sound driver with su -c ‘rcalsasound restart’ entering root password when prompted for a password and restart your mixer and then test. That may make your sound worse. It may help.

If it does not work, then do the same as above, but this time replace the word “laptop” with the next item in the list which is “laptop-hp” and then save the change, restart alsa as described above, and then again restart mixer and test sound.

Do that for each item in the list until one works, or none work. If none work, remove the line, save the change and then let us know.

Good luck.

I am writing you from ubuntu at the moment to test if this works, well surprise not even here it works not as a live cd or installation … did even the updates and all …

i had to reformat all the computer and now i lost every single file i had … this is not going very well… i am getting very frustrated with this … I yet haven’t tried what you suggested as post 17 … btw this ubuntu used to be amazing, now it feels like one of those toys for kids, sorry not because we are on here but kde4 has a real professional and advance look, feel and usability … i would be really upset if i cant get to use it and have to turn back to windows :frowning: … maybe i should of used an old laptop instead of my main one, i know this but the promisses sounded like a direct swap, i believe there should be more information yet to get to the new users coming from a windows “silver plate served” world and not just the usual how to, but how to double check on hardware and software comparison and problem shooting … all in one place instead of all over the internet … sorry just unloading some stress with you … ok back to reformatting the laptop … nothing more the lose is there?:\

i will post resoults as soon as i get 11.2 installed … or maybe i should you an older version like 11.1 or even 11.0?

I’m also rather sorry to read that you could not wait. It took me a while to type and then proof read the above. … and now its back to square -1.

Oh well. … best wishes to what ever direction you go.

Me? I think I’ll just go watch a TV episode.

So happy now, im back in KDE4 :smiley: … now down to business …

  1. hows that thing about type paste and copy? I did look inside the dmesg.txt file and read a lot of errors for output … I think as usually you find the right way …

but i will also try the other procedures you gave me “trying to prove alsa is right” …

so here it goes …

i added the line options snd-hda-intel model= (variation on list) to the 50-sound.conf file wile resetting its resoults are:

the purest silence … :’(

As you asked all the test are repeated at least twice with and without headsets and external microphone … no difference at all … I told you I’m going "CrAzY’’ after this problem …

What your watching mate? :slight_smile: