AC'97 sound adapter not working in ALSA

Hello - Was hoping somebody could help me with this problem I am having with my sound adapter in OpenSUSE. My hardware seems to be recognized by ALSA, and what I think are the appropriate kernel modules are loading, but no sound comes out, with either speaker-test, or anything else. Volume levels seem fine. I’m not sure what else to try.

Here’s a link to the posted results from the ALSA troubleshooting tool:

I’ve tried all relevant troubleshooting steps that I am able to find, without success. Any help would be greatly appreciated.


Sometimes the sound test in the audio troubleshooting guide does not work, and one has to try the following sound test:speaker-test -c2 -l5 -twav

I also note from the script output:Simple mixer control ‘External Amplifier’,0
Mono: Playback [on]
Did you try switching the external amp off?

I also note an update to the ALC850 (which is on your PC) to provide 8 channel output support (in 1.0.17 of alsa) : Search results - AlsaProject

If necessary, we could try an alsa update (I can point you to some rpms with a newer alsa precompiled).

Thanks for your quick reply!

speaker-test -c2 -l5 -twav didn’t have any better results, unfortunately. I can find where I can mute the external amplifier, and tried that, without any change. Is this what you mean by turning it off?

I searched for an RPM for a more recent ALSA, I didn’t find 1.0.17, but I did find 1.0.18-8.5, and installed that RPM. Unfortunately, this didn’t help, either.

I re-ran, and got these results:

Which shows version 1.0.16rc2, even though YaST2 shows 1.0.18-8.5 installed…

It could be you installed the wrong rpm.

You need to be precise in the rpm you install, and not just install “any” alsa rpm (which is why I volunteered to point you to some good rpms), where the link to the rpms is also in the audio troubleshooting guide, and I suspect you completely over looked that.

That link leads you here: Alsa-update - openSUSE where in the case of your PC, you should open a gnome terminal or a kde konsole and with your PC connected to the Internet, type “su” (no quotes, and then enter root password) and then send the following commands in sequence:

zypper ar multimedia 
zypper install alsa alsa-utils alsa-tools alsa-firmware libasound2
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

Then restart your PC and test your sound.

Note I “guessed” at the alsa rpms you should update, since you have not provided a list of what alsa rpms you have installed. But the rpms I listed above should definitely be updated (so do NOT omit any of them in an update).

If that does not work, then I need to re-examine what you have installed, as you have already indicated you possibly installed a wrong rpm once. So after that alsa update, please then provide the output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2

Thanks again for your help. I tried the steps you provided, but still am not having any luck. The output you requested is:

sheep@linux-h56d:~> rpm -qa | grep alsa

sheep@linux-h56d:~> rpm -qa | grep pulse
(no output)

sheep@linux-h56d:~> rpm -q libasound2

Are you certain your sound hardware is functional? Does the sound work under another Linux distribution (ie LiveCD ? or under MS-Windows? ). Also is cabling is correct? sound is switched ON in BIOS ?

If you are certain that is correct, and that your mixer settings are correct, then everything else I see is correct. In that case, write a bug report.
Submitting Bug Reports - openSUSE

I had Vista on this computer a week ago, and the sound worked, though I cannot rule out the possibility that hardware failure happened to coincide with reinstallation, it seems unlikely…

I have had Linux on this computer in the past, and the sound did work, which makes me wonder if some update along the line has broken compatibility with my sound hardware. I tried the Kubuntu LiveCD, and sound did not work for me with that distro, either. I’d like to try an older device driver/kernel combination, say one from a year back or so, to test the possibility that some kernel/driver update along the line broke my sound functionality… Do you know where I could find such a thing?


Figured out the problem. Indeed, it was hardware failure somehow coinciding with when I installed Linux.

The line out audio jack is broken, somehow. In Windows, I did not have sound until I used the Realtek application which allows me to re-map the line out jack to another audio jack. Once I did this, my sound worked.

So I guess the only question I would have for anybody who’s familiar with these Realtek AC’97 onboard sound adapters would be is if there’s any way to re-map the audio jacks in Linux, like you can in Windows?