About Opensuse 11.4 KNetwork Manager

I have heard about the bugs of Knetwork manager in all the KDEs (Be4 KDE 4.5, I have not tried KDE 4.6 yet). It seems that it has got a solution now. If yes, what are the steps to solve it?

This is a mystery to me
Never had any trouble with it, ever.
I do know some use the plasmoid instead and prefer it though.

Most of them are mystery tales by people who don’t know how NetworkManager works. Knetwork manager is working well in the standard openSUSE 11.2 KDE, which is definitely lower version that 4.5

Best regards,

The problems appeared when I was running the iso image of 11.2 in my virtual box while I was using windows. I could not connect to Internet via Knetwork Manager with my ADSL PPPOE connection. I have got an account and a password the ISP gave me and I input all the information into the manager, then I clicked “apply”, and I closed the window. After that I clicked on the icon of network manager but still only found the current eth0 connection without the new ADSL connection I had just established! I was forced to use wireless, which is annoying because I have to do a lot of changes on my hardware… I asked the users on KDE Forum and got the answer that the Knetwork manager will be never solved and I must use the network manager by GNOME… It seems that other distros of KDE has got the problem before 4.6, but I have not tried OPENSUSE. I hope that it will be a little different.

So openSUSE was virtualized or Windows ?

Best regards,

My guess is that if you’re having problems about a specific scenario, you’ll have to provide details to identify exactly what the problem might be.

In any case, you should know that any connections configured in Knetwork Manager (which BTW AFAIK is only a KDE version of the GNOME Network Manager) is applied only when that specific User logs in and will be disconnected when that User logs off. If you want a PPoE connection upon system bootup and still active even when Users logoff, you’ll need to configure in YAST. Also, at least in the scenarios I’ve dealt with it only takes one machine or logged on User to establish the Network connection, all others should be able to use a connection that’s already configured and working.


Thx, Tony and all above. The problem is not that, exactly. I mean, when I have established a new ADSL PPPOE connection and clicked the “apply” button to activate it, I still couldn’t find it when I want to choose it in the menu after I clicked the network icon on the taskbar. The connection didn’t appear! That’s the problem.
I was told that it will never be solved (That means I will never be able to choose the new connection I have just established) and I tried both in Virtual and in Livecd, sometimes even when I have installed the OS through livecd. So I was disabled to internet. I don’t know if the Opensuse KDE 4.6 has made solutions or not.

So did you try the plasmoid networkmanager?

No. But I did not know what plasmoid network manager is and I do not know where to find it or install it… I have gotten used to ubuntu. Is plasmiod network manager built in OPENSUSE without any extra installation (that may request internet)?

Open Yast > Software Management
Search for: networkmanager

In my list, right at the bottom: plasmoid-networkmanagement

Check to install it, it will remove the current network manager.

I would reboot when done:
When you login again the old network icon will be broken, delete it.
With widgets unlocked, click the panel cashew to add widgets and add the networkmanager icon
Lock widgets

Configure the network

Wow, it seems so easy! It just like the operation in ubuntu software center! I am going to try it absolutely.

What is more when using virtualized openSUSE You don’t have to connect to the ADSL at all to get internet. Just connect to the ADSL with your host OS, which I understand is Windows and set up the virtual openSUSE NIC in the NAT mode. After that just create a simple profile with DHCP and You will be good to go.

Best regards,