About kde, kmix and pulseaudio

I just enabled pulseaudio in kde-settings multimedia, and at first there was no sound at all anymore: I considured to install pavucontrol from xfce… but I remembered to have kicked master channel from kmix as it did nothing (choosed pcm as master). With right clicking kmix and choosing channels, enabling master, I saw : MUTED
Enabling “Master” as master again did enable pulseaudio sound for me, but sliding the volume does nothing now :frowning:

Pulseaudio has some extra features, is used in most distributions, is getting matured now, but:
Kmix having a “Master” which can mute but not change volume is a bug.

Have you tried enabling it in Yast>Sound>Other>Pulse Audio Configuration?

You did not fully read my report ?
Pulseaudio runs out of the box, but I had the muted “Master” channel hidden due to his (the channels) disfunctionality.

[edit] Uups: There is a YAST->Sound->Other which has not Pulseaudio activated - But Pulseaudio runs … ???

… Really that button “Other” is little/hidden - everybody overlooks as kind of [Cancel|Ok]

Did I read your post. Yes. Did I understand it. Probably not. I’ve always struggled to understand sound in Linux. All I know is PulseAudio sound does not work for me as regular user AND when enabled it seems to cause graphic problems on login. That seems bizarre. How can a sound app cause graphic problems?
My system sound:

Model: nVidia MCP51 High Definition Audio
Kernel Driver: snd_hda_intel

Curiously as mentioned as regular user in KDE System Settings PulseAudio does not play a sound. However if I run ‘kdesu systemsettings’ it DOES play a sound as root… Wonder what that means? Permissions problem?

See this bug for some newer alsa and pulseaudio rpms that fix the muting problem.


The link to the packages is in comment #25 and the instructions are in comment #27.