Ableconn ASMedia 1062 PCIe eSATA card problem


Does anybody have successfully used Ableconn PEX-SA134 4-Port eSATA III 6Gbps PCI Express Host Adapter Card ?

I added the card to HP z820 box to be able to connect my old Areca ARC-5040 RAID (ROC) enclosure. The enclosure has 8 drives (4 Tb each) paired in 4 mirror RAID’s. When I boot I can see that BIOS detects those RAID discs as 4 separate 4Tb drives. But when system boots after that I get errors (dmesg):

3.488048] ata19: SATA max UDMA/133 abar m8192@0xef180000 port 0xef180100 irq 32
8.840042] ata19: link is slow to respond, please be patient (ready=0)

13.520047] ata19: COMRESET failed (errno=-16)
18.872048] ata19: link is slow to respond, please be patient (ready=0)
23.552046] ata19: COMRESET failed (errno=-16)
28.904049] ata19: link is slow to respond, please be patient (ready=0)
58.604040] ata19: COMRESET failed (errno=-16)
58.605353] ata19: limiting SATA link speed to 1.5 Gbps
63.656039] ata19: COMRESET failed (errno=-16)
63.657347] ata19: reset failed, giving up

and same set of messages for other 4 drives (ata24,ata24,ata26).

“errno=-16” means EBUSY (“Device or resource busy”).

I tried to boot with different kernels, 4.4.114-42 (Leap42.3 latest kernel), 4.9.79, 4.14.16, same errors. The controller requires ahci driver which compiled in kernels. There are 2 SATA ASMedia controllers detected by kernel (lspci):

08:00.0 SATA controller: ASMedia Technology Inc. Device 0625 (rev 01)
09:00.0 SATA controller: ASMedia Technology Inc. Device 0625 (rev 01)

The other installed hardware:
2x Xeon E5-2690 v2
on-board LSI SAS2308 controller
3 ssd SATA ||| disks (Intel 120Gb,Seagate 480Gb,Micron 512Gb) connected to onboard LSI SAS2308 controller
1 video card NVIDIA Quadro K6000

Does anybody have an experience with this sort of problem and/or ASM1062 controller based cards?
What is COMRESET command ?
Maybe there are kernel /module parameters that has to be passed on boot to make OS see the drives ?

Thank you in advance for any tips/hunches/advises/info …

p.s. of course one can migrate to SAS enclosure, it would require a new enclosure and new SAS RAID controller card (onboard SAS2308 controller is for software RAID) but that would a costly upgrade …

I have a PCIe 2 port card on Tumbleweed;

03:00.0 SATA controller: ASMedia Technology Inc. ASM1062 Serial ATA Controller (rev 01)

I run SATAIII cables, are you running old cables, are all hooked up ok… normally that’s an indication of a degraded cable, connection…

Swap the cables around, make sure they are seated properly.

Thank you for reply.
I connect ARECA enclosure with workstation using eSATA to eSATA cable. I will get a new one tomorrow and check if it fixes the problem.

Although, I do not have the same problem when connecting with the same cable to my old box which has EVGA Classified SR2 motherboard that has JMicron362 onboard controller with port multiplier. But will try anyway, thank you again.