AAAARGH! Synaptics touchpad will NOT stay turned off

Laptop here is HP 635. OS is 11.4. 64 KDE 4.6

I’m at wits end here. I’ve tried everything I know or have been able to find here to turn my touchpad off and keep it off. Ran synclient Touchpadoff =1. edited /etc/x11/xorg.conf.d/50-synaptics.conf to set “Option” “Touchpadoff” “1”. Installed gsynaptics. Ran it and deselected “enabled”. Each of these things will turn the touchpad off. But after a couple of minutes I find it’s enabled again. I’m a touch typist which puts my right thumb way to close to the pad when I’m typing. (I hit it three times while typing this)
What can I try?

> What can I try?

tales of both successes and failures here:“HP+635”+linux+“disable+touchpad”

openSUSE®, the “German Engineered Automobile” of operating systems!

Since you use KDE, you should be able to use the KDE controls
Personal Settings → Input Devices

I have mine set to automatically turn off the touchpad if there is usb mouse.

If it accepts the setting, but the setting still does not work, then install “hal”.

If all else fails you can try a dirty, nauseating hack. Copy the lines below to a text file, make it executable and drop it in ~/kde4/Autostart. Change the 120 to the number of seconds you want between touchpad-disabling-command executions, if necessary. Restart KDE.


while true; do
  sleep 120
  <substitute this line with your touchpad-disabling command>

Thanks for all who replied. I never did find KDE Controls, but in my exploration I did find the Synaptiks touchpad applet. I kind of knew that the Synaptiks daemon was running, but I didn’t know how to access or configure it. Found he applet and added it to the taskmanager panel. It allows my to toggle the status of the touchpad.