A warning if 42.2 is installed and a linux raid is installed.

When ever I have installed an upgrade I always import the partitioning. My previous install was 12.3 and on that I chose to map /home to a raid1 set up and all worked out without any problems. When I imported the partitioning installing 42.2 it’s totally disregarded where I had placed /home and just put it at the root of the boot disk. It put other partitions where I wanted them to be.

This has wasted a lot of time as I assumed home was where I wanted it to be but couldn’t find any mount points for the raid. Some one on another forum suggested using

df /home/

to see where it actually is. Now all is clear. Not where I wanted it to be so this is entirely correct.


ohn@dhcppc1:~> lsblk
NAME    MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda       8:0    0 119.2G  0 disk  
├─sda1    8:1    0   195M  0 part  /boot/efi
└─sda2    8:2    0 119.1G  0 part  /
sdb       8:16   0 232.9G  0 disk  
├─sdb1    8:17   0    10G  0 part  [SWAP]
├─sdb2    8:18   0    10G  0 part  /var
├─sdb3    8:19   0    10G  0 part  /tmp
└─sdb4    8:20   0 202.9G  0 part  /home/home2
sdc       8:32   0 232.9G  0 disk  
└─sdc1    8:33   0 232.9G  0 part  
sdd       8:48   1 232.9G  0 disk  
└─sdd1    8:49   1 232.9G  0 part  
  └─md0   9:0    0 232.9G  0 raid1 
sr0      11:0    1  1024M  0 rom   

I’ve no idea what sr0 is. It might be for built in soft raid or something to do with the usb3 card reader / sata dock I have plugged in. If soft raid HP suggest using the linux one.

John

sr0 is normally the (read-only) CD/DVD player.

Thanks. I had wondered.

I deleted the raid via YAST2. Interesting aspect. Despite not being used for anything this messed up KDE. It generated greeter error messages when I tried to reboot. :wink: It also wanted me to report the error so that it could be fixed - then reported that it couldn’t because the greeter was broken. :open_mouth: I sometimes think these kde people are dangerous. A console reboot was ok. One application wouldn’t fire up after the raid was deleted but all others were ok. That one and kde were ok following the reboot.

I am a none pc software person so tend to be a bit cynical about bugs and features as I have been there many times often with others bugs.

I’ve built the knew raid with YAST2. 2x ! tb wd nas red’s. Mdadm reckoned 150min to sync them but I’d say it was under or not much over 100min in practice. I didn’t know that these drives were 5,400rpm but large 10k server drives are way too expensive at the moment. Large read rates are not far short of of what wd claim. 140mb/sec. They claim 150. I hadn’t looked but that sort of number for my data files and software settings etc should be acceptable. The caches on the disks are big enough for any writes I am likely to make by a factor of 3.

One odd thing I have noticed is that I am pretty sure but need to check that the drives are on a sata III controller. They are being run at sataII speeds even though they are sata III drives. Not that this would make much difference but I wonder how that could be corrected.

:\Looking on the bright side my home is on the ssd so just need to copy across and remap and don’t have to set up bookmarks and a number of other things again.

I followed this guide to build the raid. It’s a bit more comprehensive than the one for 42.2.

openSUSE 42.1 Installation

Only deviation was double clicking each drive from the main view to obtain the partition view for each and clone isn’t worth bothering with. I classified the drives as c and d assuming this might provide some sort of labelling. It hasn’t so far so not sure what it does. ???

The raid is currently mapped to /homeA so it should be a simple matter to copy across, alter fstab and reboot. If not please tell me. Fstab currently looks like this


/dev/disk/by-id/ata-PLEXTOR_PX-128M5Pro_P02306101219-part2    /    ext4    acl,user_xattr 1 1 
/dev/disk/by-id/ata-VB0250EAVER_Z3TCNPGW-part1    swap    swap    defaults 0 0 
/dev/disk/by-id/ata-PLEXTOR_PX-128M5Pro_P02306101219-part1    /boot/efi    vfat    umask=0002,utf8=true 0 0 
/dev/disk/by-id/ata-VB0250EAVER_Z3TCNPGW-part4    /home/home2    ext4    noacl,user_xattr 1 2 
/dev/disk/by-id/ata-VB0250EAVER_Z3TCNPGW-part3    /tmp    ext4    acl,user_xattr 1 2 
/dev/disk/by-id/ata-VB0250EAVER_Z3TCNPGW-part2    /var    ext4    acl,user_xattr 1 2 
/dev/md0             /homeA               ext4       acl,user_xattr        1 2

I’m assuming I will just need to change homeA to home and reboot.

John