A usb port is not working...

I have a 16 Gb NTFS usb stick, which I have used since a while.
But now, it’s not working at all in one of the 4 usb ports the laptop has. The other 3 are still functional, but on that one the system does nothing, as though not recognizing the device.

On this laptop I have dual boot with Windows 8, so I tried the usb stick on Windows 8 but here the usb stick worked normally! I also tried the stick on other PC’s and it also worked.

But I tried with another usb stick, a 4 Gb FAT32 one, and this one does work normally with all 4 ports of the laptop on openSUSE.

So I’m having problems with that usb port on openSUSE with the NTFS stick.

Can someone help me?

Odd maybe removed it without first unmounting it for safe removal and it thinks it is still mounted. Try a reboot if you have not already.

try a check disk

Rebooting is useless.
As I said, I don’t think it’s the usb stick itself. It’s that port that is not working on openSUSE at least with that usb stick. With a FAT32 one it’s working.
How do I do check disk? What good would it be for?

check disk could be resolve any errors of the filesystem…try with the command fsck
get the su privileges
and use this code

sudo fsck -p /dev/sdbx

where sdbx is your usb device

have you tried?