A rant about updates.

Getting to work on mondaymorning I switched on my PC, which started booting normally, until it gave me a dark, sleeping screen and no keyboard. Annoying, at 7:30.
I next booted into safemode, and while searching for causes, realized I had seen a xorg-x11-Xvnc update on friday afternoon. It turned out that, WITH NO WARNING WHATSOVER, an update of xorg-x11-Xvnc actually updates the xorg-x11-server package as well. Since I ran the ATI-proprietary fglrx driver, this destroyed my X-server capabilities. Why does this type of update happen without user notification?
I reverted back to the previous version of xorg-x11-server and xorg-x11-Xvnc, that worked perfectly fine up until the moment I switched of my pc early friday evening, and lo and behold! This DID NOT! restore functionality. Now I was getting pissed.
In the end I had to completely uninstall fglrx, rebuild my xorg-configuration to work with the radeon module, and edit kwinrc to disable compositing since otherwise kde would no longer start, to get back to a sort of working system. Sort of working, because I now miss functionality I had working to full satisfaction, and I now have a display that twice a minute blacks out for a few seconds before restoring the desktop. THAT is extremely irritating, and happens both with the old (7.4-61.63.1-x86_64) AND with the new (7.4-61.64.1-x86_64) xorg-x11-server.
Questions.
Why does stuff get updated without usernotification?
Why does functionality not get restored when backing out of forced changes?
Why does the radeon-driver suspend my display for seconds at a time at least twice a minute?
Why do I still have a command_not_found_handle in my rootshell even though I explicitly told YaST to NOT EVER EVER UNDER ANY CIRCUMSTANCE install that utterly annoying package?
I must admit: I am not looking forward to the next experience of this type, and thanks to the “flashing” display problem I am at present not at all happy working with this system.
Thank you for listening.
Krelis Krotenkoker
(running openSUSE 11.2 (x86_64) VERSION = 11.2 on a HP AMD AthlonII, 2GB RAM,
onboard ati rs880 9710, kde 4.3.5 r0)

Why didn’t you just reinstall you gfx-driver? Why didn’t you make a backup? Why don’t you use a better supported gfx-card?

Period. I hate rants.

I can sympathize with this point. However, if you use YaST>Software>Online Update to apply the updates instead of using the updater applet, you will easily be able to identify all the packages affected by the update.

I have an nVidia - you should have one too.

As I said: this was at work. Where I do not have the luxury to be picky about what hardware my employer supplies.

Thank you for your suggestion. I will do so in the future. And thank you for trying to be helpfull where I just needed to let of steam.

KrelisK wrote:
> I just needed to let of steam.

i’ve been real successful in avoiding the steam for quite a while
now…am getting close to a year with no way for the “updates” to kill
my system…sure is nice to be able to avoid all the pain!!


DenverD
CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]