A Quick Bittorrent Guide (with screenshots)

**A Quick Guide to Setting up Ktorrent **

First let me say, this is not a comprehensive guide and was written for OpenSuse 11.1 using KDE4.2

Start ktorrent and go to settings – configure ktorrent – Network
You need to enter your Port(TCP) and UDP tracker port. You can use the default or select your own as in the image. Write them down.


Ktorrent Network settings



Now open Yast - Security and Users and go to Firewall
Yast Security and Users


Then to Allowed services
Yast Firewall go to Allowed Services

Then the Advanced button. Brings a box. Here add the port numbers you selected for use in ktorrent or Vuze and wrote down!
Allowed Services – Advanced


If you have a router, then the same ports need to be opened there too. The link here should help as it covers a wide range.
Port Forwarding for Routers
PortForward.com - Free Help Setting up Your Router or Firewall

Alternatively look in the configuration/options section of both Vuze and KTorrent for the ‘uPnP’ plugin. If your router supports uPnP and it’s enabled all you have to do is enable the plugin.

The supplied pics are so low resolution that they are almost impossible to read


If you enable the webui plugin, take the same steps for opening ports but now for port 8080 (TCP only) for kTorrent.

For Vuze the port depends on the plugin you use as there is more than one web backend.

The torrent clients are so unfortunate that Vuze is heave like hell while ktorrent looks good only on KDE 4 DE. I propose to add Transmission for a Gnome DE. Greatest ever:)

so i did everything till i got to the router i see were i am suppose to set the ports but i guess i need to have a static ip adresse how do i do that…

First, run
ifconfig (as root) in a console and leave the window opened while you go to:
Yast - Control Center > Network settings

On the first tab (Global options) set it to ifup, on the second tab edit the settings of the network card to reflect those that you find via ifconfig, once you’re done hit ok and reboot.
(Okay… it’s linux and I’m sure there is a command or some other steps to take where you don’t have to reboot… but I don’t know 'em)

Alternatively, look in your router to see if it has a setting to link your MAC address (unique address of your network card) to a set IP.
Your mac address is listed with ifconfig as well, called “HWaddr” there instead.

I think you are mixed up. When you say static IP - I’m sure what you are meaning is your LAN IP.

Each device that connects to a router is assigned an IP on the LAN either by DHCP or by rules in the LAN IP setup according to the MAC address of each device.

For bittorrent you are better not to use DHCP assigned LAN IP. But assign each device that connects an IP in a range.

For netgear the router IP is:
so the first device that connects will be
and so on…

In LAN IP setup in the router you can specify a range, so say you have 8 possible devices that may connect the range will be starting from and end at 0.9

You assign an IP in the range to the MAC of connecting devices, and for wireless you have to setup those in the access list in wireless settings.

You don’t have to do it this way, DHCP is possible but I don’t find it works as well. You still need to add the ports required by your torrent client in to the firewall rules and select allow all.

**I have added some better quality screenshots of firewall and torrent config:
Client Settings Vuze


  1. Yast Firewall

  2. Firewall Opening Page

  3. Allowed Services (Advanced Button Lower right)

  4. Adding Ports in Advanced

p.s. to oldcpu
Lee, if you want to edit the original part with the new url’s - please go ahead.

mistaken post

Even with the The openSuSE firewall turned off Vuze fails the NAT/Firewall test.

Port is properly forrwarded from LinkSyS router. I triple check that it had not changed at the Router. I used this computer with Azureus/Vuze before When I ran Mandriva Linux and it worked fine.
The internal IP address hasn’t changed and have been checked using ifconfig. What other paranoid security setting is there I have to configure so I can use bittorent again?

Look at it logically. If you turned the firewall OFF - then the problem is even less complicated. Though I don’t recommend leaving it like that.

In Vuze you have to set a tcp and a udp listen port
open the same port in your router to your LAN IP and also open the same ports in the Suse firewall.

In the router -Make sure you have a fixed LAN IP assigned to your MAC and that you have it as a rule in the Firewall Rules before the default Out/Allow/Any - and the IN/Block/Any

It answer was pretty simple. I had run and configured KTorrent first in case I decided to use it at some time. KTorrent didn’t release the port when it exited. so whenI shut KTorrent down the port was still not available. So there was no way Vuze/Azureus could use the port. The firewall/NAT test was failing from that. It had nothing to do with any other process or settings.

If you are running a router with a hardware firewall (packet filtering actually) running a firewall on your computer is redundant. It is a good idea but it is redundant.

What is the situation for Monsoon (Gnome bittorrent client)

In the Preferences it has Listen Port = 34807. Does that mean that I enable UDP 34807 in Yast firewall and that I forward in my router UDP 34807 to the IP of my client. Or do I ignore that and use Carl’s recommended 54000.

Next question: what TCP port do I forward through the router and allow in Yast firewall? Is it 34807 or is it Carls’ recommended 59000 or something else.

John, the 54000 range is a range used and recommended in some BT quarters, it’s supposed to be better if your ISP uses control on default ports.
Use whatever, well you know what I mean.

UDP is only needed if you allow UDP trackers. You can just as well block UDP ports and only allow TCP trackers and you won’t be missing much since 0.01% of all torrents use UDP only tracking, though the majority of trackers that offer UDP also offer TCP (as it’s a requirement of the BitTorrent protocol) and virtually always on the same port so you’ll only have to replace udp:// with http:// in the tracker’s URL. Although UDP has a much lower overhead, puts less strain/load on the tracker server and is simpler than TCP, lots of torrent clients don’t support it. TCP is also a bit more reliable than UDP when it comes to ratios updates. Also you can’t restrict clients on the tracker side, while it’s possible with TCP. There are a few other “negative” things about UDP trackers, like no support yet for IPv6 and a few others.

I should know. I run three open public torrent trackers and a tracker redirector, all running on Google’s App Engine except but one of the trackers which runs on my own machine. I’m also part of the Trackon team - http://www.trackon.org/ :slight_smile:

Thanks caf4926 & microchip8.

I thought about all that and in the wind up I went with the value that Monsoon seems to suggest, 34807, and forwarded tcp/udp for that to the client and through SuSEfirewall2 as well. And I ticked upnp in Monsoon’s settings and the router. And the RC1 Gnome CD for 11.2 is nearly in the nest.