A problem with opensuse 11.1 Repositories

I am having a problem with opensuse 11.1 repositories. I just installed opensuse 11.1 and I want to update it. I used the command ‘zypper update’ it didn’t work. I used yast to do refreshing, after a while an error message poped up stating:
Download (curl) error for ‘http://download.opensuse.org/update/11.1/repodata/repomd.xml’:
error code:
error message: couldn’t connect to host

This is the same for all other repositories (opensuse distribution oss & non-oss)
So, can you help me with this issue?
Thank you

> download.opensuse.org/update/11.1/
> Download (curl) error

the address you give above will automatically route you to a mirror
somewhere, hopefully nearby…there is probably a routing problem,
right now…

which usually gets sorted out by itself, with a little time…

try it again in a while…if that doesn’t work you can pick a close
by mirror from the long list at:

but (sorry) i can’t tell you exactly how to enter that address in YaST


Thank you very much for your reply. I tried last night and today morning with the same error. I will give it a while and then I will try to pick a mirror as you listed in your reply.

Thank you again.

I tried it again with no luck. I used one of the HTTP links, also never worked. But I used another site with FTP link and it worked :slight_smile:

Now I don’t know exactly was it because of the site I picked or because of FTP instead of HTTP?
Can I get an answer for this?

Thank you

> Can I get an answer for this?

maybe you are behind a corp/school firewall that has blocked
something…or, or or or…like, have you disabled IPv6?

if FTP works, use it…


I have a similar issue with 11.0

Updates were working fine on a home server that has basically been setup and just monitored (ie I don’t put it through regular system changes etc.) Then one day it stopped.

Same solution: switching to FTP works fine. I tried turning IPv6 off and on, checked the firewall and router and still no joy. So for now, I’m sticking with that option.

Gentlemen, it would be better if you posted in the relevant forum.Posting in the **forum usage and support **section,which is for problems with the forum software, will not garner the necessary answers to alleviate the problem. Please, post in the correct forum.


I’ll vote with deltaflyer on this. I still don’t get what isn’t
understandable about the heading “Forums Feedback” :slight_smile: FYI folks get their
openSUSE issues handled more quickly and with more relevant discussion
when they post in the HELP section.

Sorry malghwell…don’t mean to pick on you. :wink: Good luck in your
request. I often don’t read everything I should before jumping into the
fire either. I’m just hoping someone else reading this thread in the
future will be lead to post their message in the right place to begin with
so the answer they want will get to them faster.

Kim (7/10/2009 1:16:27 PM Mountain)